aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2024-05-15 01:15:04 +0200
committerLucio Sauer <watermanpaint@posteo.net>2024-05-15 01:27:42 +0200
commitb41084798596ef12a11d449cd55d3bdba5886738 (patch)
tree04c70cb00e1215388323505feafd211a55a21cb6 /sys-apps
parentnet-im/gajim-plugins: enable py3.12 (diff)
downloadguru-b41084798596ef12a11d449cd55d3bdba5886738.tar.gz
guru-b41084798596ef12a11d449cd55d3bdba5886738.tar.bz2
guru-b41084798596ef12a11d449cd55d3bdba5886738.zip
sys-apps/hex: speed up cargo SRC_URI generation
Signed-off-by: Lucio Sauer <watermanpaint@posteo.net>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hex/hex-0.4.2.ebuild57
1 files changed, 29 insertions, 28 deletions
diff --git a/sys-apps/hex/hex-0.4.2.ebuild b/sys-apps/hex/hex-0.4.2.ebuild
index a17b1d1bfc..4b765bcc50 100644
--- a/sys-apps/hex/hex-0.4.2.ebuild
+++ b/sys-apps/hex/hex-0.4.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Auto-Generated by cargo-ebuild 0.4.0
@@ -6,39 +6,40 @@
EAPI=8
CRATES="
- ansi_term-0.11.0
- ansi_term-0.12.1
- assert_cmd-1.0.1
- atty-0.2.11
- bitflags-1.0.4
- clap-2.33.3
- difference-2.0.0
- doc-comment-0.3.3
- libc-0.2.47
- no_color-0.1.0
- predicates-1.0.5
- predicates-core-1.0.0
- predicates-tree-1.0.0
- redox_syscall-0.1.50
- redox_termios-0.1.1
- strsim-0.8.0
- termion-1.5.1
- textwrap-0.11.0
- treeline-0.1.0
- unicode-width-0.1.5
- vec_map-0.8.1
- wait-timeout-0.2.0
- winapi-0.3.6
- winapi-i686-pc-windows-gnu-0.4.0
- winapi-x86_64-pc-windows-gnu-0.4.0
+ ansi_term@0.11.0
+ ansi_term@0.12.1
+ assert_cmd@1.0.1
+ atty@0.2.11
+ bitflags@1.0.4
+ clap@2.33.3
+ difference@2.0.0
+ doc-comment@0.3.3
+ libc@0.2.47
+ no_color@0.1.0
+ predicates@1.0.5
+ predicates-core@1.0.0
+ predicates-tree@1.0.0
+ redox_syscall@0.1.50
+ redox_termios@0.1.1
+ strsim@0.8.0
+ termion@1.5.1
+ textwrap@0.11.0
+ treeline@0.1.0
+ unicode-width@0.1.5
+ vec_map@0.8.1
+ wait-timeout@0.2.0
+ winapi@0.3.6
+ winapi-i686-pc-windows-gnu@0.4.0
+ winapi-x86_64-pc-windows-gnu@0.4.0
"
inherit cargo
DESCRIPTION="Futuristic take on hexdump"
HOMEPAGE="https://github.com/sitkevij/hex"
-SRC_URI="https://github.com/sitkevij/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" $(cargo_crate_uris)"
+SRC_URI="https://github.com/sitkevij/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${CARGO_CRATE_URIS}
+"
# Prevent portage from trying to fetch bunch of *.crate from mirror despite they are not mirrored.
RESTRICT="mirror"
LICENSE="MIT"