aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@aarsen.me>2022-02-18 13:56:20 +0100
committerArsen Arsenović <arsen@aarsen.me>2022-02-18 13:56:44 +0100
commitb80592c8c9102750b8343e66e9e696396156daac (patch)
tree33eca054e363115c59e6cca18dcadf413852e47c /sys-boot
parentgames-emulation/rpcs: include soundtouch (diff)
downloadguru-b80592c8c9102750b8343e66e9e696396156daac.tar.gz
guru-b80592c8c9102750b8343e66e9e696396156daac.tar.bz2
guru-b80592c8c9102750b8343e66e9e696396156daac.zip
sys-boot/limine: bump to 2.85
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Arsen Arsenović <arsen@aarsen.me>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/limine/Manifest1
-rw-r--r--sys-boot/limine/limine-2.85.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-boot/limine/Manifest b/sys-boot/limine/Manifest
index fa101b3cf..7f5ba2c9f 100644
--- a/sys-boot/limine/Manifest
+++ b/sys-boot/limine/Manifest
@@ -1 +1,2 @@
DIST limine-2.84.2.tar.xz 1561312 BLAKE2B f46f0e37d581f7360377ad1582183bd89bc7eca57c7c11d388f02f6e8d1cf257f0150e15dc78390833974f7eb8bcaa8d3b49718fb9d49cb3edaf981f777f26cc SHA512 5fef4b7577078f2dd34d9a5bdaa4be1bebeb658c590d7cff4fa8aef73bbadab1a29983b949701a3103519c8a5f11b91ab1522b7b59315fc677b3a3b3d5e3eb91
+DIST limine-2.85.tar.xz 1562456 BLAKE2B 00b0b5efd793f8ca32948529d2f06804fbae70604419c80b6a70f282b48a5a259ba9677ada81bca152fbcf86bdddac33fb63e4b8792d9cd5619649d9ff1523ee SHA512 84af1613aa335c34afcc118d0a5a4307c0a82352ea68036fbf2c5be52d156b6254688cf417f47c1685a5f84d596cb7ed8dbebc4243bdd6070039847a5dc69e02
diff --git a/sys-boot/limine/limine-2.85.ebuild b/sys-boot/limine/limine-2.85.ebuild
new file mode 100644
index 000000000..555b21b16
--- /dev/null
+++ b/sys-boot/limine/limine-2.85.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WANT_LIBTOOL=none
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Limine is a modern, advanced x86/x86_64 BIOS/UEFI multiprotocol bootloader."
+HOMEPAGE="https://limine-bootloader.org/"
+SRC_URI="https://github.com/limine-bootloader/limine/releases/download/v${PV}/limine-${PV}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+eltorito-efi"
+
+BDEPEND="
+ sys-apps/findutils
+ dev-lang/nasm
+ app-arch/gzip
+ eltorito-efi? ( sys-fs/mtools )
+"
+
+src_configure() {
+ local myconf=(
+ "$(use_enable eltorito-efi)"
+ )
+
+ LIMINE_LD="$(tc-getLD)" \
+ LIMINE_AR="$(tc-getAR)" \
+ LIMINE_AS="$(tc-getAS)" \
+ LIMINE_OBJCOPY="$(tc-getOBJCOPY)" \
+ LIMINE_OBJDUMP="$(tc-getOBJDUMP)" \
+ LIMINE_READELF="$(tc-getREADELF)" \
+ econf "${myconf[@]}"
+}