aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@aarsen.me>2022-04-27 23:30:46 +0200
committerArsen Arsenović <arsen@aarsen.me>2022-04-27 23:30:46 +0200
commitdea7dc763fc53b323c707a4eb997951cf460205f (patch)
treebba4c716ec8800258c205bc7456c3eb3883afb85 /sys-boot
parentdev-ml/ocaml_intrinsics: treeclean (diff)
downloadguru-dea7dc763fc53b323c707a4eb997951cf460205f.tar.gz
guru-dea7dc763fc53b323c707a4eb997951cf460205f.tar.bz2
guru-dea7dc763fc53b323c707a4eb997951cf460205f.zip
sys-boot/limine: add 3.4.3
Signed-off-by: Arsen Arsenović <arsen@aarsen.me>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/limine/Manifest1
-rw-r--r--sys-boot/limine/limine-3.4.3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-boot/limine/Manifest b/sys-boot/limine/Manifest
index 752b1f55a..6516228a1 100644
--- a/sys-boot/limine/Manifest
+++ b/sys-boot/limine/Manifest
@@ -1,2 +1,3 @@
DIST limine-2.88.tar.xz 3154252 BLAKE2B d3e7b081245010c7fe5218ea364a4bb825ef6b7505b33db37bdc6a0e61a43f273c443d00df6ae7b61901420704d0368b5bcad59797f3eeb403c3bb9388193927 SHA512 53bb81e1261a5a6ae45c525cb2724871a11544c2d8236d421e6cde42c34cbf4c6b4a1a322a86e8064abadf5c124525149cecd93339a748a925673fc581805cee
DIST limine-3.0.tar.xz 3164168 BLAKE2B fedd161ec8957fd2b3245d8a7a6bffaeab4fa7629b5c07671287f964b8dd78396b530299a0b3f9de0c4ea0010624590ec505308b0612cfd419cbb4bc57b21496 SHA512 c92c5a6f094f7dd90bebbbaf5be59843897a66771550805e70536793549e42bdc49f4763a0eda9491235ace801ca3644697276de381240654b9cc95ea5c2e353
+DIST limine-3.4.3.tar.xz 3165344 BLAKE2B fe2afef5c960d9cfb78883ebe02d0fab754e40b466630ec3959d77e3f62f533e94d0ba3ecfda06688b8705140514c9aa4bb5c9e3c91ef884879e9e75c24fcd61 SHA512 986f95e3a12b5d4ae5f166f4d7388aa5feb12fa4b03f0acb8aa00a7494fbd37e53961b5afc2a85b1f399a742a78b72f70c9268792f652a64a491a142d3260256
diff --git a/sys-boot/limine/limine-3.4.3.ebuild b/sys-boot/limine/limine-3.4.3.ebuild
new file mode 100644
index 000000000..d054a12ed
--- /dev/null
+++ b/sys-boot/limine/limine-3.4.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WANT_LIBTOOL=none
+inherit autotools
+
+DESCRIPTION="Limine is a modern, advanced x86/x86_64 BIOS/UEFI multiprotocol bootloader."
+HOMEPAGE="https://limine-bootloader.org/"
+SRC_URI="https://github.com/limine-bootloader/limine/releases/download/v${PV}/limine-${PV}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+bios +bios-pxe +bios-cd +limine-deploy +uefi +cd-efi +uefi32 +uefi64"
+REQUIRED_USE="
+ uefi32? ( uefi )
+ uefi64? ( uefi )
+ cd-efi? ( uefi )
+ uefi? ( || ( uefi32 uefi64 cd-efi ) )
+
+ bios-pxe? ( bios )
+ bios-cd? ( bios )
+ limine-deploy? ( bios )
+ bios? ( || ( bios-pxe bios-cd limine-deploy ) )
+"
+
+BDEPEND="
+ sys-apps/findutils
+ dev-lang/nasm
+ app-arch/gzip
+ cd-efi? ( sys-fs/mtools )
+"
+
+src_configure() {
+ local myconf=(
+ "$(use_enable bios)"
+ "$(use_enable bios-cd)"
+ "$(use_enable bios-pxe)"
+ "$(use_enable limine-deploy)"
+
+ "$(use_enable uefi)"
+ "$(use_enable uefi32)"
+ "$(use_enable uefi64)"
+ "$(use_enable cd-efi)"
+ )
+
+ TOOLCHAIN="${CHOST}" \
+ econf "${myconf[@]}"
+}