aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZen <z@pyl.onl>2024-05-26 17:46:41 -0500
committerZen <z@pyl.onl>2024-05-26 17:47:19 -0500
commita2eb7cba03023eb55694e34317a24c43e5fd0960 (patch)
tree8b6ae3ae65de6ddf3b7a9da0869a7113ee47201b /sys-kernel
parentgames-rpg/snoot-game: add 1.10.0, drop 1.9.1 (diff)
downloadguru-a2eb7cba03023eb55694e34317a24c43e5fd0960.tar.gz
guru-a2eb7cba03023eb55694e34317a24c43e5fd0960.tar.bz2
guru-a2eb7cba03023eb55694e34317a24c43e5fd0960.zip
sys-kernel/ugrd: Add 1.8.3 with new installkernel hooks
Signed-off-by: Zen <z@pyl.onl>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ugrd/Manifest1
-rw-r--r--sys-kernel/ugrd/ugrd-1.8.3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-kernel/ugrd/Manifest b/sys-kernel/ugrd/Manifest
index 049fe24ca..870b971a0 100644
--- a/sys-kernel/ugrd/Manifest
+++ b/sys-kernel/ugrd/Manifest
@@ -5,3 +5,4 @@ DIST ugrd-1.4.2.tar.gz 50984 BLAKE2B 5b69cbaaefdcfe5b427f781806a58b39e6539b7f790
DIST ugrd-1.5.1.tar.gz 51574 BLAKE2B 5058e515e3d9aa543eb9ddd51335a5aa197ddf79395a193a4a4440706c2d940e77a0a26d470fc1ae86965d605e9889004d404e6ab5a4e1b4c12aaac92b872d2d SHA512 0a83180ed2947ce71cfb91c0fe65ddf20a3cbcb7f98f04efb4a95f904489153cb2e32e7efdb85c8ded8c4f29d95361bb7dc93e7eba72e74f1531c91aa03c1912
DIST ugrd-1.6.0.tar.gz 52219 BLAKE2B 34168eb5c553efe804ac9d5034ada96634f2323f26ecaad89eb5e0c0cc4eeb1ce6182d850186c3d439fa5470679ed08a73531966e9e742c1a018f84bf4dd851c SHA512 ea4843d5c21aa09e992478236395cdb3262110ffa3b5caec8db6712ea132851e9daa471a959437a37d2ca29cd62b9275dfe5515cdeb5c557c1268d797468dfb9
DIST ugrd-1.7.1.tar.gz 52946 BLAKE2B a41be0e5177b1883060a1693a8ec68179cf69d74713a95c51d2b2d2b8f3faca74f8f80d32e7767719e8de4b7190162f3b41bc779d487fdcbfe3e40a416f86c89 SHA512 f042106ec8843f738968e16d51d9deda010179678cf82daf2d162d3a3125eb9106dfdc5453c8555d8ba097caa2af22b74b2e1c5c38dc5083b97ac49cb7cea225
+DIST ugrd-1.8.3.tar.gz 53150 BLAKE2B 02a1429ac73c039b269fb289e2112ec485c3765d2d7f57c73808f243745e5f92b367267010d333b190695562cab529d3502780b741a730d6ddff5a216e616626 SHA512 224c956d1f3e53ab4e62067c1f6fcfe44424c560e0df1f9a645406d95381a16c5e0a8dd19156048fd64ead5fd41b05d6e0b84fc830b284813d4bf6e428ca8c20
diff --git a/sys-kernel/ugrd/ugrd-1.8.3.ebuild b/sys-kernel/ugrd/ugrd-1.8.3.ebuild
new file mode 100644
index 000000000..2c55118ef
--- /dev/null
+++ b/sys-kernel/ugrd/ugrd-1.8.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+inherit distutils-r1 optfeature shell-completion
+
+DESCRIPTION="Python based initramfs generator with TOML defintions"
+HOMEPAGE="https://github.com/desultory/ugrd"
+SRC_URI="https://github.com/desultory/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ app-misc/pax-utils
+ >=dev-python/zenlib-2.1.2[${PYTHON_USEDEP}]
+ >=dev-python/pycpio-1.1.2[${PYTHON_USEDEP}]
+ sys-apps/pciutils
+"
+
+src_install() {
+ # Call the distutils-r1_src_install function to install the package
+ distutils-r1_src_install
+ # Create the ugrd config directory
+ keepdir /etc/ugrd
+ # Install the example config into /etc/ugrd/config.toml
+ # Do not overwrite an existing config
+ insinto /etc/ugrd
+ newins examples/example.toml config.toml
+ # Create the kernel preinst.d directory if it doesn't exist
+ # Install the kernel preinst.d hook
+ exeinto /usr/lib/kernel/preinst.d
+ doexe hooks/installkernel/51-ugrd.install
+ exeinto /usr/lib/kernel/install.d
+ doexe hooks/kernel-install/51-ugrd.install
+ # Install bash autocomplete script
+ dobashcomp completion/ugrd
+ dozshcomp completion/_ugrd
+}
+
+pkg_postinst() {
+ optfeature "ugrd.crypto.cryptsetup support" sys-fs/cryptsetup
+ optfeature "ugrd.fs.btrfs support" sys-fs/btrfs-progs
+ optfeature "ugrd.crypto.gpg support" app-crypt/gnupg
+ ewarn "UGRD will not be used with installkernel unless 'ugrd' is set as the"
+ ewarn "'initrd_generator' in /usr/lib/kernel/install.conf."
+}