aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDale Showers <gentoo@fictx.com>2024-05-31 19:24:19 -0400
committerDale Showers <gentoo@fictx.com>2024-05-31 19:24:19 -0400
commit201512946988e3db5a7c92c349a3beab525f7e1f (patch)
treebe0d0ddd6a5294460f767532a13d237be15d726f /www-client
parentwww-client/nyxt: update sbcl dep version (diff)
downloadguru-201512946988e3db5a7c92c349a3beab525f7e1f.tar.gz
guru-201512946988e3db5a7c92c349a3beab525f7e1f.tar.bz2
guru-201512946988e3db5a7c92c349a3beab525f7e1f.zip
www-client/nyxt: add 3.11.7
Signed-off-by: Dale Showers <gentoo@fictx.com>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/nyxt/Manifest1
-rw-r--r--www-client/nyxt/nyxt-3.11.7.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/www-client/nyxt/Manifest b/www-client/nyxt/Manifest
index fd53238e85..1689bb25b4 100644
--- a/www-client/nyxt/Manifest
+++ b/www-client/nyxt/Manifest
@@ -1,3 +1,4 @@
DIST nyxt-3.11.4.gh.tar.xz 18095472 BLAKE2B 04aa9378efbf23153044c8e64f303240a9c424175c668968d05aad4ce8641ba4c2aa99b27b92c3683e84089bfdce0ef1e9d13ace231eaaef6ab521a5c4b19701 SHA512 f38a66af0fc45d8baa15be639d46d42eac96c71f085daec01b4ed48fabc7bbb4f301dd4394d9ffd6d1d6584a55acf64ef9042167cfdcf0bbb3045c72189a6063
DIST nyxt-3.11.5.gh.tar.xz 18100684 BLAKE2B 190ca6087cd781253bb08818072122bd720b423981621b5c94eb525816893ac9438bf278068378a60f3514b806f4681f697d7ff2061e2b71daf00b722c33b5c4 SHA512 1991c4c16e45df08b0630f003ca52213697a569e7545e412ede0a72af67337076c0e2605f4d85388717505513438bfcc2401db8a49c0d5a3c6e734669ac56661
DIST nyxt-3.11.6.gh.tar.xz 18092664 BLAKE2B ec540c4d751cb3d85df3c39fac6b48cb4355975c43f14391565fc72ec3aba9281001919251cb3d62800ac58501f33193ce96eedc720a6b41b2a5d4257c323202 SHA512 29aece8bf7c5d0ac47ab33e3f3387da7e62d669be1f2b7d08b27897982dcf07470c9d0cc59c58eee3bb174429d0f08226e51735162b87b37a2cf69148ec45f26
+DIST nyxt-3.11.7.gh.tar.xz 18094656 BLAKE2B 6e7dbe65601525fafa493cc86689062a3157812f8d7991bee42926291efeaddb699596d6eaa7207c633ec2e6beb3cd32884ba1ab0990aafeace8080b5cb242c1 SHA512 853cb4ec7fe0e04a9f4672170965d6e71c9c81d77382b08f3abe8bb68ce6d44b6ba2a8c3ed6d7d47b2a0a6a92cc3c312189ea7a0635f1a7a3c1ebcea8f710a40
diff --git a/www-client/nyxt/nyxt-3.11.7.ebuild b/www-client/nyxt/nyxt-3.11.7.ebuild
new file mode 100644
index 0000000000..af21d87820
--- /dev/null
+++ b/www-client/nyxt/nyxt-3.11.7.ebuild
@@ -0,0 +1,88 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop optfeature xdg
+
+DESCRIPTION="Nyxt - the hacker's power-browser"
+HOMEPAGE="https://nyxt.atlas.engineer/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/atlas-engineer/${PN}.git"
+ EGIT_SUBMODULES=( '*' )
+ EGIT_BRANCH="master"
+ EGIT_CHECKOUT_DIR="${S}"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/atlas-engineer/${PN}/releases/download/${PV}/nyxt-${PV}-source-with-submodules.tar.xz -> ${PF}.gh.tar.xz"
+fi
+
+LICENSE="BSD CC-BY-SA-3.0"
+SLOT="0"
+IUSE="doc"
+
+# Portage replaces the nyxt binary with sbcl when stripping
+RESTRICT="mirror strip"
+
+RDEPEND="
+ dev-libs/gobject-introspection
+ gnome-base/gsettings-desktop-schemas
+ net-libs/glib-networking
+ net-libs/webkit-gtk:4.1
+ sys-libs/libfixposix
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-lisp/sbcl-2.0.0[threads,unicode]
+ <=dev-lisp/sbcl-2.4.4[threads,unicode]
+"
+QA_FLAGS_IGNORED="usr/bin/${PN}"
+
+if [[ "${PV}" != 9999 ]]; then
+ src_unpack() {
+ mkdir "${WORKDIR}/${P}" || die
+ cd "${WORKDIR}/${P}"
+ default
+}
+
+fi
+
+src_compile() {
+ emake all
+ use doc && emake doc
+}
+
+src_install(){
+ dobin "${S}/nyxt"
+
+ if [ "$(use doc)" ]
+ then
+ docinto "/usr/share/doc/${P}"
+ dodoc "${S}/manual.html"
+ fi
+
+ for icon in 16x16 32x32 128x128 256x256 512x512; do
+ newicon -s ${icon} "${S}/assets/nyxt_${icon}.png" ${PN}.png
+ done
+
+ domenu "${S}/assets/nyxt.desktop"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "for X11 clipboard support" "x11-misc/xclip"
+ optfeature "for spellchecking" "app-text/enchant"
+ optfeature "for HTML5 audio/video" "media-libs/gstreamer"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-bad"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-base"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-good"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-ugly"
+ optfeature "for HTML5 audio/video" "media-plugins/gst-plugins-libav"
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}