aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDale Showers <gentoo@fictx.com>2024-02-06 13:05:07 -0500
committerDale Showers <gentoo@fictx.com>2024-02-06 13:05:07 -0500
commit8f59f523c31c16840c758d82e001fd958c5e0b3a (patch)
treeb93f02888a1b3afa7f7a5c6114b0c6520207a0b4 /www-client
parentapp-misc/minder: add 1.16.2 (diff)
downloadguru-8f59f523c31c16840c758d82e001fd958c5e0b3a.tar.gz
guru-8f59f523c31c16840c758d82e001fd958c5e0b3a.tar.bz2
guru-8f59f523c31c16840c758d82e001fd958c5e0b3a.zip
www-client/nyxt: fix 9999 build
Signed-off-by: Dale Showers <gentoo@fictx.com>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/nyxt/nyxt-9999.ebuild62
1 files changed, 26 insertions, 36 deletions
diff --git a/www-client/nyxt/nyxt-9999.ebuild b/www-client/nyxt/nyxt-9999.ebuild
index 59fd29939..463f1d0ed 100644
--- a/www-client/nyxt/nyxt-9999.ebuild
+++ b/www-client/nyxt/nyxt-9999.ebuild
@@ -1,30 +1,22 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit desktop optfeature xdg-utils
+inherit desktop optfeature xdg
DESCRIPTION="Nyxt - the hacker's power-browser"
HOMEPAGE="https://nyxt.atlas.engineer/"
-if [[ "${PV}" = *9999* ]]
-then
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/atlas-engineer/${PN}.git"
+ EGIT_SUBMODULES=( '*' )
+ EGIT_BRANCH="master"
+ EGIT_CHECKOUT_DIR="${S}"
else
KEYWORDS="~amd64"
- NYXTCOMMIT="27612fee394f80dee6480c045ec7da5cd1f82196"
- S="${WORKDIR}/${PN}-${NYXTCOMMIT}"
-
- # Specify commits for each submodules
- # Some regex substitutions allows to automate this process...
- # Commit hashes are obtained from -9999 version on ${NYXTCOMMIT}
- # Full list can be found here: https://github.com/atlas-engineer/nyxt/tree/master/_build
- # Removed the commits to reduce useless lines in -9999 version
-
- SRC_URI="https://github.com/atlas-engineer/${PN}/archive/${NYXTCOMMIT}.tar.gz -> ${P}.gh.tar.gz"
- # Removed the submodules SRC_URIs to reduce useless lines in -9999 version
+ SRC_URI="https://github.com/atlas-engineer/${PN}/releases/download/${PV}/nyxt-${PV}-source-with-submodules.tar.xz -> ${PF}.gh.tar.xz"
fi
# Portage replaces the nyxt binary with scbl when stripping
@@ -37,11 +29,6 @@ IUSE="doc"
RDEPEND="
dev-libs/gobject-introspection
gnome-base/gsettings-desktop-schemas
- media-libs/gst-plugins-bad
- media-libs/gst-plugins-base
- media-libs/gst-plugins-good
- media-libs/gst-plugins-ugly
- media-plugins/gst-plugins-libav
net-libs/glib-networking
net-libs/webkit-gtk:4.1
sys-libs/libfixposix
@@ -53,17 +40,15 @@ BDEPEND="
"
QA_FLAGS_IGNORED="usr/bin/${PN}"
-src_unpack() {
- default
-
- # Unpack the submodules in the _build directory
- if [[ "${PV}" != *9999* ]]
- then
- # Removed src_unpack to reduce useless lines in -9999
- true
- fi
+if [[ "${PV}" != 9999 ]]; then
+ src_unpack() {
+ mkdir "${WORKDIR}/${P}" || die
+ cd "${WORKDIR}/${P}"
+ default
}
+fi
+
src_compile() {
emake all
use doc && emake doc
@@ -78,20 +63,25 @@ src_install(){
dodoc "${S}/manual.html"
fi
- doicon "${S}/assets/icon_512x512.png.ico"
+ for icon in 16x16 32x32 128x128 256x256 512x512; do
+ newicon -s ${icon} "${S}/assets/nyxt_${icon}.png" ${PN}.png
+ done
+
domenu "${S}/assets/nyxt.desktop"
}
pkg_postinst() {
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
- xdg_icon_cache_update
+ xdg_pkg_postinst
optfeature "for X11 clipboard support" "x11-misc/xclip"
optfeature "for spellchecking" "app-text/enchant"
+ optfeature "for HTML5 audio/video" "media-libs/gstreamer"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-bad"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-base"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-good"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-ugly"
+ optfeature "for HTML5 audio/video" "media-plugins/gst-plugins-libav"
}
pkg_postrm() {
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
- xdg_icon_cache_update
+ xdg_pkg_postrm
}