aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2021-02-13 22:51:16 +0800
committerHuang Rui <vowstar@gmail.com>2021-02-13 22:51:16 +0800
commitcb3e18a4b44f27c1f138ee24b08443aac284fae4 (patch)
treef6b5039da383885e029435ed38e5e70cd52eb9d5 /x11-themes
parentsys-apps/systemd-bootchart: New ebuild (diff)
downloadguru-cb3e18a4b44f27c1f138ee24b08443aac284fae4.tar.gz
guru-cb3e18a4b44f27c1f138ee24b08443aac284fae4.tar.bz2
guru-cb3e18a4b44f27c1f138ee24b08443aac284fae4.zip
x11-themes/obsidian-icon-theme: bump to 4.15
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Huang Rui <vowstar@gmail.com>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/obsidian-icon-theme/Manifest1
-rw-r--r--x11-themes/obsidian-icon-theme/obsidian-icon-theme-4.15.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/x11-themes/obsidian-icon-theme/Manifest b/x11-themes/obsidian-icon-theme/Manifest
index 8600be81e..c97dcfc2e 100644
--- a/x11-themes/obsidian-icon-theme/Manifest
+++ b/x11-themes/obsidian-icon-theme/Manifest
@@ -1 +1,2 @@
DIST obsidian-icon-theme-4.14.tar.gz 70967634 BLAKE2B 8f4a0d26945dd18c1de626292000eedaf54a33668b0b5282530ed876f261304a11876a7320db3a59137e2dcf90d8e3854413635361807a97bdfaae70cc26cca8 SHA512 985b4bbc6ab9a04ab688bff1eb77448a2139ba6c9598c0ce778a01f7bca455308a28afed7bb33741734a3e9e52bfc50129c5c140eaae4b3671e06e301a42dc5d
+DIST obsidian-icon-theme-4.15.tar.gz 71019938 BLAKE2B 23a709d46c6ea01d7d6a4a98913a07ea2e3ebaa0f9a06d1e52e9335b3d244b08ae98fae2ebbaf9791836c2e46ff6293996dd6df41a0aee04efc58d77657df232 SHA512 3b982db0c6ae637173a02bf8a5aa13dd85568ca2765f7e5839bbdeaa1e631622676e841169145686b74a213c1aca496d436c55f52c173479120a74822b2b7b3a
diff --git a/x11-themes/obsidian-icon-theme/obsidian-icon-theme-4.15.ebuild b/x11-themes/obsidian-icon-theme/obsidian-icon-theme-4.15.ebuild
new file mode 100644
index 000000000..9662e9f1b
--- /dev/null
+++ b/x11-themes/obsidian-icon-theme/obsidian-icon-theme-4.15.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+GIT_PN="iconpack-obsidian"
+
+inherit xdg
+
+DESCRIPTION="Obsidian Icon Theme is intuitive Faenza-like icon theme"
+
+HOMEPAGE="https://github.com/madmaxms/iconpack-obsidian"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/madmaxms/${GIT_PN}.git"
+else
+ SRC_URI="https://github.com/madmaxms/${GIT_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ S="${WORKDIR}/${GIT_PN}-${PV}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ x11-themes/adwaita-icon-theme
+"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( README.md )
+
+src_install() {
+ # Remove dead links to fix symbolic link does not exist QA.
+ find . -xtype l -exec rm {} + || die
+ # Install the icons
+ insinto /usr/share/icons
+ doins -r Obsidian*
+}