aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-vcs/got/Manifest2
-rw-r--r--dev-vcs/got/got-0.61.ebuild39
-rw-r--r--dev-vcs/got/got-0_p20210217.ebuild60
3 files changed, 40 insertions, 61 deletions
diff --git a/dev-vcs/got/Manifest b/dev-vcs/got/Manifest
index a16d3ea71..f772a1b25 100644
--- a/dev-vcs/got/Manifest
+++ b/dev-vcs/got/Manifest
@@ -1,2 +1,2 @@
-DIST got-0_p20210217.tar.gz 517647 BLAKE2B 4b4f5436c5804aa60038d737de883eb69ce4d4f0f705f7d310722222da38b917d577a09fb37b2317c1a34b1a0aa2b0fe00cf07dcbb350a901fe50dbb31ca6ede SHA512 fb3c60b5d1036d735e775e362c7349720bfeae62c1e8b830417b5edd57c86546a97113f6b10b742b1b3b6146d0a7e41906042c1008551b4d15e2bd0331c7ab2f
DIST got-portable-0.60.tar.gz 664189 BLAKE2B 2ea2c7680de2fde60d4c862ebb836c9809b686396d8ed9c250b14c5d874f393a30f97281fa601fd1e4a7a19c66d8c71f478fda7fea21f11017dbc2bea593900b SHA512 9139c4187914d3ac93880a1b242e14a4d93e3982251dd6eb346911e76f51cc7f0041b45af712633a1099b727580870572c8f590432e7f51abe3c682cba47b524
+DIST got-portable-0.61.tar.gz 672888 BLAKE2B 17a195e6717ef94c7de2ef70180a92af81fbac8a298d67db17e703045590b58bec85c276a95f3f8ad49ed47367acd9fc85afbf57d95de79adefb5f8d642b6a7c SHA512 3af662be0c6279c970bf2578bdbd6ca16118af2a5ce3aa49c0243c62051e0a7fc5fd8f78cc27e063ae639929f3b69c4efc01a7642ea76abfcd60f205b9a758a0
diff --git a/dev-vcs/got/got-0.61.ebuild b/dev-vcs/got/got-0.61.ebuild
new file mode 100644
index 000000000..a5501db1d
--- /dev/null
+++ b/dev-vcs/got/got-0.61.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN="${PN}-portable"
+DESCRIPTION="Portable version of the Game of Trees version control system"
+HOMEPAGE="https://gameoftrees.org"
+SRC_URI="https://gameoftrees.org/releases/portable/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ sys-libs/ncurses:=[unicode(+)]
+ sys-libs/zlib:=
+ elibc_Darwin? ( sys-libs/native-uuid )
+ elibc_SunOS? ( sys-libs/libuuid )
+ !elibc_Darwin? ( dev-libs/libbsd )
+ !elibc_Darwin? ( !elibc_SunOS? (
+ app-crypt/libmd
+ sys-apps/util-linux
+ ) )
+"
+BDEPEND="
+ virtual/pkgconfig
+ virtual/yacc
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGELOG CHANGES README TODO )
+
+src_compile() {
+ emake AR=$(tc-getAR) GOT_RELEASE=Yes
+}
diff --git a/dev-vcs/got/got-0_p20210217.ebuild b/dev-vcs/got/got-0_p20210217.ebuild
deleted file mode 100644
index 115529b51..000000000
--- a/dev-vcs/got/got-0_p20210217.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools toolchain-funcs
-
-MY_PN="${PN}-portable"
-COMMIT="36536ee0b0fb5108076d8238a4b78c59db9dac3d" # "linux" branch
-DESCRIPTION="Portable version of the Game of Trees version control system"
-HOMEPAGE="https://gameoftrees.org"
-SRC_URI="https://git.gameoftrees.org/gitweb/?p=${MY_PN}.git;a=snapshot;h=${COMMIT};sf=tgz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${COMMIT:0:7}"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="
- dev-libs/openssl:=
- sys-libs/ncurses:=
- sys-libs/zlib:=
- elibc_Darwin? ( sys-libs/native-uuid )
- elibc_SunOS? ( sys-libs/libuuid )
- !elibc_Darwin? (
- dev-libs/libbsd
- !elibc_SunOS? (
- app-crypt/libmd
- sys-apps/util-linux
- )
- )
-"
-RDEPEND="${DEPEND}
- dev-vcs/git
-"
-BDEPEND="
- virtual/pkgconfig
- virtual/yacc
-"
-
-DOCS=( CHANGES README README.portable )
-
-src_prepare() {
- default
-
- # remove debugging flags (-Werror, -g, ...)
- sed "s/\(GOT_RELEASE\)=No/\1=Yes/" -i configure.ac || die
- sed "/AM_CFLAGS += -g/d" -i Makefile.am || die
-
- eautoreconf
-}
-
-src_compile() {
- emake AR=$(tc-getAR)
-}
-
-src_install() {
- default
- doman got/*.5
-}