aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-arcade/taisei/taisei-1.3.1.ebuild12
-rw-r--r--games-arcade/taisei/taisei-9999.ebuild12
2 files changed, 14 insertions, 10 deletions
diff --git a/games-arcade/taisei/taisei-1.3.1.ebuild b/games-arcade/taisei/taisei-1.3.1.ebuild
index a8371fb62..cbecc2fbc 100644
--- a/games-arcade/taisei/taisei-1.3.1.ebuild
+++ b/games-arcade/taisei/taisei-1.3.1.ebuild
@@ -1,13 +1,14 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit meson
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit meson python-any-r1
if [[ ${PV} == *9999* ]]; then
inherit git-r3
- KEYWORDS=""
EGIT_REPO_URI="https://github.com/taisei-project/taisei.git"
else
SRC_URI="https://github.com/taisei-project/taisei/releases/download/v${PV}/${PN}-v${PV}.tar.xz"
@@ -31,8 +32,9 @@ DEPEND="
sys-libs/zlib
zip? ( dev-libs/libzip )
"
-BDEPEND=">=dev-util/meson-0.49
- >=dev-lang/python-3.5
+BDEPEND="
+ >=dev-util/meson-0.49
+ ${PYTHON_DEPS}
doc? ( dev-python/docutils )"
src_prepare() {
diff --git a/games-arcade/taisei/taisei-9999.ebuild b/games-arcade/taisei/taisei-9999.ebuild
index a8371fb62..cbecc2fbc 100644
--- a/games-arcade/taisei/taisei-9999.ebuild
+++ b/games-arcade/taisei/taisei-9999.ebuild
@@ -1,13 +1,14 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit meson
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit meson python-any-r1
if [[ ${PV} == *9999* ]]; then
inherit git-r3
- KEYWORDS=""
EGIT_REPO_URI="https://github.com/taisei-project/taisei.git"
else
SRC_URI="https://github.com/taisei-project/taisei/releases/download/v${PV}/${PN}-v${PV}.tar.xz"
@@ -31,8 +32,9 @@ DEPEND="
sys-libs/zlib
zip? ( dev-libs/libzip )
"
-BDEPEND=">=dev-util/meson-0.49
- >=dev-lang/python-3.5
+BDEPEND="
+ >=dev-util/meson-0.49
+ ${PYTHON_DEPS}
doc? ( dev-python/docutils )"
src_prepare() {