aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/tarlz/tarlz-0.19-r3.ebuild')
-rw-r--r--app-arch/tarlz/tarlz-0.19-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-arch/tarlz/tarlz-0.19-r3.ebuild b/app-arch/tarlz/tarlz-0.19-r3.ebuild
new file mode 100644
index 000000000..ac53651c5
--- /dev/null
+++ b/app-arch/tarlz/tarlz-0.19-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs unpacker
+
+DESCRIPTION="A parallel archiver combining tar and lzip"
+HOMEPAGE="https://www.nongnu.org/lzip/tarlz.html"
+SRC_URI="https://download.savannah.gnu.org/releases/lzip/${PN}/${P}.tar.lz"
+LICENSE="GPL-2+"
+
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+RDEPEND="app-arch/lzlib:0="
+DEPEND="
+ ${RDEPEND}
+ $(unpacker_src_uri_depends)
+"
+
+PATCHES=(
+ "${FILESDIR}/skip-broken-testcase.patch"
+)
+
+src_configure() {
+ econf \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}