aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/nvidia-container-toolkit/nvidia-container-toolkit-1.10.0.ebuild')
-rw-r--r--app-containers/nvidia-container-toolkit/nvidia-container-toolkit-1.10.0.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/app-containers/nvidia-container-toolkit/nvidia-container-toolkit-1.10.0.ebuild b/app-containers/nvidia-container-toolkit/nvidia-container-toolkit-1.10.0.ebuild
deleted file mode 100644
index e5407673e..000000000
--- a/app-containers/nvidia-container-toolkit/nvidia-container-toolkit-1.10.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-EGO_PN="github.com/NVIDIA/${PN}"
-
-inherit go-module
-
-DESCRIPTION="NVIDIA container runtime toolkit"
-HOMEPAGE="https://github.com/NVIDIA/nvidia-container-toolkit"
-
-if [[ "${PV}" == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/NVIDIA/${PN}.git"
- inherit git-r3
-
- src_unpack() {
- git-r3_src_unpack
- go-module_live_vendor
- }
-else
- SRC_URI="
- https://github.com/NVIDIA/${PN}/archive/v${PV/_rc/-rc.}.tar.gz -> ${P}.tar.gz
- https://media.githubusercontent.com/media/vowstar/distfiles/main/${P}-deps.tar.xz
- "
- S="${WORKDIR}/${PN}-${PV/_rc/-rc.}"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-
-IUSE=""
-
-RDEPEND="
- sys-libs/libnvidia-container
-"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- app-arch/unzip
- sys-devel/make
-"
-
-src_compile() {
- emake binaries
-}
-
-src_install() {
- dobin "${PN}"
- into "/usr/bin"
- dosym "${PN}" "/usr/bin/nvidia-container-runtime-hook"
- insinto "/etc/nvidia-container-runtime"
- doins "${FILESDIR}/config.toml"
-}
-
-pkg_postinst() {
- elog "Your docker service must restart after install this package."
- elog "OpenRC: sudo rc-service docker restart"
- elog "systemd: sudo systemctl restart docker"
- elog "You may need to edit your /etc/nvidia-container-runtime/config.toml"
- elog "file before running ${PN} for the first time."
- elog "For details, please see the NVIDIA docker manual page."
-}