aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/megasync/files/megasync-5.3.0.0-fix-install-dir.patch')
-rw-r--r--net-misc/megasync/files/megasync-5.3.0.0-fix-install-dir.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-misc/megasync/files/megasync-5.3.0.0-fix-install-dir.patch b/net-misc/megasync/files/megasync-5.3.0.0-fix-install-dir.patch
new file mode 100644
index 000000000..a5f86e3e7
--- /dev/null
+++ b/net-misc/megasync/files/megasync-5.3.0.0-fix-install-dir.patch
@@ -0,0 +1,27 @@
+--- a/contrib/cmake/modules/desktopapp_configuration.cmake
++++ b/contrib/cmake/modules/desktopapp_configuration.cmake
+@@ -29,8 +29,6 @@ if(UNIX AND NOT APPLE)
+ # Note: using cmake --install --prefix /some/prefix will keep the RPATH as configured above.
+ # Used for building packages: in which install dir is a path construction folder that will not be there in packages
+
+- set(CMAKE_INSTALL_LIBDIR "opt/megasync/lib") # override default "lib" from GNUInstallDirs
+- set(CMAKE_INSTALL_BINDIR "usr/bin") # override default "bin" from GNUInstallDirs
+
+ # Override CMAKE_INSTALL_PREFIX
+ if(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT) # In consecutive runs it will always be undef/false
+--- a/src/MEGASync/CMakeLists.txt
++++ b/src/MEGASync/CMakeLists.txt
+@@ -142,13 +142,6 @@ if (UNIX AND NOT APPLE)
+
+ set(vcpkg_lib_folder "${VCPKG_INSTALLED_DIR}/${VCPKG_TARGET_TRIPLET}/$<$<CONFIG:Debug>:debug/>lib/")
+
+- install(DIRECTORY "${vcpkg_lib_folder}"
+- TYPE LIB # In CMAKE_INSTALL_LIBDIR directory
+- FILES_MATCHING
+- PATTERN "*.so*"
+- PATTERN "manual-link" EXCLUDE
+- PATTERN "pkgconfig" EXCLUDE
+- )
+
+ if(DEPLOY_QT_LIBRARIES)
+ include(desktopapp_deploy_qt)