aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/slang/slang-1.0.ebuild')
-rw-r--r--sci-electronics/slang/slang-1.0.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/sci-electronics/slang/slang-1.0.ebuild b/sci-electronics/slang/slang-1.0.ebuild
deleted file mode 100644
index cddfba31c..000000000
--- a/sci-electronics/slang/slang-1.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-PYTHON_COMPAT=( python3_{9..12} )
-inherit cmake python-single-r1
-
-DESCRIPTION="SystemVerilog compiler and language services"
-HOMEPAGE="
- https://sv-lang.com
- https://github.com/MikePopoloski/slang
-"
-
-if [[ "${PV}" == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/MikePopoloski/${PN}.git"
-else
- SRC_URI="https://github.com/MikePopoloski/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
- S="${WORKDIR}/${P}"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="python test"
-REQUIRED_USE=" ${PYTHON_REQUIRED_USE} "
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-libs/libfmt
-"
-
-DEPEND="
- ${RDEPEND}
-"
-
-src_configure() {
- python_setup
-
- local mycmakeargs=(
- -D CMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
- -D BUILD_SHARED_LIBS=ON
- -D SLANG_INCLUDE_TESTS=$(usex test)
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- # fix libdir path
- if [[ "$(get_libdir)" != "lib" ]] ; then
- mv "${D}"/usr/lib "${D}"/usr/"$(get_libdir)" || die
- fi
- # file collisions of internal fmt
- rm -r "${D}"/usr/include/fmt || die
-}