aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-06-21 08:38:34 -0700
committerorbea <orbea@riseup.net>2023-06-21 08:38:34 -0700
commit8bcf17a0e99cccd54f2a7fc80efa4d585272f935 (patch)
tree1ae2d6088aabf48fcf3e89fe44880f0d0fa46891 /app-crypt
parentdev-lang/python: add 3.9.17, 3.10.12, 3.11.4 (diff)
downloadlibressl-8bcf17a0e99cccd54f2a7fc80efa4d585272f935.tar.gz
libressl-8bcf17a0e99cccd54f2a7fc80efa4d585272f935.tar.bz2
libressl-8bcf17a0e99cccd54f2a7fc80efa4d585272f935.zip
app-crypt/qca: sync ::gentoo
Signed-off-by: orbea <orbea@riseup.net>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/qca/qca-2.3.6-r2.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/app-crypt/qca/qca-2.3.6-r2.ebuild b/app-crypt/qca/qca-2.3.6-r2.ebuild
index d2d0386..317d18d 100644
--- a/app-crypt/qca/qca-2.3.6-r2.ebuild
+++ b/app-crypt/qca/qca-2.3.6-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake kde.org multibuild qmake-utils
+inherit cmake kde.org multibuild out-of-source-utils qmake-utils
DESCRIPTION="Qt Cryptographic Architecture (QCA)"
HOMEPAGE="https://userbase.kde.org/QCA"
@@ -92,6 +92,9 @@ src_configure() {
src_compile() {
multibuild_foreach_variant cmake_src_compile
+ if use doc; then
+ multibuild_for_best_variant cmake_build doc
+ fi
}
src_test() {
@@ -106,10 +109,7 @@ src_install() {
multibuild_foreach_variant cmake_src_install
if use doc; then
- pushd "${BUILD_DIR}" >/dev/null || die
- doxygen Doxyfile || die
- dodoc -r apidocs/html
- popd >/dev/null || die
+ multibuild_for_best_variant run_in_build_dir dodoc -r apidocs/html
fi
if use examples; then