aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2020-05-20 08:07:49 +0300
committerStefan Strogin <steils@gentoo.org>2020-05-21 00:06:34 +0300
commit1a786ad34d612a6f887b8d92b95863f4d19fb630 (patch)
tree7692712869219a4e757072beec671bb742fcddcb
parentlayout.conf: set sign-manifests = false (diff)
downloadmatrix-1a786ad34d612a6f887b8d92b95863f4d19fb630.tar.gz
matrix-1a786ad34d612a6f887b8d92b95863f4d19fb630.tar.bz2
matrix-1a786ad34d612a6f887b8d92b95863f4d19fb630.zip
net-im/riot-web: drop 9999
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Stefan Strogin <steils@gentoo.org>
-rw-r--r--net-im/riot-web/riot-web-9999.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/net-im/riot-web/riot-web-9999.ebuild b/net-im/riot-web/riot-web-9999.ebuild
deleted file mode 100644
index dc90f99..0000000
--- a/net-im/riot-web/riot-web-9999.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="A glossy Matrix collaboration client for the web"
-HOMEPAGE="https://riot.im"
-
-inherit eutils
-
-if [[ ${PV} == "9999" ]]; then
- inherit git-r3
-
- SRC_URI=""
- EGIT_REPO_URI="https://github.com/vector-im/riot-web.git"
- EGIT_BRANCH="develop"
-else
- SRC_URI="https://github.com/vector-im/riot-web/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-REQUIRED_USE=""
-
-DEPEND="sys-devel/binutils:*
- net-libs/nodejs[npm]
- x11-libs/libXScrnSaver
- net-print/cups
- dev-libs/nss
- gnome-base/gconf"
-RDEPEND="${DEPEND}"
-
-QA_PREBUILT="
- opt/Riot/libffmpeg.so
- opt/Riot/libnode.so
- opt/Riot/riot-web"
-
-DESTINATION="/" # We build and unpack a Debian installer, which already has everything in the proper directories {usr,opt}, so we just set the destination to "/"
-
-src_prepare() {
- default
-
- if [[ ${PV} == "9999" ]]; then
- "${S}"/scripts/fetch-develop.deps.sh
- fi
-
- npm install
-
- cp "${S}"/config.sample.json "${S}"/config.json
-}
-
-src_compile() {
- npm run build || die
-
- "${S}"/node_modules/.bin/build -l --x64 || die
-}
-
-src_install() {
- ar x "${S}"/electron_app/dist/riot-web*.deb
- tar xvf data.tar.xz
-
- mv usr/share/doc/${PN} usr/share/doc/${PF}
- gunzip usr/share/doc/${PF}/changelog.gz
- insinto ${DESTINATION}
- doins -r usr
- doins -r opt
- fperms +x /opt/Riot/${PN}
- dosym ${DESTINATION}/opt/Riot/${PN} ${DESTINATION}/usr/bin/${PN}
-}