summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2018-11-19 17:38:30 +0100
committerFabian Groffen <grobian@gentoo.org>2018-11-19 17:38:30 +0100
commitdb0865445d76ed1c2c1704458d1dceed1fde0194 (patch)
tree6de71a31d8f6f1f57a04dbfe5c1a3e73ac6e266f /app-arch
parentapp-arch/bzip2: sync (diff)
downloadprefix-db0865445d76ed1c2c1704458d1dceed1fde0194.tar.gz
prefix-db0865445d76ed1c2c1704458d1dceed1fde0194.tar.bz2
prefix-db0865445d76ed1c2c1704458d1dceed1fde0194.zip
app-arch/unzip: sync
Signed-off-by: Fabian Groffen <grobian@gentoo.org> Package-Manager: Portage-2.3.40.3-prefix, Repoman-2.3.9
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unzip/Manifest2
-rw-r--r--app-arch/unzip/files/unzip-6.0-format-security.patch91
-rw-r--r--app-arch/unzip/unzip-6.0-r3.ebuild82
-rw-r--r--app-arch/unzip/unzip-6.0_p21-r2.ebuild (renamed from app-arch/unzip/unzip-6.0_p20.ebuild)20
4 files changed, 101 insertions, 94 deletions
diff --git a/app-arch/unzip/Manifest b/app-arch/unzip/Manifest
index 3b13649240..c338085389 100644
--- a/app-arch/unzip/Manifest
+++ b/app-arch/unzip/Manifest
@@ -1,2 +1,2 @@
DIST unzip60.tar.gz 1376845 BLAKE2B 5016d300b4452018a391f4ebc03c6960c068df400a0407c0c60bd7bb5ec5012031f916d8b204a6149ba291c2c35beba40d9b43c76fc093026e79471329ab0e47 SHA512 0694e403ebc57b37218e00ec1a406cae5cc9c5b52b6798e0d4590840b6cdbf9ddc0d9471f67af783e960f8fa2e620394d51384257dca23d06bcd90224a80ce5d
-DIST unzip_6.0-20.debian.tar.xz 16680 BLAKE2B 17ce9234ac485eab4e5188b555af31dcb0db577b199e0c58991ba7211c4c80edce52b72e89cc4d82b000b70bed1ac90262c0972507f28f054af2cebd0ca33b48 SHA512 7212cb110291581c2e465dc8ea5130eabffc4e0369d6245e8c26fa9d350bed904847d6e1191afaaa2d3fc23bd05fda7da80439d0c06b88f5331b01c9eff97fbe
+DIST unzip_6.0-21.debian.tar.xz 17740 BLAKE2B 098a84e5b05f819f9c8c6a6656fdb2359dfb5b93f63444e55347e0bef9735fa48bf1631a658a2cb6d0c604e7e740e47b57910d251b74e5df7c8b9468acfe55f4 SHA512 f7bce4156ac13c34da3f991df3ae88b0db99b0810c7f8904ea3ac666a4cb2788d7182056f2bbd82d7519d0e0ee31a10af47bee08f360ceb859e5fbfc6e15ef36
diff --git a/app-arch/unzip/files/unzip-6.0-format-security.patch b/app-arch/unzip/files/unzip-6.0-format-security.patch
new file mode 100644
index 0000000000..c61c135963
--- /dev/null
+++ b/app-arch/unzip/files/unzip-6.0-format-security.patch
@@ -0,0 +1,91 @@
+Fix build with -Werror=format-security
+
+Origin: http://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/?h=master-next&id=f7d80257afcfefdc85b6745328f2d12b957a848b
+Author: Edwin Plauchu <edwin.plauchu.camacho@intel.com>
+
+diff --git a/extract.c b/extract.c
+index 7cd9123..25c5a62 100644
+--- a/extract.c
++++ b/extract.c
+@@ -475,7 +475,7 @@ int extract_or_test_files(__G) /* return PK-type error code */
+ Info(slide, 0x401, ((char *)slide,
+ LoadFarString(CentSigMsg), j + blknum*DIR_BLKSIZ + 1));
+ Info(slide, 0x401, ((char *)slide,
+- LoadFarString(ReportMsg)));
++ "%s",LoadFarString(ReportMsg)));
+ error_in_archive = PK_BADERR;
+ }
+ reached_end = TRUE; /* ...so no more left to do */
+@@ -754,8 +754,8 @@ int extract_or_test_files(__G) /* return PK-type error code */
+
+ #ifndef SFX
+ if (no_endsig_found) { /* just to make sure */
+- Info(slide, 0x401, ((char *)slide, LoadFarString(EndSigMsg)));
+- Info(slide, 0x401, ((char *)slide, LoadFarString(ReportMsg)));
++ Info(slide, 0x401, ((char *)slide, "%s", LoadFarString(EndSigMsg)));
++ Info(slide, 0x401, ((char *)slide, "%s", LoadFarString(ReportMsg)));
+ if (!error_in_archive) /* don't overwrite stronger error */
+ error_in_archive = PK_WARN;
+ }
+diff --git a/list.c b/list.c
+index 15e0011..0b484f6 100644
+--- a/list.c
++++ b/list.c
+@@ -181,7 +181,7 @@ int list_files(__G) /* return PK-type error code */
+ Info(slide, 0x401,
+ ((char *)slide, LoadFarString(CentSigMsg), j));
+ Info(slide, 0x401,
+- ((char *)slide, LoadFarString(ReportMsg)));
++ ((char *)slide, "%s", LoadFarString(ReportMsg)));
+ return PK_BADERR; /* sig not found */
+ }
+ }
+@@ -507,7 +507,7 @@ int list_files(__G) /* return PK-type error code */
+ && (!G.ecrec.is_zip64_archive)
+ && (memcmp(G.sig, end_central_sig, 4) != 0)
+ ) { /* just to make sure again */
+- Info(slide, 0x401, ((char *)slide, LoadFarString(EndSigMsg)));
++ Info(slide, 0x401, ((char *)slide, "%s", LoadFarString(EndSigMsg)));
+ error_in_archive = PK_WARN; /* didn't find sig */
+ }
+
+@@ -591,7 +591,7 @@ int get_time_stamp(__G__ last_modtime, nmember) /* return PK-type error code */
+ Info(slide, 0x401,
+ ((char *)slide, LoadFarString(CentSigMsg), j));
+ Info(slide, 0x401,
+- ((char *)slide, LoadFarString(ReportMsg)));
++ ((char *)slide, "%s", LoadFarString(ReportMsg)));
+ return PK_BADERR; /* sig not found */
+ }
+ }
+@@ -674,7 +674,7 @@ int get_time_stamp(__G__ last_modtime, nmember) /* return PK-type error code */
+ ---------------------------------------------------------------------------*/
+
+ if (memcmp(G.sig, end_central_sig, 4)) { /* just to make sure again */
+- Info(slide, 0x401, ((char *)slide, LoadFarString(EndSigMsg)));
++ Info(slide, 0x401, ((char *)slide, "%s", LoadFarString(EndSigMsg)));
+ error_in_archive = PK_WARN;
+ }
+ if (*nmember == 0L && error_in_archive <= PK_WARN)
+diff --git a/zipinfo.c b/zipinfo.c
+index 0ac75b3..1e7fa82 100644
+--- a/zipinfo.c
++++ b/zipinfo.c
+@@ -833,7 +833,7 @@ int zipinfo(__G) /* return PK-type error code */
+ Info(slide, 0x401,
+ ((char *)slide, LoadFarString(CentSigMsg), j));
+ Info(slide, 0x401,
+- ((char *)slide, LoadFarString(ReportMsg)));
++ ((char *)slide, "%s", LoadFarString(ReportMsg)));
+ error_in_archive = PK_BADERR; /* sig not found */
+ break;
+ }
+@@ -1022,7 +1022,7 @@ int zipinfo(__G) /* return PK-type error code */
+ && (!G.ecrec.is_zip64_archive)
+ && (memcmp(G.sig, end_central_sig, 4) != 0)
+ ) { /* just to make sure again */
+- Info(slide, 0x401, ((char *)slide, LoadFarString(EndSigMsg)));
++ Info(slide, 0x401, ((char *)slide, "%s", LoadFarString(EndSigMsg)));
+ error_in_archive = PK_WARN; /* didn't find sig */
+ }
+
diff --git a/app-arch/unzip/unzip-6.0-r3.ebuild b/app-arch/unzip/unzip-6.0-r3.ebuild
deleted file mode 100644
index 5f2c49483f..0000000000
--- a/app-arch/unzip/unzip-6.0-r3.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="2"
-inherit eutils toolchain-funcs flag-o-matic
-
-MY_P="${PN}${PV/.}"
-
-DESCRIPTION="unzipper for pkzip-compressed files"
-HOMEPAGE="http://www.info-zip.org/"
-SRC_URI="mirror://sourceforge/infozip/${MY_P}.tar.gz"
-
-LICENSE="Info-ZIP"
-SLOT="0"
-KEYWORDS="~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bzip2 natspec unicode"
-
-DEPEND="bzip2? ( app-arch/bzip2 )
- natspec? ( dev-libs/libnatspec )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-no-exec-stack.patch
- use natspec && epatch "${FILESDIR}/${PN}-6.0-natspec.patch" #275244
- epatch "${FILESDIR}"/${P}-irix.patch
- sed -i -r \
- -e '/^CFLAGS/d' \
- -e '/CFLAGS/s:-O[0-9]?:$(CFLAGS) $(CPPFLAGS):' \
- -e '/^STRIP/s:=.*:=true:' \
- -e "s:\<CC *= *\"?g?cc2?\"?\>:CC=\"$(tc-getCC)\":" \
- -e "s:\<LD *= *\"?(g?cc2?|ld)\"?\>:LD=\"$(tc-getCC)\":" \
- -e "s:\<AS *= *\"?(g?cc2?|as)\"?\>:AS=\"$(tc-getCC)\":" \
- -e 's:LF2 = -s:LF2 = :' \
- -e 's:LF = :LF = $(LDFLAGS) :' \
- -e 's:SL = :SL = $(LDFLAGS) :' \
- -e 's:FL = :FL = $(LDFLAGS) :' \
- -e "/^#L_BZ2/s:^$(use bzip2 && echo .)::" \
- -e 's:$(AS) :$(AS) $(ASFLAGS) :g' \
- -e "s!CF = \$(CFLAGS) \$(CF_NOOPT)!CF = \$(CFLAGS) \$(CF_NOOPT) \$(CPPFLAGS)!" \
- unix/Makefile \
- || die "sed unix/Makefile failed"
-}
-
-src_compile() {
- local TARGET
- case ${CHOST} in
- i?86*-*linux*) TARGET=linux_asm ;;
- *linux*) TARGET=linux_noasm ;;
- i?86*-*bsd* | \
- i?86*-dragonfly*) TARGET=freebsd ;; # mislabelled bsd with x86 asm
- *bsd* | *dragonfly*) TARGET=bsd ;;
- *-darwin*) TARGET=macosx; append-cppflags "-DNO_LCHMOD" ;;
- *-solaris*) TARGET=generic ;;
- mips-sgi-irix*) TARGET=sgi; append-cppflags "-DNO_LCHMOD" ;;
- *-interix3*) TARGET=gcc; append-flags "-DUNIX"; append-cppflags "-DNO_LCHMOD" ;;
- *-interix*) TARGET=gcc; append-flags "-DUNIX -DNO_LCHMOD" ;;
- *-aix*) TARGET=gcc; append-cppflags "-DNO_LCHMOD"; append-ldflags "-Wl,-blibpath:${EPREFIX}/usr/$(get_libdir)" ;;
- *-hpux*) TARGET=gcc; append-ldflags "-Wl,+b,${EPREFIX}/usr/$(get_libdir)" ;;
- *-mint*) TARGET=generic ;;
- *-cygwin*) TARGET=generic ;;
- *) die "Unknown target, you suck" ;;
- esac
-
- [[ ${CHOST} == *linux* ]] && append-cppflags -DNO_LCHMOD
- use bzip2 && append-cppflags -DUSE_BZIP2
- use unicode && append-cppflags -DUNICODE_SUPPORT -DUNICODE_WCHAR -DUTF8_MAYBE_NATIVE
- append-cppflags -DLARGE_FILE_SUPPORT #281473
-
- ASFLAGS="${ASFLAGS} $(get_abi_var CFLAGS)" emake \
- -f unix/Makefile \
- ${TARGET} || die "emake failed"
-}
-
-src_install() {
- dobin unzip funzip unzipsfx unix/zipgrep || die "dobin failed"
- dosym unzip /usr/bin/zipinfo || die
- doman man/*.1
- dodoc BUGS History* README ToDo WHERE
-}
diff --git a/app-arch/unzip/unzip-6.0_p20.ebuild b/app-arch/unzip/unzip-6.0_p21-r2.ebuild
index bb988fe692..0f0cdaa560 100644
--- a/app-arch/unzip/unzip-6.0_p20.ebuild
+++ b/app-arch/unzip/unzip-6.0_p21-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
inherit eutils toolchain-funcs flag-o-matic
@@ -27,14 +27,12 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
local deb="${WORKDIR}"/debian/patches
- rm \
- "${deb}"/series \
- "${deb}"/02-branding-patch-this-is-debian-unzip \
- || die
- epatch "${deb}"/*
+ rm "${deb}"/02-this-is-debian-unzip.patch || die
+ eapply "${deb}"/*.patch
- epatch "${FILESDIR}"/${PN}-6.0-no-exec-stack.patch
- use natspec && epatch "${FILESDIR}/${PN}-6.0-natspec.patch" #275244
+ eapply "${FILESDIR}"/${PN}-6.0-no-exec-stack.patch
+ eapply "${FILESDIR}"/${PN}-6.0-format-security.patch
+ use natspec && eapply "${FILESDIR}/${PN}-6.0-natspec.patch" #275244
sed -i -r \
-e '/^CFLAGS/d' \
-e '/CFLAGS/s:-O[0-9]?:$(CFLAGS) $(CPPFLAGS):' \
@@ -54,7 +52,7 @@ src_prepare() {
# Delete bundled code to make sure we don't use it.
rm -r bzip2 || die
- epatch_user
+ eapply_user
}
src_configure() {
@@ -75,7 +73,7 @@ src_configure() {
[[ ${CHOST} == *linux* ]] && append-cppflags -DNO_LCHMOD
use bzip2 && append-cppflags -DUSE_BZIP2
- use unicode && append-cppflags -DUNICODE_SUPPORT -DUNICODE_WCHAR -DUTF8_MAYBE_NATIVE
+ use unicode && append-cppflags -DUNICODE_SUPPORT -DUNICODE_WCHAR -DUTF8_MAYBE_NATIVE -DUSE_ICONV_MAPPING
append-cppflags -DLARGE_FILE_SUPPORT #281473
}