aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikhail Pukhlikov <cynede@gentoo.org>2020-05-18 13:11:04 +0400
committerMikhail Pukhlikov <cynede@gentoo.org>2020-05-18 13:11:04 +0400
commit17283ef6f8f9ef274e34dd3c2fa9814362d4d3ce (patch)
treee0b0ac6960850d1fad3f856e512d3c3ed6e80479
parentbump rust (diff)
downloadrust-17283ef6f8f9ef274e34dd3c2fa9814362d4d3ce.tar.gz
rust-17283ef6f8f9ef274e34dd3c2fa9814362d4d3ce.tar.bz2
rust-17283ef6f8f9ef274e34dd3c2fa9814362d4d3ce.zip
virtual/rust: multilib support
Signed-off-by: Mikhail Pukhlikov <cynede@gentoo.org>
-rw-r--r--virtual/rust/rust-1.43.1-r666.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/virtual/rust/rust-1.43.1-r666.ebuild b/virtual/rust/rust-1.43.1-r666.ebuild
index a16b9a6..63b7dbb 100644
--- a/virtual/rust/rust-1.43.1-r666.ebuild
+++ b/virtual/rust/rust-1.43.1-r666.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit multilib-build
+
DESCRIPTION="Virtual for Rust language compiler"
HOMEPAGE=""
SRC_URI=""
@@ -12,4 +14,4 @@ SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
BDEPEND=""
-RDEPEND="|| ( =dev-lang/rust-${PVR}* =dev-lang/rust-bin-${PV}* )"
+RDEPEND="|| ( =dev-lang/rust-${PVR}*[${MULTILIB_USEDEP}] =dev-lang/rust-bin-${PV}*[${MULTILIB_USEDEP}] )"