aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcnd <cynede@gentoo.org>2019-10-25 23:05:58 +0400
committerGitHub <noreply@github.com>2019-10-25 23:05:58 +0400
commit902a621d6943a145e701f4dcbe54eaa57f418591 (patch)
tree6cf90ca32f3a01801169075d66aa50c3f4fa3229
parentMerge pull request #457 from stefson/remove-rust-patch (diff)
parentdev-lang/rust: add reference to upstream bug 65757 (diff)
downloadrust-902a621d6943a145e701f4dcbe54eaa57f418591.tar.gz
rust-902a621d6943a145e701f4dcbe54eaa57f418591.tar.bz2
rust-902a621d6943a145e701f4dcbe54eaa57f418591.zip
Merge pull request #458 from stefson/fix-#454
dev-lang/rust: use tar.xz for stage0 rather than tar.gz
-rw-r--r--dev-lang/rust/files/37c5cb8118b6de04dd5d4e5e43787c8b83339472.patch46
-rw-r--r--dev-lang/rust/rust-999.ebuild4
-rw-r--r--dev-lang/rust/rust-9999.ebuild6
3 files changed, 55 insertions, 1 deletions
diff --git a/dev-lang/rust/files/37c5cb8118b6de04dd5d4e5e43787c8b83339472.patch b/dev-lang/rust/files/37c5cb8118b6de04dd5d4e5e43787c8b83339472.patch
new file mode 100644
index 0000000..6504fbe
--- /dev/null
+++ b/dev-lang/rust/files/37c5cb8118b6de04dd5d4e5e43787c8b83339472.patch
@@ -0,0 +1,46 @@
+From 37c5cb8118b6de04dd5d4e5e43787c8b83339472 Mon Sep 17 00:00:00 2001
+From: stefson <hidden@yahoo.de>
+Date: Fri, 25 Oct 2019 13:20:03 +0200
+Subject: [PATCH] rust/src/bootstrap.py: change src url from tar.gz to tar.xz
+
+---
+ src/bootstrap/bootstrap.py | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/bootstrap/bootstrap.py b/src/bootstrap/bootstrap.py
+index 4caf36a6f2a5..6c2f522f50d6 100644
+--- a/src/bootstrap/bootstrap.py
++++ b/src/bootstrap/bootstrap.py
+@@ -105,7 +105,7 @@ def verify(path, sha_path, verbose):
+ def unpack(tarball, dst, verbose=False, match=None):
+ """Unpack the given tarball file"""
+ print("extracting", tarball)
+- fname = os.path.basename(tarball).replace(".tar.gz", "")
++ fname = os.path.basename(tarball).replace(".tar.xz", "")
+ with contextlib.closing(tarfile.open(tarball)) as tar:
+ for member in tar.getnames():
+ if "/" not in member:
+@@ -349,12 +349,12 @@ def download_stage0(self):
+ self.program_out_of_date(self.rustc_stamp())):
+ if os.path.exists(self.bin_root()):
+ shutil.rmtree(self.bin_root())
+- filename = "rust-std-{}-{}.tar.gz".format(
++ filename = "rust-std-{}-{}.tar.xz".format(
+ rustc_channel, self.build)
+ pattern = "rust-std-{}".format(self.build)
+ self._download_stage0_helper(filename, pattern)
+
+- filename = "rustc-{}-{}.tar.gz".format(rustc_channel, self.build)
++ filename = "rustc-{}-{}.tar.xz".format(rustc_channel, self.build)
+ self._download_stage0_helper(filename, "rustc")
+ self.fix_executable("{}/bin/rustc".format(self.bin_root()))
+ self.fix_executable("{}/bin/rustdoc".format(self.bin_root()))
+@@ -372,7 +372,7 @@ def download_stage0(self):
+ if self.cargo().startswith(self.bin_root()) and \
+ (not os.path.exists(self.cargo()) or
+ self.program_out_of_date(self.cargo_stamp())):
+- filename = "cargo-{}-{}.tar.gz".format(cargo_channel, self.build)
++ filename = "cargo-{}-{}.tar.xz".format(cargo_channel, self.build)
+ self._download_stage0_helper(filename, "cargo")
+ self.fix_executable("{}/bin/cargo".format(self.bin_root()))
+ with output(self.cargo_stamp()) as cargo_stamp:
diff --git a/dev-lang/rust/rust-999.ebuild b/dev-lang/rust/rust-999.ebuild
index 1e20a71..aa2be45 100644
--- a/dev-lang/rust/rust-999.ebuild
+++ b/dev-lang/rust/rust-999.ebuild
@@ -74,6 +74,7 @@ DEPEND="${COMMON_DEPEND}
>=sys-devel/clang-3.5
)
dev-util/cmake
+ app-arch/xz-utils
"
RDEPEND="${COMMON_DEPEND}
@@ -90,6 +91,9 @@ REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )
PATCHES=(
"${FILESDIR}"/pr65474.patch
+
+ # upstream issue: https://github.com/rust-lang/rust/issues/65757
+ "${FILESDIR}"/37c5cb8118b6de04dd5d4e5e43787c8b83339472.patch
)
S="${WORKDIR}/${MY_P}-src"
diff --git a/dev-lang/rust/rust-9999.ebuild b/dev-lang/rust/rust-9999.ebuild
index 238b918..a418d09 100644
--- a/dev-lang/rust/rust-9999.ebuild
+++ b/dev-lang/rust/rust-9999.ebuild
@@ -72,6 +72,7 @@ DEPEND="${COMMON_DEPEND}
>=sys-devel/clang-3.5
)
dev-util/cmake
+ app-arch/xz-utils
"
RDEPEND="${COMMON_DEPEND}
@@ -86,7 +87,10 @@ REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )
?? ( system-llvm sanitize )
"
-#PATCHES=()
+PATCHES=(
+ # upstream issue: https://github.com/rust-lang/rust/issues/65757
+ "${FILESDIR}"/37c5cb8118b6de04dd5d4e5e43787c8b83339472.patch
+ )
S="${WORKDIR}/${MY_P}-src"