summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Perlov <perlovka@gmail.com>2020-05-22 03:51:44 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2020-05-25 22:41:10 +0300
commit039f4330b472cdff9414557b11e695d058451e27 (patch)
treeecb9ed0a688be0ce86f4e2ef94f01be7047bd777
parentdev-libs/libsavitar: version bump to 4.6.1 (diff)
downloadgentoo-039f4330b472cdff9414557b11e695d058451e27.tar.gz
gentoo-039f4330b472cdff9414557b11e695d058451e27.tar.bz2
gentoo-039f4330b472cdff9414557b11e695d058451e27.zip
dev-python/uranium: version bump to 4.6.1
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Michael Perlov <perlovka@gmail.com> Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
-rw-r--r--dev-python/uranium/Manifest1
-rw-r--r--dev-python/uranium/files/uranium-4.6.1-fix-install-paths.patch32
-rw-r--r--dev-python/uranium/uranium-4.6.1.ebuild76
3 files changed, 109 insertions, 0 deletions
diff --git a/dev-python/uranium/Manifest b/dev-python/uranium/Manifest
index b348616a1c15..2757e84d142a 100644
--- a/dev-python/uranium/Manifest
+++ b/dev-python/uranium/Manifest
@@ -1 +1,2 @@
DIST uranium-4.3.0.tar.gz 899153 BLAKE2B 314dbeed1cce49d33439b2fa744d37e4b360edb041964d2c3336730295b88bb2af86df8eac8382a6696fbc9c1ba07fa0774089ec3aa7fd0f8fbb92c61ce2825b SHA512 eac28907ccd66e5a43012a6f5af2a97daea21f0e2832613562e848cca967e036fea117811d8a4cc519c1417a113449e7065233fc541347202c6a8ff85a9d60b7
+DIST uranium-4.6.1.tar.gz 1013314 BLAKE2B 2a89eb1c4ffab35879eea9a681ea20e9cc5f78736d9c8bda5bf33baf5ef6d3f6418fd1f4b779738d644afd2d553d500c4892559ae402eeab0c38a4d95b295cf5 SHA512 ba7ed12d507fb1bd08fc0e77285933802a31b63d09f2dd0c7329e5644f82e6372fa11a1bbc28f3f1928ae0acfb3cb0afdeedf8e90e619c484fd5f623f8af722a
diff --git a/dev-python/uranium/files/uranium-4.6.1-fix-install-paths.patch b/dev-python/uranium/files/uranium-4.6.1-fix-install-paths.patch
new file mode 100644
index 000000000000..5777065e9da8
--- /dev/null
+++ b/dev-python/uranium/files/uranium-4.6.1-fix-install-paths.patch
@@ -0,0 +1,32 @@
+--- Uranium-4.5.0-orig/CMakeLists.txt 2020-03-01 16:26:44.736355687 +0200
++++ Uranium-4.5.0/CMakeLists.txt 2020-02-24 17:02:05.000000000 +0200
+@@ -12,6 +12,16 @@
+
+ find_package(PythonInterp 3.5.0 REQUIRED)
+
++if(NOT PYTHON_SITE_PACKAGES_DIR)
++ if(APPLE OR WIN32)
++ set(PYTHON_SITE_PACKAGES_DIR lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
++ CACHE STRING "Directory to install Python bindings to")
++ else()
++ set(PYTHON_SITE_PACKAGES_DIR lib/python${PYTHON_VERSION_MAJOR}/dist-packages CACHE
++ STRING "Directory to install Python bindings to")
++ endif()
++endif()
++
+ # # Checks using pylint
+ # Note that we use exit 0 here to not mark the build as a failure on check failure
+ # In addition, the specified pylint configuration uses the spellchecker plugin. This required python-enchant to be installed.
+@@ -48,10 +58,10 @@
+ if(EXISTS /etc/debian_version)
+ install(DIRECTORY UM DESTINATION lib${LIB_SUFFIX}/python${PYTHON_VERSION_MAJOR}/dist-packages)
+ else()
+- install(DIRECTORY UM DESTINATION lib${LIB_SUFFIX}/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages)
++ install(DIRECTORY UM DESTINATION ${PYTHON_SITE_PACKAGES_DIR})
+ endif()
+ install(FILES ${CMAKE_SOURCE_DIR}/cmake/UraniumTranslationTools.cmake
+- DESTINATION ${CMAKE_INSTALL_DATADIR}/cmake-${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}/Modules/ )
++ DESTINATION ${CMAKE_INSTALL_DATADIR}/cmake/Modules/ )
+ install(DIRECTORY resources DESTINATION ${CMAKE_INSTALL_DATADIR}/uranium)
+
+ # Detect plugins to install
diff --git a/dev-python/uranium/uranium-4.6.1.ebuild b/dev-python/uranium/uranium-4.6.1.ebuild
new file mode 100644
index 000000000000..e2a3e9d997e2
--- /dev/null
+++ b/dev-python/uranium/uranium-4.6.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit cmake python-single-r1
+
+MY_PN="Uranium"
+
+DESCRIPTION="A Python framework for building 3D printing related applications"
+HOMEPAGE="https://github.com/Ultimaker/Uranium"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="${PYTHON_DEPS}
+ sys-devel/gettext
+ doc? ( app-doc/doxygen )
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest[${PYTHON_MULTI_USEDEP}]
+ dev-python/mypy[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
+
+DEPEND="${PYTHON_DEPS}
+ ~dev-libs/libarcus-${PV}:=[python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[${PYTHON_MULTI_USEDEP},declarative,network,svg]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ >=sci-libs/scipy-1.1[${PYTHON_MULTI_USEDEP}]
+ sci-libs/Shapely[${PYTHON_MULTI_USEDEP}]
+ ')"
+
+RDEPEND="${DEPEND}
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtquickcontrols2:5"
+
+DOCS=( README.md )
+
+PATCHES=( "${FILESDIR}/${PN}-4.6.1-fix-install-paths.patch" )
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)"
+ )
+ cmake_src_configure
+
+ if ! use debug; then
+ sed -i 's/logging.DEBUG/logging.ERROR/' plugins/ConsoleLogger/ConsoleLogger.py || die
+ sed -i 's/logging.DEBUG/logging.ERROR/' plugins/FileLogger/FileLogger.py || die
+ fi
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc; then
+ cmake_src_compile doc
+ HTML_DOCS=( html )
+ fi
+}
+
+src_install() {
+ cmake_src_install
+ python_optimize
+ python_optimize "${D}/usr/$(get_libdir)"
+}