summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-08-06 09:13:10 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-08-06 09:13:22 -0400
commit04f2266c04d25ad22d14e22a5f10b75e5572e8c4 (patch)
treeaced9f70d4e401f805db1fa08aaa9ca355aabcaa
parentsci-mathematics/primesieve: stabilize 7.9 for amd64 (diff)
downloadgentoo-04f2266c04d25ad22d14e22a5f10b75e5572e8c4.tar.gz
gentoo-04f2266c04d25ad22d14e22a5f10b75e5572e8c4.tar.bz2
gentoo-04f2266c04d25ad22d14e22a5f10b75e5572e8c4.zip
sci-mathematics/primesieve: drop 7.7
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--sci-mathematics/primesieve/Manifest1
-rw-r--r--sci-mathematics/primesieve/primesieve-7.7.ebuild50
2 files changed, 0 insertions, 51 deletions
diff --git a/sci-mathematics/primesieve/Manifest b/sci-mathematics/primesieve/Manifest
index 97e69ce5c74d..cd41bbd1bc6f 100644
--- a/sci-mathematics/primesieve/Manifest
+++ b/sci-mathematics/primesieve/Manifest
@@ -1,2 +1 @@
-DIST primesieve-7.7.tar.gz 101558 BLAKE2B cfaa91ddcf661e265d403f8a93461fe297ac48db843b096d0dd7828c4e3d11cdba60cb102197248359c79950fe2ac66c8e9295ab17b0d6bd0eed5a6260c7d115 SHA512 bbcc141a12afdf54386d2408e067b1c6af2dd9b5c9f44d71290269ddefc7c46ba6794064cde6728c8356724553cb6bc2e765bf18c24a18b6d5d1f472d2c6e6dd
DIST primesieve-7.9.tar.gz 111361 BLAKE2B 8e227bd04a89dd5e8ea5dc5e79afa1c5254216863086fd6c3712fb45767ee7e5e23e72d166ada17295e56479e0c0e1ae7f215b72e124e5234a79fb20f340cb3f SHA512 fcfc3445e5becd555b66743f6d73dd4a0cbb48b1d4a3d0d22043261f1861e0631bdeb8702b1f942110f8b327a01173b231accd1f7595600308709832bbbafc06
diff --git a/sci-mathematics/primesieve/primesieve-7.7.ebuild b/sci-mathematics/primesieve/primesieve-7.7.ebuild
deleted file mode 100644
index 65d0b3d3e93a..000000000000
--- a/sci-mathematics/primesieve/primesieve-7.7.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="CLI and library for quickly generating prime numbers"
-HOMEPAGE="https://github.com/kimwalisch/primesieve"
-SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD-2"
-SLOT="0/9" # subslot is first component of libprimesieve.so version
-KEYWORDS="amd64"
-IUSE="doc +executable test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="doc? ( app-doc/doxygen app-text/texlive media-gfx/graphviz )"
-DEPEND=""
-RDEPEND=""
-
-DOCS=(
- ChangeLog
- README.md
- doc/ALGORITHMS.md
- doc/CPP_Examples.md
- doc/C_Examples.md
-)
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_DOC="$(usex doc)"
- -DBUILD_PRIMESIEVE="$(usex executable)"
- -DBUILD_STATIC_LIBS="OFF"
- -DBUILD_TESTS="$(usex test)"
- )
-
- if use doc; then
- DOCS+=(
- "${BUILD_DIR}/doc/html"
- "${BUILD_DIR}/doc/latex/refman.pdf"
- )
- fi
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- use doc && cmake_build doc
-}