summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-29 05:02:08 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-29 05:26:19 +0200
commit05aa576fa28bbc88b5bf76037d58b488c9dc63ba (patch)
treeb6febba2c8865a8afcf2e573814a2d0e22144b31
parentdev-python/pytools: Bump to 2024.1.6 (diff)
downloadgentoo-05aa576fa28bbc88b5bf76037d58b488c9dc63ba.tar.gz
gentoo-05aa576fa28bbc88b5bf76037d58b488c9dc63ba.tar.bz2
gentoo-05aa576fa28bbc88b5bf76037d58b488c9dc63ba.zip
dev-python/scikit-build-core: Bump to 0.9.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/scikit-build-core/Manifest1
-rw-r--r--dev-python/scikit-build-core/scikit-build-core-0.9.8.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/scikit-build-core/Manifest b/dev-python/scikit-build-core/Manifest
index d686d71a5648..10f16b64fddb 100644
--- a/dev-python/scikit-build-core/Manifest
+++ b/dev-python/scikit-build-core/Manifest
@@ -1,3 +1,4 @@
DIST scikit_build_core-0.9.5.tar.gz 228404 BLAKE2B 6b3aa905a63b73147e1a760bf8e0265395f6e2b5cce2a24594ee384f6e8ad31d7d16e76e7666115e5a962f49c2f2a4c622a33ac5e3a11443cfc2ed50e0801589 SHA512 fade6192347ea9d3010a24de7c1b868aea14fa2028a064fe397db26e15437f74f3d9b017be940855d57db32cb867cfa9bab1902bc1f51f96589a38b9478d01bc
DIST scikit_build_core-0.9.6.tar.gz 228743 BLAKE2B da5dff989ca053c9ee1abfff739d0b755bb14f9d810020e4b44ba5caad670dfe24ef99b4cb93a18ae162dca8fe21d6d09c4d692ff1406bfa3a64ca25c24aeddb SHA512 b2b1e9b4baefc360b26dfc0bbf0edef20d7b6681140ef9a413c565666869e67ddce2cdd3027f3de6af29b7ef76bd7eeb401c08f3803524706d0ace9106b63f65
DIST scikit_build_core-0.9.7.tar.gz 229179 BLAKE2B 0a21c46187a529290ce12afc4f352d563cac167a166bc9c62a865756975c2c95f2cdf1aa2ddc1d5d80f8f22c7145fdfef9da64084e28895086ca43b06b3d3726 SHA512 c269424ec70a6ca6eee1a18ba34bd58fa155d3f596c42424f691dce4511112a50ca89196835c19f6b5d0fa6903a2a9a6d51f5978931bfb836cf27569eb39a1eb
+DIST scikit_build_core-0.9.8.tar.gz 229845 BLAKE2B 419d8891dd3f95bee7f8f7dcc1addb94d2698f8ff392eef19a67e851f57b58d09b9878705d0e8d728d3c6f2b316d538c76471164781fcd1fb5d02dfbfd9d7a85 SHA512 f1206715eef1bdeccddc5987cae4f455522c4ef4dbca305ad7d3772c61f5615c5742b109c5527a5ad5e25a2348abff69ea5ae7153ac18c43cca63783872aa3d5
diff --git a/dev-python/scikit-build-core/scikit-build-core-0.9.8.ebuild b/dev-python/scikit-build-core/scikit-build-core-0.9.8.ebuild
new file mode 100644
index 000000000000..729919e913ae
--- /dev/null
+++ b/dev-python/scikit-build-core/scikit-build-core-0.9.8.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Build backend for CMake based projects"
+HOMEPAGE="
+ https://github.com/scikit-build/scikit-build-core/
+ https://pypi.org/project/scikit-build-core/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# we always want [pyproject] extra
+RDEPEND="
+ app-alternatives/ninja
+ dev-build/cmake
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-metadata-0.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.2.2[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ >=dev-python/cattrs-22.2.0[${PYTHON_USEDEP}]
+ dev-python/fastjsonschema[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ >=dev-python/pytest-subprocess-1.5[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local _EPYTEST_DESELECT=(
+ # TODO / we don't package validate_pyproject anyway
+ tests/test_schema.py::test_compare_schemas
+ # setuptools now respects PEP 625
+ tests/test_setuptools_pep517.py::test_pep517_sdist
+ )
+ local EPYTEST_IGNORE=(
+ # needs unpackaged validate_pyproject
+ tests/test_schema.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p subprocess -m "not isolated and not network"
+}