summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-04-17 12:39:33 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2020-04-17 12:39:54 -0700
commit073532b17c2d28bd996e0ba9def8690405f2c85b (patch)
tree064a6c58ef36220433121bb833f075eb3fc0018c
parentwww-client/chromium: security cleanup (diff)
downloadgentoo-073532b17c2d28bd996e0ba9def8690405f2c85b.tar.gz
gentoo-073532b17c2d28bd996e0ba9def8690405f2c85b.tar.bz2
gentoo-073532b17c2d28bd996e0ba9def8690405f2c85b.zip
sys-apps/iproute2: QAfix emptydir /var/lib/arpd
Closes: https://bugs.gentoo.org/647032 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-rw-r--r--sys-apps/iproute2/iproute2-5.6.0.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/sys-apps/iproute2/iproute2-5.6.0.ebuild b/sys-apps/iproute2/iproute2-5.6.0.ebuild
index 9e2e1f7f4e54..7670dd448c2e 100644
--- a/sys-apps/iproute2/iproute2-5.6.0.ebuild
+++ b/sys-apps/iproute2/iproute2-5.6.0.ebuild
@@ -158,5 +158,7 @@ src_install() {
# bug 47482, arpd doesn't need to be in /sbin
dodir /usr/bin
mv "${ED}"/sbin/arpd "${ED}"/usr/bin/ || die
+ elif [[ -d "${ED}"/var/lib/arpd ]]; then
+ rmdir "${ED}"/var/lib/arpd || die
fi
}