summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-06 17:40:42 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-06 18:45:52 +0100
commit0b3920a45c89bfccb3845efdb68710ac5018de99 (patch)
treebb294507529cc38575a06cf21d06d2b2eb39f39c
parentdev-python/sphinx: Bump to 3.5.2 (diff)
downloadgentoo-0b3920a45c89bfccb3845efdb68710ac5018de99.tar.gz
gentoo-0b3920a45c89bfccb3845efdb68710ac5018de99.tar.bz2
gentoo-0b3920a45c89bfccb3845efdb68710ac5018de99.zip
dev-python/croniter: Bump to 1.0.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/croniter/Manifest1
-rw-r--r--dev-python/croniter/croniter-1.0.8.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/croniter/Manifest b/dev-python/croniter/Manifest
index 8b3246d9496b..dab7bedff33c 100644
--- a/dev-python/croniter/Manifest
+++ b/dev-python/croniter/Manifest
@@ -1,3 +1,4 @@
DIST croniter-1.0.2.tar.gz 29809 BLAKE2B d7e5b668f97f98efdf992de4dd92bbddd8197275557364516af5d74b8376260967b249723dfda1d835c60dd185612a45f6ed6447609c593ad108ae1b738cefc7 SHA512 6e4b593dbbb5e3e1ce9a25ad709a1970f22feb1d0a2bf7fa97b8cc3eb43fbe896a842f74b3fc3cd08e3d414767cc661bf5c5307a206c42e1f0de5776b2b24310
DIST croniter-1.0.6.tar.gz 30489 BLAKE2B a3caf1d0606dbec7a978e5089b08bf6edb13533524f5a3f1639483547b14a83f099276f4c63e9b84031202c088a8237326f70ecaca0bf3503f4a33173ce0d358 SHA512 1ca37c7dbd6a7365db112ccd474d76babc890aad1e2c341677be13c4f4e28a98219266efc065442e2077588a36b60c01d8e2996f0a32def690cf49e2c7c584bc
DIST croniter-1.0.7.tar.gz 30735 BLAKE2B 0cd033fd669e8b5ce58136898f8409bc1d3253d7e6b7d8b6d09792fad715656fa51655930aa4fd7b7f771fd8684048dd3d5bcc28510882b7c726ccc5636c87b2 SHA512 db31271889b95333c2bfdb371804bc9ca5197c96b20ad5bd4bf2d81f86b58d43266be8a76c481d28ef4e8f7ae9e4f21947754d6a721ed71ccd0ff0143c80b918
+DIST croniter-1.0.8.tar.gz 31019 BLAKE2B a637f7df806a85aeb236c38a9fa19ed0929fd257268cbe98bf7b281f1c52a9bfe98c91063da48b1344946f6619c5ac8f0e89051c1672fa6997c830dd97b7d9f2 SHA512 cf620baa55709c2379cc7f8f0123bd79e03b7dabaecd539633b8f52f97aa617c48e5692e0a45c08f4b30b2fab52c47cfc502c2ea550329083db2353ecdc56635
diff --git a/dev-python/croniter/croniter-1.0.8.ebuild b/dev-python/croniter/croniter-1.0.8.ebuild
new file mode 100644
index 000000000000..872a3960c97a
--- /dev/null
+++ b/dev-python/croniter/croniter-1.0.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to provide iteration for datetime object"
+HOMEPAGE="https://github.com/kiorky/croniter https://pypi.org/project/croniter/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest