summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-22 08:34:30 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-22 09:36:56 +0200
commit0b9332e3b789f6a6b508ed55b879bea2c57e17c2 (patch)
treef1c3470ec8e310b58f3297403cce61aad131c915
parentxfce-base/xfce4-appfinder: Bump to 4.17.0 (diff)
downloadgentoo-0b9332e3b789f6a6b508ed55b879bea2c57e17c2.tar.gz
gentoo-0b9332e3b789f6a6b508ed55b879bea2c57e17c2.tar.bz2
gentoo-0b9332e3b789f6a6b508ed55b879bea2c57e17c2.zip
dev-python/dask: Bump to 2021.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dask/Manifest1
-rw-r--r--dev-python/dask/dask-2021.9.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/dask/Manifest b/dev-python/dask/Manifest
index 74fca4f87558..bea81d880f61 100644
--- a/dev-python/dask/Manifest
+++ b/dev-python/dask/Manifest
@@ -1,2 +1,3 @@
DIST dask-2021.8.1.tar.gz 3786161 BLAKE2B cb47b900e4769113e28e1cea70cb65008debb25431c05792666ca1d9aef9143061d1b0c2ce825ff1a22312c4cc615a2878591fc93236521811c19a35e70446b1 SHA512 aff7b92b66ab5d8858eb28d416c3661e64400a8ddcc9135b74b1bf3cad195a4fc55a00365c5602cb0b66ef8506e73c0f6bd2d3972ce8744d2e77095cdf040d11
DIST dask-2021.9.0.tar.gz 3792016 BLAKE2B f2538c9df5783f087f555945234b4d31c5f02a539eaf14bffdc05e4d3f62d5ef309289e216434e477a728837e9556b2f50a0aadf8a943380496168c62577c356 SHA512 b821c38faf9cdf6574eab8014d4acb95f37cc260c9c3ad2c19fbdf24c3ed9fa5c9cfa35fdaf53f7b640b3c8a86eb6b60c2e5e9bcb7760870023451c6c383545f
+DIST dask-2021.9.1.tar.gz 3794819 BLAKE2B c3ed5050581f41c4ea82ad9d1d233205f105434e5e6dcc654ba2e999b8cf105033d58ecf045d2063dabcb701cb2af6f092ecfd8435d24e5949ed2d39b54ae19e SHA512 20beca3f68c2e21d54c941049a1f352e19fcce7b5f7ecf84abf60cfb9979551a3e83938ca5439b662d35c0b64b26d726f6fea85641e737d0060c56a2e879755e
diff --git a/dev-python/dask/dask-2021.9.1.ebuild b/dev-python/dask/dask-2021.9.1.ebuild
new file mode 100644
index 000000000000..a4142fe932b3
--- /dev/null
+++ b/dev-python/dask/dask-2021.9.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
+HOMEPAGE="https://dask.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cloudpickle-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ >=dev-python/partd-0.3.10[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/toolz[${PYTHON_USEDEP}]
+ test? (
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/numexpr[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:flaky -m "not network"
+}