summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2023-08-21 15:31:33 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2023-08-21 15:31:33 +0000
commit0d25fece54d259f6eb004ec683962b9486779407 (patch)
tree855fcb7d09fe4322cea24a51e18b20fe13c06096
parent2023-08-21 15:01:45 UTC (diff)
parentdev-python/pytest-qt: enable py3.12 (diff)
downloadgentoo-0d25fece54d259f6eb004ec683962b9486779407.tar.gz
gentoo-0d25fece54d259f6eb004ec683962b9486779407.tar.bz2
gentoo-0d25fece54d259f6eb004ec683962b9486779407.zip
Merge updates from master
-rw-r--r--dev-python/QtPy/QtPy-2.3.1-r1.ebuild218
-rw-r--r--dev-python/pytest-qt/pytest-qt-4.2.0.ebuild23
-rw-r--r--net-libs/grpc/Manifest1
-rw-r--r--net-libs/grpc/grpc-1.52.1-r1.ebuild (renamed from net-libs/grpc/grpc-1.52.1.ebuild)17
-rw-r--r--profiles/arch/amd64/package.use.stable.mask4
5 files changed, 256 insertions, 7 deletions
diff --git a/dev-python/QtPy/QtPy-2.3.1-r1.ebuild b/dev-python/QtPy/QtPy-2.3.1-r1.ebuild
new file mode 100644
index 000000000000..b6127a1aae93
--- /dev/null
+++ b/dev-python/QtPy/QtPy-2.3.1-r1.ebuild
@@ -0,0 +1,218 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 virtualx pypi
+
+DESCRIPTION="Abstraction layer on top of PyQt and PySide with additional custom QWidgets"
+HOMEPAGE="
+ https://github.com/spyder-ide/qtpy/
+ https://pypi.org/project/QtPy/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+_IUSE_QT_MODULES="
+ designer +gui help multimedia +network opengl positioning
+ printsupport qml quick serialport +sql svg testlib
+ webchannel webengine websockets +widgets +xml
+"
+IUSE="+pyqt5 pyqt6 pyside2 pyside6 ${_IUSE_QT_MODULES}"
+unset _IUSE_QT_MODULES
+
+REQUIRED_USE="
+ || ( pyqt5 pyqt6 pyside2 pyside6 )
+ python_targets_python3_12? ( !pyside2 !pyside6 )
+"
+
+# These flags are currently *not* common to the PySide2/6 and PyQt5/6 ebuilds
+# Disable them for now, please check periodically if this is still up to date.
+# bluetooth? ( pyqt5 only )
+# dbus? ( pyqt5 only )
+#
+# 3d? ( pyside2 only )
+# charts? ( pyside2 only )
+# concurrent? ( pyside2 only )
+# datavis? ( pyside2 only )
+# scxml? ( pyside2 only )
+# script? ( pyside2 only )
+# scripttools? ( pyside2 only )
+#
+# location? ( pyside2 and pyqt5 only )
+# sensors? ( pyside2 and pyqt5 only )
+# speech? ( pyside2 and pyqt5 only )
+# x11extras? ( pyside2 and pyqt5 only )
+# xmlpatterns? ( pyside2 and pyqt5 only )
+
+# WARNING: the obvious solution of using || for PyQt5/pyside2 is not going
+# to work. The package only checks whether PyQt5/pyside2 is installed, it does
+# not verify whether they have the necessary modules (i.e. satisfy the USE dep).
+#
+# Webengine is a special case, because PyQt5 provides this in a separate package
+# while PySide2 ships it in the same package.
+#
+# declarative/qml/quick is a special case, because PyQt5 bundles the bindings
+# for qml and quick in one flag: declarative PySide2 does not.
+#
+# The PyQt5 ebuild currently enables xml support unconditionally, the flag is
+# added anyway with a (+) to make it future proof if the ebuild were to change
+# this behaviour in the future.
+#
+# The PySide2 ebuild currently enables opengl and serialport support
+# unconditionally, the flag is added anyway with a (+) to make it future proof
+# if the ebuild were to change this behaviour in the future.
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ pyqt5? (
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ dev-python/PyQt5[designer?,gui?,help?,multimedia?,network?,opengl?]
+ dev-python/PyQt5[positioning?,printsupport?,serialport?,sql?,svg?]
+ dev-python/PyQt5[testlib?,webchannel?,websockets?,widgets?,xml(+)?]
+ qml? ( dev-python/PyQt5[declarative] )
+ quick? ( dev-python/PyQt5[declarative] )
+ webengine? ( dev-python/PyQtWebEngine[${PYTHON_USEDEP}] )
+ )
+ pyqt6? (
+ dev-python/PyQt6[${PYTHON_USEDEP}]
+ dev-python/PyQt6[designer?,gui?,help?,multimedia?,network?,opengl?]
+ dev-python/PyQt6[positioning?,printsupport?,qml?,quick?,serialport?,sql?]
+ dev-python/PyQt6[svg?,testlib?,webchannel?,websockets?,widgets?,xml?]
+ webengine? ( dev-python/PyQt6-WebEngine[${PYTHON_USEDEP},widgets?,quick?] )
+
+ )
+ pyside2? (
+ $(python_gen_cond_dep '
+ dev-python/pyside2[${PYTHON_USEDEP}]
+ dev-python/pyside2[designer?,gui?,help?,multimedia?,network?,opengl(+)?]
+ dev-python/pyside2[positioning?,printsupport?,qml?,quick?,serialport(+)?]
+ dev-python/pyside2[sql?,svg?,testlib?,webchannel?,webengine?,websockets?]
+ dev-python/pyside2[widgets?,xml?]
+ ' python3_{10..11})
+ )
+ pyside6? (
+ $(python_gen_cond_dep '
+ dev-python/pyside6[${PYTHON_USEDEP}]
+ dev-python/pyside6[designer?,gui?,help?,multimedia?,network?,opengl?]
+ dev-python/pyside6[positioning?,printsupport?,qml?,quick?,serialport?]
+ dev-python/pyside6[sql?,svg?,testlib?,webchannel?,webengine?,websockets?]
+ dev-python/pyside6[widgets?,xml?]
+ ' python3_{10..11})
+ )
+"
+
+# The QtPy testsuite skips tests for bindings that are not installed, so here we
+# ensure that everything is available and all tests are run. Note that not
+# all flags are available in PyQt5/PySide2, so some tests are still skipped.
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ pyqt5? (
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ dev-python/PyQt5[bluetooth,dbus,declarative,designer,gui,help,location]
+ dev-python/PyQt5[multimedia,network,opengl,positioning,printsupport]
+ dev-python/PyQt5[sensors,serialport,speech(-),sql,svg,testlib,webchannel]
+ dev-python/PyQt5[websockets,widgets,x11extras,xml(+),xmlpatterns]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ )
+ pyqt6? (
+ dev-python/PyQt6[${PYTHON_USEDEP}]
+ dev-python/PyQt6[dbus,designer,gui,help,multimedia,network,opengl]
+ dev-python/PyQt6[positioning,printsupport,qml,quick,quick3d,serialport]
+ dev-python/PyQt6[sql,ssl,svg,testlib,webchannel,websockets,widgets,xml]
+ dev-python/PyQt6-WebEngine[${PYTHON_USEDEP},widgets,quick]
+ )
+ pyside2? (
+ $(python_gen_cond_dep '
+ dev-python/pyside2[${PYTHON_USEDEP}]
+ dev-python/pyside2[3d,charts,concurrent,datavis,designer,gui,help]
+ dev-python/pyside2[location,multimedia,network,opengl(+),positioning]
+ dev-python/pyside2[printsupport,qml,quick,script,scripttools,scxml]
+ dev-python/pyside2[sensors,serialport(+),speech,sql,svg,testlib]
+ dev-python/pyside2[webchannel,webengine,websockets,widgets,x11extras]
+ dev-python/pyside2[xml,xmlpatterns]
+ ' python3_{10..11})
+ )
+ pyside6? (
+ $(python_gen_cond_dep '
+ dev-python/pyside6[${PYTHON_USEDEP}]
+ dev-python/pyside6[concurrent,dbus,designer,gui,help,multimedia]
+ dev-python/pyside6[network,opengl,positioning,printsupport,qml]
+ dev-python/pyside6[quick,quick3d,serialport,sql,svg,testlib]
+ dev-python/pyside6[webchannel,webengine,websockets,widgets,xml]
+ ' python3_{10..11})
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i -e 's:--cov=qtpy --cov-report=term-missing::' pytest.ini || die
+ # Disable Qt for Python implementations that are not selected
+ if ! use pyqt5; then
+ sed -i -e "s/from PyQt5.QtCore import/raise ImportError #/" qtpy/__init__.py || die
+ fi
+ if ! use pyqt6; then
+ sed -i -e "s/from PyQt6.QtCore import/raise ImportError #/" qtpy/__init__.py || die
+ fi
+ if ! use pyside2; then
+ sed -i -e "s/from PySide2 import/raise ImportError #/" qtpy/__init__.py || die
+ sed -i -e "s/from PySide2.QtCore import/raise ImportError #/" qtpy/__init__.py || die
+ fi
+ if ! use pyside6; then
+ sed -i -e "s/from PySide6 import/raise ImportError #/" qtpy/__init__.py || die
+ sed -i -e "s/from PySide6.QtCore import/raise ImportError #/" qtpy/__init__.py || die
+ fi
+}
+
+python_test() {
+ # Test for each enabled Qt4Python target.
+ # Deselect the other targets, their test fails if we specify QT_API
+ # or if we have disabled their corresponding inherit in __init__.py above
+ if use pyqt5; then
+ einfo "Testing with ${EPYTHON} and QT_API=PyQt5"
+ QT_API="pyqt5" virtx epytest \
+ --deselect qtpy/tests/test_main.py::test_qt_api_environ[PySide2] \
+ --deselect qtpy/tests/test_main.py::test_qt_api_environ[PyQt6] \
+ --deselect qtpy/tests/test_main.py::test_qt_api_environ[PySide6]
+ fi
+ if use pyqt6; then
+ einfo "Testing with ${EPYTHON} and QT_API=PyQt6"
+ QT_API="pyqt6" virtx epytest \
+ --deselect qtpy/tests/test_main.py::test_qt_api_environ[PySide2] \
+ --deselect qtpy/tests/test_main.py::test_qt_api_environ[PyQt5] \
+ --deselect qtpy/tests/test_main.py::test_qt_api_environ[PySide6] \
+ --deselect qtpy/tests/test_qtsensors.py::test_qtsensors
+ # Qt6Sensors not yet packaged and enabled in PyQt6 ebuild
+ fi
+ if use pyside2; then
+ einfo "Testing with ${EPYTHON} and QT_API=PySide2"
+ QT_API="pyside2" virtx epytest \
+ --deselect qtpy/tests/test_main.py::test_qt_api_environ[PyQt5] \
+ --deselect qtpy/tests/test_main.py::test_qt_api_environ[PyQt6] \
+ --deselect qtpy/tests/test_main.py::test_qt_api_environ[PySide6]
+ fi
+ if use pyside6; then
+ einfo "Testing with ${EPYTHON} and QT_API=PySide6"
+ QT_API="pyside6" virtx epytest \
+ --deselect qtpy/tests/test_main.py::test_qt_api_environ[PySide2] \
+ --deselect qtpy/tests/test_main.py::test_qt_api_environ[PyQt5] \
+ --deselect qtpy/tests/test_main.py::test_qt_api_environ[PyQt6] \
+ --deselect qtpy/tests/test_qtsensors.py::test_qtsensors
+ # Qt6Sensors not yet packaged and enabled in PySide6 ebuild
+ fi
+}
+
+pkg_postinst() {
+ elog "When multiple Qt4Python targets are enabled QtPy will default to"
+ elog "the first enabled target in this order: PyQt5 PySide2 PyQt6 PySide6."
+ elog "This can be overridden with the QT_API environment variable."
+}
diff --git a/dev-python/pytest-qt/pytest-qt-4.2.0.ebuild b/dev-python/pytest-qt/pytest-qt-4.2.0.ebuild
index 81b76782132f..5c321c7bdf1f 100644
--- a/dev-python/pytest-qt/pytest-qt-4.2.0.ebuild
+++ b/dev-python/pytest-qt/pytest-qt-4.2.0.ebuild
@@ -5,8 +5,9 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} )
-PYSIDE2_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{10..12} )
+PYSIDE2_COMPAT=( python3_{10..11} )
+PYSIDE6_COMPAT=( python3_{10..11} )
inherit distutils-r1 virtualx pypi
@@ -26,9 +27,17 @@ RDEPEND="
BDEPEND="
test? (
dev-python/PyQt5[gui,testlib,widgets,${PYTHON_USEDEP}]
+ amd64? (
+ dev-python/PyQt6[gui,testlib,widgets,${PYTHON_USEDEP}]
+ )
$(python_gen_cond_dep '
dev-python/pyside2[gui,testlib,widgets,${PYTHON_USEDEP}]
' "${PYSIDE2_COMPAT[@]}")
+ amd64? (
+ $(python_gen_cond_dep '
+ dev-python/pyside6[gui,testlib,widgets,${PYTHON_USEDEP}]
+ ' "${PYSIDE6_COMPAT[@]}")
+ )
)
"
@@ -57,9 +66,17 @@ python_test() {
einfo "Testing with PyQt5"
PYTEST_QT_API="pyqt5" epytest || die
- # Pyside2 is not compatible with python3.11
+ if use amd64; then
+ einfo "Testing with PyQt6"
+ PYTEST_QT_API="pyqt6" epytest || die
+ fi
+ # Pyside{2,6} is not compatible with python3.12
if has "${EPYTHON}" "${PYSIDE2_COMPAT[@]/_/.}"; then
einfo "Testing with PySide2"
PYTEST_QT_API="pyside2" epytest || die
fi
+ if use amd64 && has "${EPYTHON}" "${PYSIDE6_COMPAT[@]/_/.}"; then
+ einfo "Testing with PySide6"
+ PYTEST_QT_API="pyside6" epytest || die
+ fi
}
diff --git a/net-libs/grpc/Manifest b/net-libs/grpc/Manifest
index 748c6d78954c..f96b5140be56 100644
--- a/net-libs/grpc/Manifest
+++ b/net-libs/grpc/Manifest
@@ -1 +1,2 @@
+DIST abseil-cpp-20220623.1.tar.gz 1957483 BLAKE2B 5bcf60b5a55882bcb78c7095a9892f6d1e5819fb116e325a8299fb22780ab009f0e1d92d5d8aca5ae0d4acc6d60e620e3357a24e389059f6e75d94f1cbdc1ced SHA512 ab4fccd9a2bfa0c5ad4b56c8e8f8b7ec7a8eca8b6cc6959802acadd1da785e1feb078c6ac621808cd699c82717a9e637dc426d94b70a8db7f2a807059d41cbc2
DIST grpc-1.52.1.tar.gz 8686340 BLAKE2B 0076ddd4a2840892f4ad11885e18f782b6a645337224974522c5f828d0226d6a1e19aaaf0f30ea3225d56118e0cfc251d45b8d5e6811c2d1a84e274ff037bb53 SHA512 06c69fb817af75b2610761a3a193178b749755eb7bed58875aa251def7c0c253cdaf02cf834c31c8b2cae7b01a6081e2aece4b131a162f64bd45ff0aff4d7758
diff --git a/net-libs/grpc/grpc-1.52.1.ebuild b/net-libs/grpc/grpc-1.52.1-r1.ebuild
index c36f6dbeb491..780e0ab91b8f 100644
--- a/net-libs/grpc/grpc-1.52.1.ebuild
+++ b/net-libs/grpc/grpc-1.52.1-r1.ebuild
@@ -3,13 +3,20 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
MY_PV="${PV//_pre/-pre}"
+# Check third_party/abseil-cpp's commit for each tag of ${PN}
+# It may correspond to a commit of abseil-cpp - if so, use the tarball for it
+# and not an arbitrary commit.
+ABSEIL_COMMIT="20220623.1"
DESCRIPTION="Modern open source high performance RPC framework"
HOMEPAGE="https://www.grpc.io"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/abseil/abseil-cpp/archive/refs/tags/${ABSEIL_COMMIT}.tar.gz -> abseil-cpp-${ABSEIL_COMMIT}.tar.gz
+"
LICENSE="Apache-2.0"
# format is 0/${CORE_SOVERSION//./}.${CPP_SOVERSION//./} , check top level CMakeLists.txt
@@ -19,7 +26,6 @@ IUSE="doc examples test"
# look for submodule versions in third_party dir
RDEPEND="
- =dev-cpp/abseil-cpp-20220623.1*:=
>=dev-libs/re2-0.2021.11.01:=
>=dev-libs/openssl-1.1.1:0=[-bindist(-)]
>=dev-libs/protobuf-3.18.1:=
@@ -72,7 +78,10 @@ src_configure() {
local mycmakeargs=(
-DgRPC_INSTALL=ON
- -DgRPC_ABSL_PROVIDER=package
+ -DgRPC_ABSL_PROVIDER=module
+ -DgRPC_INSTALL=OFF
+ -DABSL_ENABLE_INSTALL=OFF
+ -DABSL_ROOT_DIR="${WORKDIR}"/abseil-cpp-${ABSEIL_COMMIT}
-DgRPC_BACKWARDS_COMPATIBILITY_MODE=OFF
-DgRPC_CARES_PROVIDER=package
-DgRPC_INSTALL_CMAKEDIR="$(get_libdir)/cmake/${PN}"
diff --git a/profiles/arch/amd64/package.use.stable.mask b/profiles/arch/amd64/package.use.stable.mask
index 9f702cca9700..f2195e3d8fbe 100644
--- a/profiles/arch/amd64/package.use.stable.mask
+++ b/profiles/arch/amd64/package.use.stable.mask
@@ -17,6 +17,10 @@
#--- END OF EXAMPLES ---
+# Andrew Ammerlaan <andrewammerlaan@gentoo.org> (2023-08-21)
+# Mask testing on stable until we have stable qt6
+dev-python/pytest-qt test
+
# Matt Jolly <matt.jolly@footclan.ninja> (2023-08-10)
# net-libs/ngtcp2 is not marked stable
net-misc/curl nghttp3