summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2019-03-26 09:04:05 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2019-03-26 09:04:05 +0000
commit0f09ed692018b70a58206c4d5b0f9a76b4bffc8a (patch)
tree260f93ce6ce601787204842baf82ed8a9703a5ea
parent2019-03-26 08:44:23 UTC (diff)
parentsys-process/nmon: Bump to 16i (diff)
downloadgentoo-0f09ed692018b70a58206c4d5b0f9a76b4bffc8a.tar.gz
gentoo-0f09ed692018b70a58206c4d5b0f9a76b4bffc8a.tar.bz2
gentoo-0f09ed692018b70a58206c4d5b0f9a76b4bffc8a.zip
Merge updates from master
-rw-r--r--dev-python/flexmock/Manifest1
-rw-r--r--dev-python/flexmock/flexmock-0.10.4.ebuild33
-rw-r--r--sys-apps/baselayout-prefix/baselayout-prefix-2.6-r1.ebuild2
-rw-r--r--sys-apps/baselayout-prefix/baselayout-prefix-2.6.ebuild328
-rw-r--r--sys-auth/polkit/files/polkit-0.115-spidermonkey-60.patch180
-rw-r--r--sys-auth/polkit/polkit-0.115-r4.ebuild143
-rw-r--r--sys-process/nmon/Manifest1
-rw-r--r--sys-process/nmon/nmon-16i.ebuild52
-rw-r--r--x11-wm/i3/Manifest3
-rw-r--r--x11-wm/i3/files/i3-4.13-remove-git-polling.patch19
-rw-r--r--x11-wm/i3/i3-4.13-r1.ebuild88
-rw-r--r--x11-wm/i3/i3-4.16.1.ebuild (renamed from x11-wm/i3/i3-4.14.1.ebuild)15
12 files changed, 418 insertions, 447 deletions
diff --git a/dev-python/flexmock/Manifest b/dev-python/flexmock/Manifest
index 5733f1448532..7d6098a560d2 100644
--- a/dev-python/flexmock/Manifest
+++ b/dev-python/flexmock/Manifest
@@ -1,2 +1,3 @@
DIST flexmock-0.10.2.tar.gz 44425 BLAKE2B e49db5b7a4a739f72a2560c52d0493cc284641f7c54d11e67a4c40ae3681ed2ca22fdc17c9f8ffc667bef409e1ecb5e36acdcd73a968984a38992927ff7c416f SHA512 6824da47af260a93ad685b66bcbd2d9a93f98eec218242e0dd9ef885594d9218e4c7170c832a0b3ea3cf201896ec1efc2afacbffe1fc5dab032240369d7b3ac3
DIST flexmock-0.10.3.tar.gz 45017 BLAKE2B 03e6a709bd6c7889fa91692c27041f3d8109a57aa188a7043d5f45f757dd2bf929f80b9e57375bf7835ec4a88f032ed026c183320098546862f30c6bfedf6e8d SHA512 9c19e7a6765e57789065e6f5940270f5c0395194eddd8fedaf0abe52e0ffaaa33945385e981285caa1b7facb58be92b76dd0f370c242216626a30ab97b926bd1
+DIST flexmock-0.10.4.tar.gz 45362 BLAKE2B 4ff79cff3b0d8fb0c97bd60b0d5aa5555a7b939d3d6275a17c9bd1002b1d7acb53d4f63f5f834faf0d349d8b8d429eb063f121c4d7b6d12aa1bb3e7bdbadb861 SHA512 d190fcb66f0c2c4e3be2384d68b95a22c695ffa0fe8f8a218f2baa68c91683641396197cac69ddab21e4b0990b9930f56423bb7cd85770ceade9c22ece72cedc
diff --git a/dev-python/flexmock/flexmock-0.10.4.ebuild b/dev-python/flexmock/flexmock-0.10.4.ebuild
new file mode 100644
index 000000000000..59e66efe32a9
--- /dev/null
+++ b/dev-python/flexmock/flexmock-0.10.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Testing library to create mocks, stubs and fakes"
+HOMEPAGE="http://flexmock.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+ "
+RDEPEND=""
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r docs
+}
+
+python_test() {
+ pytest -vv tests || die "pytest failed"
+}
diff --git a/sys-apps/baselayout-prefix/baselayout-prefix-2.6-r1.ebuild b/sys-apps/baselayout-prefix/baselayout-prefix-2.6-r1.ebuild
index 8cff70e3e2c6..b689642fcbbf 100644
--- a/sys-apps/baselayout-prefix/baselayout-prefix-2.6-r1.ebuild
+++ b/sys-apps/baselayout-prefix/baselayout-prefix-2.6-r1.ebuild
@@ -17,7 +17,7 @@ if [[ ${PV} = 9999 ]]; then
inherit git-r3
else
SRC_URI="https://gitweb.gentoo.org/proj/${MY_PN}.git/snapshot/${MY_P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+ KEYWORDS="~arm ~arm64 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
fi
LICENSE="GPL-2"
diff --git a/sys-apps/baselayout-prefix/baselayout-prefix-2.6.ebuild b/sys-apps/baselayout-prefix/baselayout-prefix-2.6.ebuild
deleted file mode 100644
index 630c9a15a853..000000000000
--- a/sys-apps/baselayout-prefix/baselayout-prefix-2.6.ebuild
+++ /dev/null
@@ -1,328 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib
-
-# just use "upstream" sources
-MY_P=${P/-prefix/}
-MY_PN=${PN/-prefix/}
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Filesystem baselayout and init scripts"
-HOMEPAGE="https://www.gentoo.org/"
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/${MY_PN}.git"
- inherit git-r3
-else
- SRC_URI="https://gitweb.gentoo.org/proj/${MY_PN}.git/snapshot/${MY_P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="build kernel_FreeBSD kernel_linux +split-usr"
-
-my_prefix_commits=(
- # commits in reverse order as listed by:
- # git log --decorate=no --oneline --no-abbrev-commit origin/master..
- 5926fe447541607ed137d67ca84080326584b2fc # create usr/bin during layout-usrmerge
- 395424f90c8ca6969589905cbf86d74fae9d7ea6 # add prefix-stack support
- 95a8e95af948014d024842892be1405d656ab5fc # add prefix-guest support
- c88ceddbfc6a965dc0153aef21e012e774d9e30c # sync prefix usage for Makefile target 'layout'
- c9338e89cdb603c1e08998bba28fbc977a62fc51 # add prefix support per Makefile target 'install'
-)
-for my_c in ${my_prefix_commits[*]}
-do
- SRC_URI+=" https://github.com/haubi/gentoo-baselayout/commit/${my_c}.patch -> ${PN}-${my_c}.patch"
- PATCHES=( "${DISTDIR}/${PN}-${my_c}.patch" "${PATCHES[@]}" )
-done
-unset my_prefix_commits my_c
-
-pkg_setup() {
- multilib_layout
-}
-
-# Create our multilib dirs - the Makefile has no knowledge of this
-multilib_layout() {
- use prefix && return 0
- local dir def_libdir libdir libdirs
- local prefix prefix_lst
- def_libdir=$(get_abi_LIBDIR $DEFAULT_ABI)
- libdirs=$(get_all_libdirs)
- : ${libdirs:=lib} # it isn't that we don't trust multilib.eclass...
-
- if [[ -z "${SYMLINK_LIB}" || ${SYMLINK_LIB} = no ]] ; then
- prefix_lst=( "${EROOT}"{,usr/,usr/local/} )
- for prefix in ${prefix_lst[@]}; do
- for libdir in ${libdirs}; do
- dir="${prefix}${libdir}"
- if [[ -e "${dir}" ]]; then
- [[ ! -d "${dir}" ]] &&
- die "${dir} exists but is not a directory"
- continue
- fi
- if ! use split-usr && [[ ${prefix} = ${EROOT} ]]; then
- einfo "symlinking ${dir} to usr/${libdir}"
- ln -s usr/${libdir} ${dir} ||
- die " Unable to make ${dir} symlink"
- else
- einfo "creating directory ${dir}"
- mkdir -p "${dir}" ||
- die "Unable to create ${dir} directory"
- fi
- done
- done
- return 0
- fi
-
- [ -z "${def_libdir}" ] &&
- die "your DEFAULT_ABI=$DEFAULT_ABI appears to be invalid"
-
- # figure out which paths should be symlinks and which should be directories
- local dirs syms exp d
- for libdir in ${libdirs} ; do
- if use split-usr ; then
- exp=( {,usr/,usr/local/}${libdir} )
- else
- exp=( {usr/,usr/local/}${libdir} )
- fi
- for d in "${exp[@]}" ; do
- # most things should be dirs
- if [ "${SYMLINK_LIB}" = "yes" ] && [ "${libdir}" = "lib" ] ; then
- [ ! -h "${d}" ] && [ -e "${d}" ] && dirs+=" ${d}"
- else
- [ -h "${d}" ] && syms+=" ${d}"
- fi
- done
- done
- if [ -n "${syms}${dirs}" ] ; then
- ewarn "Your system profile has SYMLINK_LIB=${SYMLINK_LIB:-no}, so that means you need to"
- ewarn "have these paths configured as follows:"
- [ -n "${dirs}" ] && ewarn "symlinks to '${def_libdir}':${dirs}"
- [ -n "${syms}" ] && ewarn "directories:${syms}"
- ewarn "The ebuild will attempt to fix these, but only for trivial conversions."
- ewarn "If things fail, you will need to manually create/move the directories."
- echo
- fi
-
- # setup symlinks and dirs where we expect them to be; do not migrate
- # data ... just fall over in that case.
- if use split-usr ; then
- prefix_lst=( "${EROOT}"{,usr/,usr/local/} )
- else
- prefix_lst=( "${EROOT}"{usr/,usr/local/} )
- fi
- for prefix in "${prefix_lst[@]}"; do
- if [ "${SYMLINK_LIB}" = yes ] ; then
- # we need to make sure "lib" points to the native libdir
- if [ -h "${prefix}lib" ] ; then
- # it's already a symlink! assume it's pointing to right place ...
- continue
- elif [ -d "${prefix}lib" ] ; then
- # "lib" is a dir, so need to convert to a symlink
- ewarn "Converting ${prefix}lib from a dir to a symlink"
- rm -f "${prefix}lib"/.keep
- if rmdir "${prefix}lib" 2>/dev/null ; then
- ln -s ${def_libdir} "${prefix}lib" || die
- else
- die "non-empty dir found where we needed a symlink: ${prefix}lib"
- fi
- else
- # nothing exists, so just set it up sanely
- ewarn "Initializing ${prefix}lib as a symlink"
- mkdir -p "${prefix}" || die
- rm -f "${prefix}lib" || die
- ln -s ${def_libdir} "${prefix}lib" || die
- mkdir -p "${prefix}${def_libdir}" #423571
- fi
- else
- # we need to make sure "lib" is a dir
- if [ -h "${prefix}lib" ] ; then
- # "lib" is a symlink, so need to convert to a dir
- ewarn "Converting ${prefix}lib from a symlink to a dir"
- rm -f "${prefix}lib" || die
- if [ -d "${prefix}lib32" ] ; then
- ewarn "Migrating ${prefix}lib32 to ${prefix}lib"
- mv "${prefix}lib32" "${prefix}lib" || die
- else
- mkdir -p "${prefix}lib" || die
- fi
- elif [ -d "${prefix}lib" ] && ! has lib32 ${libdirs} ; then
- # make sure the old "lib" ABI location does not exist; we
- # only symlinked the lib dir on systems where we moved it
- # to "lib32" ...
- case ${CHOST} in
- *-gentoo-freebsd*) ;; # We want it the other way on fbsd.
- i?86*|x86_64*|powerpc*|sparc*|s390*)
- if [[ -d ${prefix}lib32 && ! -h ${prefix}lib32 ]] ; then
- rm -f "${prefix}lib32"/.keep
- if ! rmdir "${prefix}lib32" 2>/dev/null ; then
- ewarn "You need to merge ${prefix}lib32 into ${prefix}lib"
- die "non-empty dir found where there should be none: ${prefix}lib32"
- fi
- fi
- ;;
- esac
- else
- # nothing exists, so just set it up sanely
- ewarn "Initializing ${prefix}lib as a dir"
- mkdir -p "${prefix}lib" || die
- fi
- fi
- done
- if ! use split-usr ; then
- for libdir in ${libdirs}; do
- if [[ ! -e "${EROOT}${libdir}" ]]; then
- ln -s usr/"${libdir}" "${EROOT}${libdir}"
- fi
- done
- fi
-}
-
-pkg_preinst() {
- # This is written in src_install (so it's in CONTENTS), but punt all
- # pending updates to avoid user having to do etc-update (and make the
- # pkg_postinst logic simpler).
- rm -f "${EROOT}"/etc/._cfg????_gentoo-release
-
- # We need to install directories and maybe some dev nodes when building
- # stages, but they cannot be in CONTENTS.
- # Also, we cannot reference $S as binpkg will break so we do this.
- multilib_layout
- if use build ; then
- if use split-usr ; then
- emake -C "${ED}/usr/share/${PN}" DESTDIR="${ROOT}" layout
- else
- emake -C "${ED}/usr/share/${PN}" DESTDIR="${ROOT}" layout-usrmerge
- fi
- fi
- rm -f "${ED}"/usr/share/${PN}/Makefile
-}
-
-src_prepare() {
- default
-
- # handle multilib paths. do it here because we want this behavior
- # regardless of the C library that you're using. we do explicitly
- # list paths which the native ldconfig searches, but this isn't
- # problematic as it doesn't change the resulting ld.so.cache or
- # take longer to generate. similarly, listing both the native
- # path and the symlinked path doesn't change the resulting cache.
- local libdir ldpaths
- for libdir in $(get_all_libdirs) ; do
- ldpaths+=":${EPREFIX}/${libdir}:${EPREFIX}/usr/${libdir}"
- ldpaths+=":${EPREFIX}/usr/local/${libdir}"
- done
- echo "LDPATH='${ldpaths#:}'" >> etc/env.d/50baselayout
-
- # rc-scripts version for testing of features that *should* be present
- echo "Gentoo Base System release ${PV}" > etc/gentoo-release
- use prefix &&
- echo "Gentoo Prefix Base System release ${PV}" > etc/gentoo-release
- use prefix-stack &&
- echo "Gentoo Prefix Stack Base System release ${PV}" > etc/gentoo-release
-}
-
-src_configure() {
- local OS
- # although having a prefix, RAP uses full Linux baselayout
- OS=$(usex prefix-stack prefix-stack \
- $(usex prefix-guest prefix-guest \
- $(usex kernel_FreeBSD BSD \
- Linux ) ) )
- # set up immutable Makefile variables once
- sed -e "/^EPREFIX\s*?\?=\s*$/s|?\?=.*|= ${EPREFIX}|" \
- -e "/^BROOT\s*?\?=\s*$/s|?\?=.*|= ${BROOT}|" \
- -e "/^OS\s*?\?=\s*$/s|?\?=.*|= ${OS}|" \
- -i Makefile || die
-}
-
-src_install() {
- emake ROOT="${ROOT}" DESTDIR="${D}" install
- dodoc ChangeLog
-
- # need the makefile in pkg_preinst
- insinto /usr/share/${PN}
- doins Makefile
-}
-
-pkg_postinst() {
- local x
-
- # We installed some files to /usr/share/baselayout instead of /etc to stop
- # (1) overwriting the user's settings
- # (2) screwing things up when attempting to merge files
- # (3) accidentally packaging up personal files with quickpkg
- # If they don't exist then we install them
- for x in master.passwd passwd shadow group fstab ; do
- [ -e "${EROOT}/etc/${x}" ] && continue
- [ -e "${EROOT}/usr/share/baselayout/${x}" ] || continue
- cp -p "${EROOT}/usr/share/baselayout/${x}" "${EROOT}"/etc
- done
-
- # Force shadow permissions to not be world-readable #260993
- for x in shadow ; do
- [ -e "${EROOT}/etc/${x}" ] && chmod o-rwx "${EROOT}/etc/${x}"
- done
-
- # Take care of the etc-update for the user
- if [ -e "${EROOT}"/etc/._cfg0000_gentoo-release ] ; then
- mv "${EROOT}"/etc/._cfg0000_gentoo-release "${EROOT}"/etc/gentoo-release
- fi
-
- # whine about users that lack passwords #193541
- if [[ -e "${EROOT}"/etc/shadow ]] ; then
- local bad_users=$(sed -n '/^[^:]*::/s|^\([^:]*\)::.*|\1|p' "${EROOT}"/etc/shadow)
- if [[ -n ${bad_users} ]] ; then
- echo
- ewarn "The following users lack passwords!"
- ewarn ${bad_users}
- fi
- fi
-
- # whine about users with invalid shells #215698
- if [[ -e "${EROOT}"/etc/passwd ]] ; then
- local bad_shells=$(awk -F: 'system("test -e " $7) { print $1 " - " $7}' "${EROOT}"/etc/passwd | sort)
- if [[ -n ${bad_shells} ]] ; then
- echo
- ewarn "The following users have non-existent shells!"
- ewarn "${bad_shells}"
- fi
- fi
-
- # https://bugs.gentoo.org/361349
- if use kernel_linux; then
- mkdir -p "${EROOT}"/run
-
- local found fstype mountpoint
- while read -r _ mountpoint fstype _; do
- [[ ${mountpoint} = /run ]] && [[ ${fstype} = tmpfs ]] && found=1
- done < "${ROOT}"/proc/mounts
- [[ -z ${found} ]] &&
- ewarn "You should reboot now to get /run mounted with tmpfs!"
- fi
-
- for x in ${REPLACING_VERSIONS}; do
- if ver_test ${x} -lt 2.4; then
- ewarn "After updating ${EROOT}/etc/profile, please run"
- ewarn "env-update && . ${EPREFIX}/etc/profile"
- fi
-
- if ver_test ${x} -lt 2.6; then
- ewarn "Please run env-update then log out and back in to"
- ewarn "update your path."
- fi
- # clean up after 2.5 typos
- # https://bugs.gentoo.org/show_bug.cgi?id=656380
- if [[ ${x} == 2.5 ]]; then
- rm -fr "${EROOT}{,usr"
- fi
- done
-
- if [[ -e "${EROOT}"/etc/env.d/00basic ]]; then
- ewarn "${EROOT}/etc/env.d/00basic is now ${EROOT}/etc/env.d/50baselayout"
- ewarn "Please migrate your changes."
- fi
-}
diff --git a/sys-auth/polkit/files/polkit-0.115-spidermonkey-60.patch b/sys-auth/polkit/files/polkit-0.115-spidermonkey-60.patch
new file mode 100644
index 000000000000..8a4510ad2051
--- /dev/null
+++ b/sys-auth/polkit/files/polkit-0.115-spidermonkey-60.patch
@@ -0,0 +1,180 @@
+From c9cd7024140b837b5693d7c1bbaad1b0cd31cce6 Mon Sep 17 00:00:00 2001
+From: Emmanuele Bassi <ebassi@gnome.org>
+Date: Fri, 31 Aug 2018 13:32:16 +0100
+Subject: [PATCH] Depend on mozjs-60
+
+This is the new ESR version of the Mozilla JS engine, superceding
+mozjs-52.
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 5c37e48..5cedb4e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -79,7 +79,7 @@ PKG_CHECK_MODULES(GLIB, [gmodule-2.0 gio-unix-2.0 >= 2.30.0])
+ AC_SUBST(GLIB_CFLAGS)
+ AC_SUBST(GLIB_LIBS)
+
+-PKG_CHECK_MODULES(LIBJS, [mozjs-52])
++PKG_CHECK_MODULES(LIBJS, [mozjs-60])
+
+ AC_SUBST(LIBJS_CFLAGS)
+ AC_SUBST(LIBJS_CXXFLAGS)
+
+
+From dd00683e8781d230a45781d509d86ad676138564 Mon Sep 17 00:00:00 2001
+From: Emmanuele Bassi <ebassi@gnome.org>
+Date: Fri, 31 Aug 2018 13:33:20 +0100
+Subject: [PATCH] Port the JS authority to mozjs-60
+
+API changes in mozjs that need to be reflected in the JS authority:
+
+ - the JS::CompileOptions constructor and the JS::CompartmentOptions
+ do not allow setting a JS version any more
+
+ - do not use NULL comparisons for C++ objects
+
+ - the resize() method for a vector has a return value that needs
+ to be handled
+
+ - JSClassOps has different fields
+---
+ .../polkitbackendjsauthority.cpp | 65 +++++++++----------
+ 1 file changed, 32 insertions(+), 33 deletions(-)
+
+diff --git a/src/polkitbackend/polkitbackendjsauthority.cpp b/src/polkitbackend/polkitbackendjsauthority.cpp
+index 7602714..984a0f0 100644
+--- a/src/polkitbackend/polkitbackendjsauthority.cpp
++++ b/src/polkitbackend/polkitbackendjsauthority.cpp
+@@ -150,18 +150,17 @@ G_DEFINE_TYPE (PolkitBackendJsAuthority, polkit_backend_js_authority, POLKIT_BAC
+ /* ---------------------------------------------------------------------------------------------------- */
+
+ static const struct JSClassOps js_global_class_ops = {
+- NULL,
+- NULL,
+- NULL,
+- NULL,
+- NULL,
+- NULL,
+- NULL,
+- NULL,
+- NULL,
+- NULL,
+- NULL,
+- NULL
++ nullptr, // addProperty
++ nullptr, // deleteProperty
++ nullptr, // enumerate
++ nullptr, // newEnumerate
++ nullptr, // resolve
++ nullptr, // mayResolve
++ nullptr, // finalize
++ nullptr, // call
++ nullptr, // hasInstance
++ nullptr, // construct
++ JS_GlobalObjectTraceHook
+ };
+
+ static JSClass js_global_class = {
+@@ -172,18 +171,17 @@ static JSClass js_global_class = {
+
+ /* ---------------------------------------------------------------------------------------------------- */
+ static const struct JSClassOps js_polkit_class_ops = {
+- NULL,
+- NULL,
+- NULL,
+- NULL,
+- NULL,
+- NULL,
+- NULL,
+- NULL,
+- NULL,
+- NULL,
+- NULL,
+- NULL
++ nullptr, // addProperty
++ nullptr, // deleteProperty
++ nullptr, // enumerate
++ nullptr, // newEnumerate
++ nullptr, // resolve
++ nullptr, // mayResolve
++ nullptr, // finalize
++ nullptr, // call
++ nullptr, // hasInstance
++ nullptr, // construct
++ nullptr // trace
+ };
+
+ static JSClass js_polkit_class = {
+@@ -469,19 +467,18 @@ polkit_backend_js_authority_constructed (GObject *object)
+
+ {
+ JS::CompartmentOptions compart_opts;
+- compart_opts.behaviors().setVersion(JSVERSION_LATEST);
++
+ JS::RootedObject global(authority->priv->cx);
+
+ authority->priv->js_global = new JS::Heap<JSObject*> (JS_NewGlobalObject (authority->priv->cx, &js_global_class, NULL, JS::FireOnNewGlobalHook, compart_opts));
+
+ global = authority->priv->js_global->get ();
+-
+- if (global == NULL)
++ if (!global)
+ goto fail;
+
+ authority->priv->ac = new JSAutoCompartment(authority->priv->cx, global);
+
+- if (authority->priv->ac == NULL)
++ if (!authority->priv->ac)
+ goto fail;
+
+ if (!JS_InitStandardClasses (authority->priv->cx, global))
+@@ -493,7 +490,7 @@ polkit_backend_js_authority_constructed (GObject *object)
+
+ polkit = authority->priv->js_polkit->get ();
+
+- if (polkit == NULL)
++ if (!polkit)
+ goto fail;
+
+ if (!JS_DefineProperty(authority->priv->cx, global, "polkit", polkit, JSPROP_ENUMERATE))
+@@ -504,7 +501,7 @@ polkit_backend_js_authority_constructed (GObject *object)
+ js_polkit_functions))
+ goto fail;
+
+- JS::CompileOptions options(authority->priv->cx, JSVERSION_UNKNOWN);
++ JS::CompileOptions options(authority->priv->cx);
+ JS::RootedValue rval(authority->priv->cx);
+ if (!JS::Evaluate (authority->priv->cx,
+ options,
+@@ -684,7 +681,9 @@ set_property_strv (PolkitBackendJsAuthority *authority,
+ JS::AutoValueVector elems(authority->priv->cx);
+ guint n;
+
+- elems.resize(value->len);
++ if (!elems.resize(value->len))
++ g_error ("Unable to resize vector");
++
+ for (n = 0; n < value->len; n++)
+ {
+ const char *c_string = (const char *) g_ptr_array_index(value, n);
+@@ -741,7 +740,7 @@ subject_to_jsval (PolkitBackendJsAuthority *authority,
+ GError **error)
+ {
+ gboolean ret = FALSE;
+- JS::CompileOptions options(authority->priv->cx, JSVERSION_UNKNOWN);
++ JS::CompileOptions options(authority->priv->cx);
+ const char *src;
+ JS::RootedObject obj(authority->priv->cx);
+ pid_t pid;
+@@ -868,7 +867,7 @@ action_and_details_to_jsval (PolkitBackendJsAuthority *authority,
+ GError **error)
+ {
+ gboolean ret = FALSE;
+- JS::CompileOptions options(authority->priv->cx, JSVERSION_UNKNOWN);
++ JS::CompileOptions options(authority->priv->cx);
+ const char *src;
+ JS::RootedObject obj(authority->priv->cx);
+ gchar **keys;
diff --git a/sys-auth/polkit/polkit-0.115-r4.ebuild b/sys-auth/polkit/polkit-0.115-r4.ebuild
new file mode 100644
index 000000000000..ecc024a27d3c
--- /dev/null
+++ b/sys-auth/polkit/polkit-0.115-r4.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools pam pax-utils systemd user xdg-utils
+
+DESCRIPTION="Policy framework for controlling privileges for system-wide services"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/polkit https://gitlab.freedesktop.org/polkit/polkit"
+SRC_URI="https://www.freedesktop.org/software/${PN}/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="elogind examples gtk +introspection jit kde nls pam selinux systemd test"
+
+REQUIRED_USE="?? ( elogind systemd )"
+
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/gobject-introspection-common
+ dev-libs/libxslt
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ introspection? ( dev-libs/gobject-introspection )
+"
+DEPEND="
+ dev-lang/spidermonkey:60[-debug]
+ dev-libs/glib:2
+ dev-libs/expat
+ elogind? ( sys-auth/elogind )
+ pam? (
+ sys-auth/pambase
+ virtual/pam
+ )
+ systemd? ( sys-apps/systemd:0=[policykit] )
+"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-policykit )
+"
+PDEPEND="
+ gtk? ( || (
+ >=gnome-extra/polkit-gnome-0.105
+ >=lxde-base/lxsession-0.5.2
+ ) )
+ kde? ( kde-plasma/polkit-kde-agent )
+ !systemd? ( !elogind? ( sys-auth/consolekit[policykit] ) )
+"
+
+DOCS=( docs/TODO HACKING NEWS README )
+
+PATCHES=(
+ # bug 660880
+ "${FILESDIR}"/polkit-0.115-elogind.patch
+ "${FILESDIR}"/CVE-2018-19788.patch
+ "${FILESDIR}"/polkit-0.115-spidermonkey-60.patch
+)
+
+QA_MULTILIB_PATHS="
+ usr/lib/polkit-1/polkit-agent-helper-1
+ usr/lib/polkit-1/polkitd"
+
+pkg_setup() {
+ local u=polkitd
+ local g=polkitd
+ local h=/var/lib/polkit-1
+
+ enewgroup ${g}
+ enewuser ${u} -1 -1 ${h} ${g}
+ esethome ${u} ${h}
+}
+
+src_prepare() {
+ default
+
+ sed -i -e 's|unix-group:wheel|unix-user:0|' src/polkitbackend/*-default.rules || die #401513
+
+ # Workaround upstream hack around standard gtk-doc behavior, bug #552170
+ sed -i -e 's/@ENABLE_GTK_DOC_TRUE@\(TARGET_DIR\)/\1/' \
+ -e '/install-data-local:/,/uninstall-local:/ s/@ENABLE_GTK_DOC_TRUE@//' \
+ -e 's/@ENABLE_GTK_DOC_FALSE@install-data-local://' \
+ docs/polkit/Makefile.in || die
+
+ # disable broken test - bug #624022
+ sed -i -e "/^SUBDIRS/s/polkitbackend//" test/Makefile.am || die
+
+ # Fix cross-building, bug #590764, elogind patch, bug #598615
+ eautoreconf
+}
+
+src_configure() {
+ xdg_environment_reset
+
+ local myeconfargs=(
+ --localstatedir="${EPREFIX}"/var
+ --disable-static
+ --enable-man-pages
+ --disable-gtk-doc
+ --disable-examples
+ $(use_enable elogind libelogind)
+ $(use_enable introspection)
+ $(use_enable nls)
+ $(usex pam "--with-pam-module-dir=$(getpam_mod_dir)" '')
+ --with-authfw=$(usex pam pam shadow)
+ $(use_enable systemd libsystemd-login)
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ $(use_enable test)
+ --with-os-type=gentoo
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ # Required for polkitd on hardened/PaX due to spidermonkey's JIT
+ pax-mark mr src/polkitbackend/.libs/polkitd test/polkitbackend/.libs/polkitbackendjsauthoritytest
+}
+
+src_install() {
+ default
+
+ fowners -R polkitd:root /{etc,usr/share}/polkit-1/rules.d
+
+ diropts -m0700 -o polkitd -g polkitd
+ keepdir /var/lib/polkit-1
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins src/examples/{*.c,*.policy*}
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ chown -R polkitd:root "${EROOT}"/{etc,usr/share}/polkit-1/rules.d
+ chown -R polkitd:polkitd "${EROOT}"/var/lib/polkit-1
+}
diff --git a/sys-process/nmon/Manifest b/sys-process/nmon/Manifest
index d61713e68c77..fa304a4040f0 100644
--- a/sys-process/nmon/Manifest
+++ b/sys-process/nmon/Manifest
@@ -1,2 +1,3 @@
DIST lmon16f.c 271123 BLAKE2B d0ac71e061fdeadc59f0c07d46ed711570d439f8058b1fe30fd137cb648129f844c6d8b750783543eeddb3bd99f26e07e83ba63cdc55ace83d0f2fc77ab19c43 SHA512 04d22b4678932067d42158f1bc794f79b5a321e10ba7163632be3b930e28176d0d057cd652ef7cd342167741aafdc00a16e612a99522bfe75072e67cf8d0a66b
DIST lmon16g.c 267681 BLAKE2B ff7484b7853418e679720fcc76257fb7fe0208f8cf43806c76f5d189c370f995313c325d6e9821b686fa3917cc552af9e9b94ce9f9aed6efe98d2d07032d7c31 SHA512 87287183db48338a281438efc7a8b74249cf88c0a0799e826a9a89b0eb39835b0ba223c7ea6decc217848179f4991909b3cf307aa7eec8a3a4604ebf8a4e8ebe
+DIST lmon16i.c 269804 BLAKE2B 9ff75d7f9f54d6ea3d4c9bec611343c2a28f2cff44d0e2a972bce61326befd4ae455941dba406d052c4cdd820ffeae48894131c8d8b746eedbd1bb58582594d8 SHA512 7c2d60b1558c01cfbcfe040eb68652d3a6c5717efb5495563f774ff20384a6cc4532e756d49b8634a022e4681503b7738998a5dbd77e4ca37c114a94a03893cb
diff --git a/sys-process/nmon/nmon-16i.ebuild b/sys-process/nmon/nmon-16i.ebuild
new file mode 100644
index 000000000000..4cc52ae9c054
--- /dev/null
+++ b/sys-process/nmon/nmon-16i.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+MY_P="lmon${PV}"
+
+DESCRIPTION="Nigel's performance MONitor for CPU, memory, network, disks, etc..."
+HOMEPAGE="http://nmon.sourceforge.net/"
+LICENSE="GPL-3"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.c"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}"/${MY_P}.c "${S}"/${PN}.c || die
+}
+
+src_configure() {
+ local cflags=(
+ ## recommended by upstream to be always on
+ -DGETUSER
+ -DJFS
+ -DLARGEMEM
+ -DKERNEL_2_6_18
+
+ ## archs
+ $(usex amd64 -DX86 '')
+ $(usex x86 -DX86 '')
+ $(usex arm -DARM '')
+ $(usex ppc64 -DPOWER '')
+ )
+ append-cflags "${cflags[@]}"
+ append-libs "$($(tc-getPKG_CONFIG) --libs ncurses) -lm"
+}
+
+src_compile() {
+ emake ${PN} LDLIBS="${LIBS}"
+}
+
+src_install() {
+ dobin ${PN}
+}
diff --git a/x11-wm/i3/Manifest b/x11-wm/i3/Manifest
index 37fd66cefdd6..c2509315514f 100644
--- a/x11-wm/i3/Manifest
+++ b/x11-wm/i3/Manifest
@@ -1,5 +1,4 @@
-DIST i3-4.13.tar.bz2 1121298 BLAKE2B 94f3940406d43083c8dc577b4216a32a08ad4c4b58e7707cc9e3129038f4d13043c1f86e8de03d0fdfcff73f0de582fc8b3c88d71c0161ac3eefe28329f67a64 SHA512 1bb1044e8d86e78d3ccb79d49f0eb26665dcd05a348058a5e57138151d74f57d77830efc3025893170fe1b8ec612f739f75247a427410f96286b09afd2c5f14c
-DIST i3-4.14.1.tar.bz2 1173560 BLAKE2B 96a0e1d75be13098fd530c3970464ce7710063f517c0d538939de6e7c799ab6b3ec005fb50216b1db4ccefd44584c584b263ac359bd9a86be53418d8f8d4beba SHA512 ef628af002947b40e1c88b0e872c6e93d4377a9674a120bd9adc3f323a38570b05124cd3047b5a26659e72070de2d00d83fb93186510c74ad8ddbf4f3df85472
DIST i3-4.14.tar.gz 3936748 BLAKE2B 42678130be56bc695e5700e978ddbd34bfdaeda7a65252a05568581d76fe613e80e710f3a507110e7988077fe62048bf984d4009e722d877b178206cef600221 SHA512 fe3db78813987a15ed93d182968bcd5139e1d03f29d3e8effd9fce59f87bc8309407af0b2fa5f1cd83b8583e50ea0ade6b8eafc5dda6dea9161832dc9cebfdfe
DIST i3-4.15.tar.bz2 1196263 BLAKE2B 36f20327202957dba30aface91af4d2c6261979e726584712a508a11cb4a612d812e771dc9f28ec4cfcbf3ebc9d92c72f5e940048516cca0f185eab20f95ae32 SHA512 60ab61b7e380342126bea12fb4371f98fcf18f6435f79a9519d3f59cfabdb170634366036e1aa20c5592da0832b03140ad1f0c72bad3cfaace0b7c57ad01dfc4
+DIST i3-4.16.1.tar.bz2 1211532 BLAKE2B 64a6996c0b89516069b58bf1cba92908a7f61ab04d66659b612b27411eb92fa9d49a7214eccdba33e7c33605b5f9247f69c1f0e23de629552edf113ab7520747 SHA512 3e328f8c7216697c5e484ca854605350f78844e24cc6cfb9c10e71368c2c0457387a14f819abdf8be2370d437889297f452fbf63f3924766ca81c157ab27e1b0
DIST i3-4.16.tar.bz2 1213251 BLAKE2B a65d15278a83bac9903a611628ea53c64cd554ab9fff2a8864e649fd962858b2f3e77fe69d0dc70affc93dc69b3cbbd7b3ee670a2af9d697e28e9e4ea3323f67 SHA512 99abd15349ee8e61c084b3664ef3a189c92ea07812ac59eb6a5441df7cebea8211be52204e39bddcc33d8c714447fddbbe2c5c8a25b756a96e2dc6732526cbf8
diff --git a/x11-wm/i3/files/i3-4.13-remove-git-polling.patch b/x11-wm/i3/files/i3-4.13-remove-git-polling.patch
deleted file mode 100644
index ca226378ed7f..000000000000
--- a/x11-wm/i3/files/i3-4.13-remove-git-polling.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -Naur a/configure.ac b/configure.ac
---- a/configure.ac 2017-01-13 13:31:25.250216293 +0100
-+++ b/configure.ac 2017-01-13 13:31:55.930217956 +0100
-@@ -146,15 +146,6 @@
- print_BUILD_MANS=no
- fi
-
--git_dir=`git rev-parse --git-dir 2>/dev/null`
--if test -n "$git_dir"; then
-- srcdir=`dirname "$git_dir"`
-- exclude_dir=`pwd | sed "s,^$srcdir,,g"`
-- if ! grep -q "^$exclude_dir" "$git_dir/info/exclude"; then
-- echo "$exclude_dir" >> "$git_dir/info/exclude"
-- fi
--fi
--
- echo \
- "--------------------------------------------------------------------------------
- build configured:
diff --git a/x11-wm/i3/i3-4.13-r1.ebuild b/x11-wm/i3/i3-4.13-r1.ebuild
deleted file mode 100644
index 2b809ac551d6..000000000000
--- a/x11-wm/i3/i3-4.13-r1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="An improved dynamic tiling window manager"
-HOMEPAGE="https://i3wm.org/"
-SRC_URI="https://i3wm.org/downloads/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86"
-IUSE="doc"
-
-CDEPEND="dev-libs/libev
- dev-libs/libpcre
- >=dev-libs/yajl-2.0.3
- x11-libs/libxcb[xkb]
- x11-libs/libxkbcommon[X]
- x11-libs/startup-notification
- x11-libs/xcb-util
- x11-libs/xcb-util-cursor
- x11-libs/xcb-util-keysyms
- x11-libs/xcb-util-wm
- x11-libs/xcb-util-xrm
- >=x11-libs/cairo-1.14.4[X,xcb]
- >=x11-libs/pango-1.30.0[X]"
-DEPEND="${CDEPEND}
- doc? ( app-text/asciidoc app-text/xmlto dev-lang/perl )
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}
- dev-lang/perl
- dev-perl/AnyEvent-I3
- dev-perl/JSON-XS"
-
-DOCS=( RELEASE-NOTES-${PV} )
-PATCHES=(
- "${FILESDIR}/${P}-remove-git-polling.patch"
- "${FILESDIR}/${PN}-musl-GLOB_TILDE.patch"
-)
-
-src_prepare() {
- default
- if ! use doc ; then
- sed -e '/AC_PATH_PROG(\[PATH_ASCIIDOC/d' -i configure.ac || die
- eautoreconf
- fi
- cat <<- EOF > "${T}"/i3wm
- #!/bin/sh
- exec /usr/bin/i3
- EOF
-}
-
-src_configure() {
- local myeconfargs=( --enable-debug=no ) # otherwise injects -O0 -g
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- emake -C "${CBUILD}"
-}
-
-src_install() {
- emake -C "${CBUILD}" DESTDIR="${D}" install
- if ! use doc ; then
- # install docs shipped with source tarball
- # local HTML_DOCS=( docs/. ) # TODO: install unconditionally?
- doman man/*.1
- fi
- einstalldocs
-
- exeinto /etc/X11/Sessions
- doexe "${T}"/i3wm
-}
-
-pkg_postinst() {
- # Only show the elog information on a new install
- if [[ ! ${REPLACING_VERSIONS} ]]; then
- elog "There are several packages that you may find useful with ${PN} and"
- elog "their usage is suggested by the upstream maintainers, namely:"
- elog " x11-misc/dmenu"
- elog " x11-misc/i3status"
- elog " x11-misc/i3lock"
- elog "Please refer to their description for additional info."
- fi
-}
diff --git a/x11-wm/i3/i3-4.14.1.ebuild b/x11-wm/i3/i3-4.16.1.ebuild
index a10e0a5f9e40..40e2cfb9d89d 100644
--- a/x11-wm/i3/i3-4.14.1.ebuild
+++ b/x11-wm/i3/i3-4.16.1.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-AEVER=0.17
+EAPI=7
inherit autotools out-of-source virtualx
@@ -13,7 +11,7 @@ SRC_URI="https://i3wm.org/downloads/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="doc debug test"
CDEPEND="dev-libs/libev
@@ -31,8 +29,6 @@ CDEPEND="dev-libs/libev
>=x11-libs/cairo-1.14.4[X,xcb]
>=x11-libs/pango-1.30.0[X]"
DEPEND="${CDEPEND}
- app-text/asciidoc
- doc? ( app-text/xmlto dev-lang/perl )
test? (
dev-perl/AnyEvent
>=dev-perl/X11-XCB-0.120.0
@@ -44,18 +40,19 @@ DEPEND="${CDEPEND}
>=virtual/perl-Test-Simple-0.940.0
x11-base/xorg-server[xephyr]
)
- virtual/pkgconfig"
+"
RDEPEND="${CDEPEND}
dev-lang/perl
dev-perl/AnyEvent-I3
dev-perl/JSON-XS"
+BDEPEND="virtual/pkgconfig"
# Test without debug will apply optimization levels, which results
# in type-punned pointers - which in turn causes test failures.
REQUIRED_USE="test? ( debug )"
PATCHES=(
- "${FILESDIR}/${PN}-musl-GLOB_TILDE.patch"
+ "${FILESDIR}/${PN}-4.16-musl-GLOB_TILDE.patch"
)
# https://github.com/i3/i3/issues/3013