summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-08 19:53:15 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-08 19:56:18 +0100
commit1039c8f967a4beeef30b87ce131cc01aafc78da5 (patch)
tree27001cdd5cb1725ab8cb7e86bdd31009e405a0f5
parentmedia-libs/libcdr: Drop -std=c++14 workaround (diff)
downloadgentoo-1039c8f967a4beeef30b87ce131cc01aafc78da5.tar.gz
gentoo-1039c8f967a4beeef30b87ce131cc01aafc78da5.tar.bz2
gentoo-1039c8f967a4beeef30b87ce131cc01aafc78da5.zip
media-libs/libcdr: 0.1.6 version bump
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-libs/libcdr/Manifest1
-rw-r--r--media-libs/libcdr/libcdr-0.1.6.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/media-libs/libcdr/Manifest b/media-libs/libcdr/Manifest
index 4fda0e51ac06..17eeb6bc00fb 100644
--- a/media-libs/libcdr/Manifest
+++ b/media-libs/libcdr/Manifest
@@ -1 +1,2 @@
DIST libcdr-0.1.5.tar.xz 612252 BLAKE2B d23c7ae0d0f5cbdb535bfba4dff4ad40e8b0633115cbc8c5b3a40343d941eaeafbffafe99ba2107640eafdd8181ab6eed7917095d05644a43f2b11cfcc66f8f1 SHA512 e985389b0cbad65dbfa9f59d7f9dba55f1684f63e852f9acca9abb863cdaab17072e761b48dca690673360d643686b5e9bc9878530f0a3a8b5b98d917f892cf0
+DIST libcdr-0.1.6.tar.xz 612068 BLAKE2B ec5226a28f101472ea3044e9e5b87dba57b584fc813dfda29e00281182d067126bf8a5740c32bc5cb545f230f6f96163aac2fdf08879ec64379b7845839bc88a SHA512 629d55da71c7333f41f60a32e2880deffcf80088096af1bbc8c572b80ef21d851102fdebce56f77245ed60822ca98e02c0867b192abef496a2313fde54a97bb6
diff --git a/media-libs/libcdr/libcdr-0.1.6.ebuild b/media-libs/libcdr/libcdr-0.1.6.ebuild
new file mode 100644
index 000000000000..3397e4658eb6
--- /dev/null
+++ b/media-libs/libcdr/libcdr-0.1.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libcdr.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev-www.libreoffice.org/src/libcdr/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Library parsing the Corel cdr documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+IUSE="doc static-libs test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ media-libs/lcms:2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+
+src_prepare() {
+ default
+ [[ -d m4 ]] || mkdir "m4"
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with doc docs)
+ $(use_enable static-libs static)
+ $(use_enable test tests)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}