summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2020-02-11 08:06:49 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2020-02-11 08:06:49 +0000
commit19493d01c990f9fb161b5b8a558276a2cdb5bf35 (patch)
treed6a12cd52478e04035c41cf02df1dec5391878d6
parent2020-02-11 00:11:22 UTC (diff)
parentgames-fps/prboom-plus: Bump to version 2.5.1.5.4540.1 (diff)
downloadgentoo-19493d01c990f9fb161b5b8a558276a2cdb5bf35.tar.gz
gentoo-19493d01c990f9fb161b5b8a558276a2cdb5bf35.tar.bz2
gentoo-19493d01c990f9fb161b5b8a558276a2cdb5bf35.zip
Merge updates from master
-rw-r--r--dev-python/PyGithub/Manifest1
-rw-r--r--dev-python/PyGithub/PyGithub-1.46.ebuild35
-rw-r--r--dev-python/deprecated/deprecated-1.2.7.ebuild2
-rw-r--r--dev-python/pyjwt/files/pyjwt-1.7.1-ecdsa-fix.patch27
-rw-r--r--dev-python/pyjwt/pyjwt-1.7.1-r1.ebuild56
-rw-r--r--dev-python/sure/sure-1.4.11.ebuild2
-rw-r--r--dev-python/wrapt/wrapt-1.11.2-r1.ebuild2
-rw-r--r--games-fps/prboom-plus/Manifest2
-rw-r--r--games-fps/prboom-plus/metadata.xml18
-rw-r--r--games-fps/prboom-plus/prboom-plus-2.5.1.4.ebuild68
-rw-r--r--games-fps/prboom-plus/prboom-plus-2.5.1.5.4540.1.ebuild64
-rw-r--r--licenses/BSD-with-disclosure27
-rw-r--r--profiles/license_groups2
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/Manifest1
14 files changed, 228 insertions, 79 deletions
diff --git a/dev-python/PyGithub/Manifest b/dev-python/PyGithub/Manifest
index f5de2382bbdb..8fee48d24b44 100644
--- a/dev-python/PyGithub/Manifest
+++ b/dev-python/PyGithub/Manifest
@@ -1,2 +1,3 @@
DIST PyGithub-1.44.1.gh.tar.gz 2866013 BLAKE2B 90ca7f21fe0031c6cc6d50f54facd7c086037f942f9595e78a3b1a0fe0d21b6bc587f07b63152afabbaa2f38d165b8014600cb195207519a16e3e05fb9bfbcff SHA512 87b6c05f3bbfa463995b67d0bb257700e8c67050dd291c60737a84c4e8bc6bcbde1c0e2add98ec38174c55f2c21abcf4c46bba8be752d132d7e63e423ab6fd1e
DIST PyGithub-1.45.gh.tar.gz 2881912 BLAKE2B 0117608298f6b5d522f451382ea058a9dc507dbf15b31542f4039da8105cf0cb002ac17b5c5c321e465f97dce20699de0d319010c478a5c9d30529e885516e42 SHA512 24ff3c75f5578f5e0df59fa1a02511747857984d7bd4ae1b3d0a3b41a0eee79df9732d39ee5026978b70a71746826e92f27cc44b8362b6bd3e7dd4edb1654acd
+DIST PyGithub-1.46.gh.tar.gz 2882667 BLAKE2B a65a359750c146947b69ff72a4775f6f1532420c3d15e0d7df34c69c3c552aa201740c1ea2cff2dd40daddf7cdc7743b4354698e1bc701f175a5f7dcfc83dd97 SHA512 1c03920434491b279e1709550a658ff125c0d91390160b1de5e5fadf5cf5eeb722477fd913f47ec686cce052a8c34d916de753ea36fecb227d955e60d064a0b6
diff --git a/dev-python/PyGithub/PyGithub-1.46.ebuild b/dev-python/PyGithub/PyGithub-1.46.ebuild
new file mode 100644
index 000000000000..884e61e5f2d2
--- /dev/null
+++ b/dev-python/PyGithub/PyGithub-1.46.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to access the Github API v3"
+HOMEPAGE="https://github.com/PyGithub/PyGithub/"
+# Use github since pypi is missing test data
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/deprecated[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/httpretty-0.9.6[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" -m unittest -v tests.AllTests || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/deprecated/deprecated-1.2.7.ebuild b/dev-python/deprecated/deprecated-1.2.7.ebuild
index 1c28971d7adf..c5ef661a2a3f 100644
--- a/dev-python/deprecated/deprecated-1.2.7.ebuild
+++ b/dev-python/deprecated/deprecated-1.2.7.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7}} )
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
inherit distutils-r1
DESCRIPTION="Python @deprecated decorator to deprecate old API"
diff --git a/dev-python/pyjwt/files/pyjwt-1.7.1-ecdsa-fix.patch b/dev-python/pyjwt/files/pyjwt-1.7.1-ecdsa-fix.patch
new file mode 100644
index 000000000000..ebd9236c7994
--- /dev/null
+++ b/dev-python/pyjwt/files/pyjwt-1.7.1-ecdsa-fix.patch
@@ -0,0 +1,27 @@
+From 36a3f9bd0cc7029e5150b1931efbd62da975e8b9 Mon Sep 17 00:00:00 2001
+From: StefanBruens <stefan.bruens@rwth-aachen.de>
+Date: Mon, 21 Oct 2019 02:07:19 +0200
+Subject: [PATCH] Catch BadSignatureError raised by ecdsa 0.13.3 on
+ verification errors (#448)
+
+The new ecdsa no longer uses AssertionError when the signature is too long.
+This happens in the test suite, where "123" is appended to the signature.
+
+Fixes #447
+---
+ jwt/contrib/algorithms/py_ecdsa.py | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/jwt/contrib/algorithms/py_ecdsa.py b/jwt/contrib/algorithms/py_ecdsa.py
+index bf0dea5..f1170a6 100644
+--- a/jwt/contrib/algorithms/py_ecdsa.py
++++ b/jwt/contrib/algorithms/py_ecdsa.py
+@@ -56,5 +56,7 @@ def verify(self, msg, key, sig):
+ try:
+ return key.verify(sig, msg, hashfunc=self.hash_alg,
+ sigdecode=ecdsa.util.sigdecode_string)
+- except AssertionError:
++ # ecdsa <= 0.13.2 raises AssertionError on too long signatures,
++ # ecdsa >= 0.13.3 raises BadSignatureError for verification errors.
++ except (AssertionError, ecdsa.BadSignatureError):
+ return False
diff --git a/dev-python/pyjwt/pyjwt-1.7.1-r1.ebuild b/dev-python/pyjwt/pyjwt-1.7.1-r1.ebuild
new file mode 100644
index 000000000000..1cb2f6e14153
--- /dev/null
+++ b/dev-python/pyjwt/pyjwt-1.7.1-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+
+inherit distutils-r1 eutils
+
+MY_PN="PyJWT"
+DESCRIPTION="JSON Web Token implementation in Python"
+HOMEPAGE="https://github.com/progrium/pyjwt https://pypi.org/project/PyJWT/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+DEPEND="
+ test? (
+ >=dev-python/cryptography-1.4.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ find . -name '__pycache__' -prune -exec rm -rf {} + || die
+ find . -name '*.pyc' -delete || die
+
+ # enables coverage, we don't need that
+ rm setup.cfg || die
+ # kill tests using pycrypto that break with pycryptodome
+ sed -i -e '/has_pycrypto/s:True:False:' \
+ tests/contrib/test_algorithms.py || die
+
+ local PATCHES=(
+ "${FILESDIR}"/pyjwt-1.7.1-ecdsa-fix.patch
+ )
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ elog "Available optional features:"
+ optfeature "cryptography" dev-python/cryptography
+ optfeature "flake8" dev-python/flake8{,-import-order}
+
+ ewarn "flake8 feature requires 'pep8-naming' which is not packaged yet"
+}
diff --git a/dev-python/sure/sure-1.4.11.ebuild b/dev-python/sure/sure-1.4.11.ebuild
index d30b2728f231..15447975e25e 100644
--- a/dev-python/sure/sure-1.4.11.ebuild
+++ b/dev-python/sure/sure-1.4.11.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
inherit distutils-r1
diff --git a/dev-python/wrapt/wrapt-1.11.2-r1.ebuild b/dev-python/wrapt/wrapt-1.11.2-r1.ebuild
index 46b0288179ff..8260fc728419 100644
--- a/dev-python/wrapt/wrapt-1.11.2-r1.ebuild
+++ b/dev-python/wrapt/wrapt-1.11.2-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
inherit distutils-r1
diff --git a/games-fps/prboom-plus/Manifest b/games-fps/prboom-plus/Manifest
index 74314aab3b53..c1490c8fbdb3 100644
--- a/games-fps/prboom-plus/Manifest
+++ b/games-fps/prboom-plus/Manifest
@@ -1 +1 @@
-DIST prboom-plus-2.5.1.4.tar.gz 3007237 BLAKE2B 3dce8aad6fb521d13cf3e6b48a261f010b545bafa853860b284be0d0772f65b4fa0bfa965f7cb1869cc0d0eb21a4237e1873d08ff56d439cb3eed00f82bf12fb SHA512 625b75c5fe663bb3ba54bcd90f914ad7461c0860448f6f179180de26bea0a4d766739c50f96a8245687bc213742ec53bf6ffa26cde09772b3ae0bba91662213e
+DIST prboom-plus-2.5.1.5.4540.1.tar.xz 1023228 BLAKE2B 5b1c6aa80516cef4ced73701b640a261188c6eed818a204ef19f183061c0456f4af70dc8b466c240f5c8985903fe4daf0fed42cd32b47849c02b6c890fa807f0 SHA512 9fe207a395d92305dd3b89a38bc1376de6bd2a7bb29d454da42aea03a4ded82b49033d482d97c76377cbd1ecb7d8a65c9e0948af81ecd4e10bd49b0bad791bbc
diff --git a/games-fps/prboom-plus/metadata.xml b/games-fps/prboom-plus/metadata.xml
index 9ea5253b83db..555818481506 100644
--- a/games-fps/prboom-plus/metadata.xml
+++ b/games-fps/prboom-plus/metadata.xml
@@ -2,7 +2,15 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<longdescription lang="en">
- PrBoom+ is a Doom source port developed from the original PrBoom project.
+ PrBoom+ is an enhanced source port of the classic 3D first-person
+ shooter game Doom, first released by id Software in 1993. It uses the
+ Simple Direct Media layer (SDL) library and features an optional OpenGL
+ renderer. It is based on PrBoom, MBF and LxDoom, which in turn are based
+ on TeamTNT's Boom, a freely available port of Doom for DOS.
+
+ In addition to PrBoom's features, PrBoom+ offers uncapped framerate,
+ variable gamespeed, re-record, walkcam, chasecam, full mouselook, FOV,
+ and other features without loss of compatibility with the original Doom.
</longdescription>
<maintainer type="person">
<email>vilhelm.gray@gmail.com</email>
@@ -20,14 +28,12 @@
<flag name="dumb">Enable support for various tracker-style music formats via <pkg>media-libs/dumb</pkg></flag>
<flag name="fluidsynth">Enable support for MIDI via <pkg>media-sound/fluidsynth</pkg></flag>
<flag name="net">Enable support for network play</flag>
- <flag name="non-free">Enable non-free components</flag>
<flag name="portmidi">Enable support for MIDI via <pkg>media-libs/portmidi</pkg></flag>
- <flag name="sdl-image">Enable support for high-resolution texture support via <pkg>media-libs/sdl-image</pkg></flag>
- <flag name="sdl-mixer">Enable support for MIDI via <pkg>media-libs/sdl-mixer</pkg></flag>
+ <flag name="sdl2-image">Enable support for high-resolution texture support via <pkg>media-libs/sdl2-image</pkg></flag>
+ <flag name="sdl2-mixer">Enable support for MIDI via <pkg>media-libs/sdl2-mixer</pkg></flag>
</use>
<upstream>
- <bugs-to>https://sourceforge.net/p/prboom-plus/bugs</bugs-to>
+ <bugs-to>https://bugs.debian.org/prboom-plus</bugs-to>
<doc lang="en">https://prboom-plus.sourceforge.net</doc>
- <remote-id type="sourceforge">prboom-plus</remote-id>
</upstream>
</pkgmetadata>
diff --git a/games-fps/prboom-plus/prboom-plus-2.5.1.4.ebuild b/games-fps/prboom-plus/prboom-plus-2.5.1.4.ebuild
deleted file mode 100644
index aab17006b4b1..000000000000
--- a/games-fps/prboom-plus/prboom-plus-2.5.1.4.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools desktop xdg
-
-DESCRIPTION="A Doom source port developed from the original PrBoom project"
-HOMEPAGE="https://prboom-plus.sourceforge.net"
-# We are using a github mirror here because the upstream tarball is missing the
-# free dog assets; we should update SRC_URI to point to the upstream tarball
-# once the free assets are present as expected
-#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-SRC_URI="https://github.com/coelckers/prboom-plus/archive/f96f891d068dcc5ec52ed91056b46d27e9a8462d.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+
- non-free? ( freedist )
- !non-free? ( BSD )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="dumb fluidsynth mad net non-free +opengl pcre +png portmidi sdl-image +sdl-mixer vorbis"
-REQUIRED_USE="sdl-image? ( opengl )"
-
-DEPEND="
- media-libs/libsdl[opengl?,joystick,sound,video]
- dumb? ( media-libs/dumb )
- fluidsynth? ( media-sound/fluidsynth:= )
- mad? ( media-libs/libmad )
- net? ( media-libs/sdl-net )
- sdl-image? ( media-libs/sdl-image )
- pcre? ( dev-libs/libpcre:3 )
- png? ( media-libs/libpng:0= )
- portmidi? ( media-libs/portmidi )
- sdl-mixer? ( media-libs/sdl-mixer[midi] )
- vorbis? ( media-libs/libvorbis )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/prboom-plus-f96f891d068dcc5ec52ed91056b46d27e9a8462d/prboom2"
-PATCHES="${FILESDIR}/${P}-Remove-nonstandard-gamesdir-variable.patch"
-
-src_prepare() {
- xdg_src_prepare
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-cpu-opt \
- $(use_enable non-free nonfree-graphics) \
- $(use_enable opengl gl) \
- $(use_with dumb) \
- $(use_with fluidsynth) \
- $(use_with mad) \
- $(use_with net) \
- $(use_with pcre) \
- $(use_with png) \
- $(use_with portmidi) \
- $(use_with sdl-image image) \
- $(use_with sdl-mixer mixer) \
- $(use_with vorbis vorbisfile) \
- --with-waddir="${EPREFIX}/usr/share/doom"
-}
-
-src_install() {
- default
- newicon ICONS/prboom-plus.svg ${PN}.svg
- make_desktop_entry "${PN}" "PrBoom+"
-}
diff --git a/games-fps/prboom-plus/prboom-plus-2.5.1.5.4540.1.ebuild b/games-fps/prboom-plus/prboom-plus-2.5.1.5.4540.1.ebuild
new file mode 100644
index 000000000000..3e0833b7215c
--- /dev/null
+++ b/games-fps/prboom-plus/prboom-plus-2.5.1.5.4540.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop xdg
+
+MY_PV=$(ver_rs 4 "+svn" 5 "+dfsg")
+MY_P=${PN}-${MY_PV}
+DESCRIPTION="An enhanced clone of the classic first-person shooter Doom"
+HOMEPAGE="https://prboom-plus.sourceforge.net"
+SRC_URI="http://deb.debian.org/debian/pool/main/p/prboom-plus/${PN}_${MY_PV}.orig.tar.xz -> ${P}.tar.xz"
+
+LICENSE="GPL-2+ BSD BSD-with-disclosure LGPL-2.1+ MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dumb fluidsynth mad net +opengl +pcre portmidi sdl2-image +sdl2-mixer vorbis"
+REQUIRED_USE="sdl2-image? ( opengl )"
+
+DEPEND="
+ media-libs/libsdl2[opengl?,joystick,sound,video]
+ dumb? ( media-libs/dumb )
+ fluidsynth? ( media-sound/fluidsynth:= )
+ mad? ( media-libs/libmad )
+ net? ( media-libs/sdl2-net )
+ pcre? ( dev-libs/libpcre:3 )
+ portmidi? ( media-libs/portmidi )
+ sdl2-image? ( media-libs/sdl2-image )
+ sdl2-mixer? ( media-libs/sdl2-mixer[midi] )
+ vorbis? ( media-libs/libvorbis )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+PATCHES=(
+ "${FILESDIR}/${PN}-2.5.1.4-Remove-nonstandard-gamesdir-variable.patch"
+)
+
+src_prepare() {
+ xdg_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-cpu-opt \
+ --disable-nonfree-graphics \
+ $(use_enable opengl gl) \
+ $(use_with dumb) \
+ $(use_with fluidsynth) \
+ $(use_with mad) \
+ $(use_with net) \
+ $(use_with pcre) \
+ $(use_with portmidi) \
+ $(use_with sdl2-image image) \
+ $(use_with sdl2-mixer mixer) \
+ $(use_with vorbis vorbisfile) \
+ --with-waddir="${EPREFIX}/usr/share/doom"
+}
+
+src_install() {
+ default
+ doicon ICONS/${PN}.svg
+ domenu ICONS/${PN}.desktop
+}
diff --git a/licenses/BSD-with-disclosure b/licenses/BSD-with-disclosure
new file mode 100644
index 000000000000..41f1a450178b
--- /dev/null
+++ b/licenses/BSD-with-disclosure
@@ -0,0 +1,27 @@
+Copyright (c) <YEAR>, <OWNER>
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+
+1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+3. The name of the author may not be used to endorse or promote products
+ derived from this software without specific prior written permission.
+4. Full disclosure of the entire project's source code, except for third
+ party libraries is mandatory. (NOTE: This clause is non-negotiable!)
+
+THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
+IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
+INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
+NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/profiles/license_groups b/profiles/license_groups
index 90a8848787bc..dba24d230049 100644
--- a/profiles/license_groups
+++ b/profiles/license_groups
@@ -30,7 +30,7 @@ OSI-APPROVED AFL-3.0 AGPL-3 AGPL-3+ Apache-1.1 Apache-2.0 APL-1.0 APSL-2 Artisti
# Licenses in this list should NOT appear directly or indirectly in
# @FSF-APPROVED or @OSI-APPROVED.
# Note: Licenses for fonts should be included in @MISC-FREE-DOCS.
-MISC-FREE AIFFWriter.m Allegro alternate AMPAS bea.ri.jsr173 BEER-WARE boehm-gc BSD-1 BSD-with-attribution buddy bufexplorer.vim BZIP2 canfep CAOSL CDDL-1.1 CDDL-Schily CeCILL-C CMake CPL-0.5 CRACKLIB Crypt-IDEA DES docbook dom4j DUMB-0.9.3 eGenixPublic-1.1 ElementTree Emacs ErlPL-1.1 FastCGI feh File-MMagic Flashpix FLEX flexmock FLTK freetts FVWM gd gsm HTML-Tidy htmlc iASL icu IDPL imagemagick Info-ZIP inner-net Interbase-1.0 ipadic ipx-utils Ispell JDOM JNIC JOVE Khronos-CLHPP LambdaMOO LIBGLOSS libmng libpng libpng2 libtiff LLVM-Grant LPPL-1.3 LPPL-1.3b lsof Mail-Sendmail matplotlib Mini-XML minpack MIT-with-advertising mm mpich2 NCSA-HDF netcat NEWLIB ngrep Old-MIT openafs-krb5-a Openwall otter par PCRE perforce photopc PHP-2.02 pngcrush pngnq Princeton psutils rc rdisc regexp-UofT repoze RSA rwpng sash scanlogd sdlsasteroids Sendmail Sendmail-Open-Source shrimp SMAIL Snd SNIA SSLeay Subversion SVFL symlinks tablelist tcltk tcp_wrappers_license TeX TeX-other-free the-Click-license Time-Format Time-modules tm-align torque-2.5 totd Toyoda UCAR-Unidata URT VTK w3m wm2 x2x xbatt xboing XC Xdebug xtrs xvt ZSH
+MISC-FREE AIFFWriter.m Allegro alternate AMPAS bea.ri.jsr173 BEER-WARE boehm-gc BSD-1 BSD-with-attribution BSD-with-disclosure buddy bufexplorer.vim BZIP2 canfep CAOSL CDDL-1.1 CDDL-Schily CeCILL-C CMake CPL-0.5 CRACKLIB Crypt-IDEA DES docbook dom4j DUMB-0.9.3 eGenixPublic-1.1 ElementTree Emacs ErlPL-1.1 FastCGI feh File-MMagic Flashpix FLEX flexmock FLTK freetts FVWM gd gsm HTML-Tidy htmlc iASL icu IDPL imagemagick Info-ZIP inner-net Interbase-1.0 ipadic ipx-utils Ispell JDOM JNIC JOVE Khronos-CLHPP LambdaMOO LIBGLOSS libmng libpng libpng2 libtiff LLVM-Grant LPPL-1.3 LPPL-1.3b lsof Mail-Sendmail matplotlib Mini-XML minpack MIT-with-advertising mm mpich2 NCSA-HDF netcat NEWLIB ngrep Old-MIT openafs-krb5-a Openwall otter par PCRE perforce photopc PHP-2.02 pngcrush pngnq Princeton psutils rc rdisc regexp-UofT repoze RSA rwpng sash scanlogd sdlsasteroids Sendmail Sendmail-Open-Source shrimp SMAIL Snd SNIA SSLeay Subversion SVFL symlinks tablelist tcltk tcp_wrappers_license TeX TeX-other-free the-Click-license Time-Format Time-modules tm-align torque-2.5 totd Toyoda UCAR-Unidata URT VTK w3m wm2 x2x xbatt xboing XC Xdebug xtrs xvt ZSH
# Metaset for all free software
FREE-SOFTWARE @FSF-APPROVED @OSI-APPROVED @MISC-FREE
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/Manifest b/xfce-extra/xfce4-whiskermenu-plugin/Manifest
index 67a849465d20..57ea03b4acae 100644
--- a/xfce-extra/xfce4-whiskermenu-plugin/Manifest
+++ b/xfce-extra/xfce4-whiskermenu-plugin/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-whiskermenu-plugin-2.3.4.tar.bz2 160614 BLAKE2B 276842ef860965d139166ea6d8e988d39694aa06ace52bc3f48d6e3d9c9d8c930c3b9e44c3d9f84aaf7bb6fd9412a5efdda39834d8c2d33ed3f048db68893266 SHA512 8e59b6d0067e2302e3bf3e7f528cf96d613586c78c2ce6040143b449bffb3e3037b0d08738450c701d57f11cc5393154221bfbe5fa43825ca5df7ddd3c9f4cf4
DIST xfce4-whiskermenu-plugin-2.3.5.tar.bz2 160984 BLAKE2B c4a53ca34ed0eec2de27837c01d52ace334af5cf952b46b7f9f651314eb7f4aad52f5706ca8df7ddcfb4a9c0ed2fe207a138c3cb432306caa38220a6c13aa2fd SHA512 7697a5d41599df8150d4e7ad1c5898b651d196fb1bd1a657efee33206312455f24056edf679592e0a6a78b17b324fd5d93e202ae7cc461ca70df7cd41794bd58
+DIST xfce4-whiskermenu-plugin-2.4.0.tar.bz2 171617 BLAKE2B e0489370e5e83e8d18c9f42e706a32e43a623d7356ed698a32f6775c68971deb13efd6a49f770e81092f7822a0c589640930473edf8fd05928f3d2b08c5e532a SHA512 0c2cdebd57f2223c0c83975a3e20480776152a50c6d5f34f819d15e6e81b47e9fd8f657c014f0a25ce8425fa2361b7dfc9cc727bd8f0a4322a0ff33677b0db50