summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-11-24 10:14:56 -0500
committerMike Gilbert <floppym@gentoo.org>2017-11-24 10:19:26 -0500
commit2021b4da81d3fe59cd6b77317f11ec45c928e921 (patch)
tree38ca21820372db38314def79980770ce6be9005d
parentmedia-gfx/jhead: add libjhead's header (diff)
downloadgentoo-2021b4da81d3fe59cd6b77317f11ec45c928e921.tar.gz
gentoo-2021b4da81d3fe59cd6b77317f11ec45c928e921.tar.bz2
gentoo-2021b4da81d3fe59cd6b77317f11ec45c928e921.zip
dev-python/pytest: depend on setuptools at runtime
Closes: https://bugs.gentoo.org/638668
-rw-r--r--dev-python/pytest/pytest-3.0.3.ebuild2
-rw-r--r--dev-python/pytest/pytest-3.2.2.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/pytest/pytest-3.0.3.ebuild b/dev-python/pytest/pytest-3.0.3.ebuild
index 61fe2a0d9fb8..3651e51df43b 100644
--- a/dev-python/pytest/pytest-3.0.3.ebuild
+++ b/dev-python/pytest/pytest-3.0.3.ebuild
@@ -20,13 +20,13 @@ IUSE="doc test"
PY_VER="1.4.29"
COMMON_DEPEND="
>=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
doc? (
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
)
"
DEPEND="${COMMON_DEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
>=dev-python/hypothesis-3.5.2[${PYTHON_USEDEP}]
>dev-python/pytest-xdist-1.13[${PYTHON_USEDEP}]
diff --git a/dev-python/pytest/pytest-3.2.2.ebuild b/dev-python/pytest/pytest-3.2.2.ebuild
index c949a1553ce7..1a4caf32e250 100644
--- a/dev-python/pytest/pytest-3.2.2.ebuild
+++ b/dev-python/pytest/pytest-3.2.2.ebuild
@@ -20,13 +20,13 @@ IUSE="doc test"
PY_VER="1.4.33"
COMMON_DEPEND="
>=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
doc? (
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
)
"
DEPEND="${COMMON_DEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/setuptools_scm[${PYTHON_USEDEP}]
test? (
>=dev-python/hypothesis-3.5.2[${PYTHON_USEDEP}]