summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2024-12-23 09:03:24 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2024-12-23 09:03:24 +0000
commit216e7586dd23f551033cd7bf0aa9a76063566154 (patch)
treeb29562804de3942e7a258a07f19e397d628ae819
parent2024-12-23 08:18:43 UTC (diff)
parentdev-libs/botan: fix build w/o avx2 (diff)
downloadgentoo-216e7586dd23f551033cd7bf0aa9a76063566154.tar.gz
gentoo-216e7586dd23f551033cd7bf0aa9a76063566154.tar.bz2
gentoo-216e7586dd23f551033cd7bf0aa9a76063566154.zip
Merge updates from master
-rw-r--r--dev-libs/botan/botan-3.6.1.ebuild1
-rw-r--r--dev-libs/botan/files/botan-3.6.1-no-avx2.patch25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/botan/botan-3.6.1.ebuild b/dev-libs/botan/botan-3.6.1.ebuild
index e47afaa7b00d..7488dcffd9ec 100644
--- a/dev-libs/botan/botan-3.6.1.ebuild
+++ b/dev-libs/botan/botan-3.6.1.ebuild
@@ -58,6 +58,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${P}-boost-1.87.patch
"${FILESDIR}"/${P}-tests-glibcxx_assertions.patch
+ "${FILESDIR}"/${PN}-3.6.1-no-avx2.patch
)
python_check_deps() {
diff --git a/dev-libs/botan/files/botan-3.6.1-no-avx2.patch b/dev-libs/botan/files/botan-3.6.1-no-avx2.patch
new file mode 100644
index 000000000000..a4794738d6cd
--- /dev/null
+++ b/dev-libs/botan/files/botan-3.6.1-no-avx2.patch
@@ -0,0 +1,25 @@
+https://bugs.gentoo.org/946821
+https://github.com/randombit/botan/issues/4493
+https://github.com/randombit/botan/pull/4494
+
+From c7f8f6c0967faac1ba66ca3d55560b2aed12863a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ren=C3=A9=20Meusel?= <rene.meusel@rohde-schwarz.com>
+Date: Mon, 23 Dec 2024 09:29:07 +0100
+Subject: [PATCH] FIX: SM4 GFNI needs AVX2
+
+closes #4493
+---
+ src/lib/block/sm4/sm4_gfni/info.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/lib/block/sm4/sm4_gfni/info.txt b/src/lib/block/sm4/sm4_gfni/info.txt
+index 4c5867f9b72..5b5c87b42e7 100644
+--- a/src/lib/block/sm4/sm4_gfni/info.txt
++++ b/src/lib/block/sm4/sm4_gfni/info.txt
+@@ -9,4 +9,5 @@ brief -> "SM4 using Intel GFNI"
+
+ <isa>
+ gfni
++avx2
+ </isa>
+