summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2024-03-24 08:03:55 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2024-03-24 08:03:55 +0000
commit22ff968b9ca1ac8187233b64a07a3b6f100af999 (patch)
tree6c3805c8301beac02f592f8aecd07cc5d6ac9d99
parent2024-03-24 07:33:56 UTC (diff)
parentmedia-libs/libsoundtouch: respect LDFLAGS (diff)
downloadgentoo-22ff968b9ca1ac8187233b64a07a3b6f100af999.tar.gz
gentoo-22ff968b9ca1ac8187233b64a07a3b6f100af999.tar.bz2
gentoo-22ff968b9ca1ac8187233b64a07a3b6f100af999.zip
Merge updates from master
-rw-r--r--media-libs/libsoundtouch/files/libsoundtouch-2.3.2-configure-bashism.patch33
-rw-r--r--media-libs/libsoundtouch/files/libsoundtouch-2.3.2-flags.patch18
-rw-r--r--media-libs/libsoundtouch/libsoundtouch-2.3.2-r1.ebuild63
-rw-r--r--media-libs/libsoundtouch/libsoundtouch-2.3.2.ebuild10
-rw-r--r--media-libs/libsoundtouch/metadata.xml2
-rw-r--r--net-proxy/torsocks/Manifest2
-rw-r--r--net-proxy/torsocks/files/torsocks-2.4.0-configure.patch23
-rw-r--r--net-proxy/torsocks/torsocks-2.4.0-r2.ebuild (renamed from net-proxy/torsocks/torsocks-2.4.0-r1.ebuild)12
8 files changed, 151 insertions, 12 deletions
diff --git a/media-libs/libsoundtouch/files/libsoundtouch-2.3.2-configure-bashism.patch b/media-libs/libsoundtouch/files/libsoundtouch-2.3.2-configure-bashism.patch
new file mode 100644
index 000000000000..b49ebcd38aae
--- /dev/null
+++ b/media-libs/libsoundtouch/files/libsoundtouch-2.3.2-configure-bashism.patch
@@ -0,0 +1,33 @@
+https://codeberg.org/soundtouch/soundtouch/pulls/34
+
+From 429a4669cfee54ec69f8be61cc4b5ac2d87d1254 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 24 Mar 2024 07:19:34 +0000
+Subject: [PATCH 2/2] configure.ac: fix bashism in CXXFLAGS assignment
+
+configure scripts need to be runnable with a POSIX-compliant /bin/sh.
+
+On many (but not all!) systems, /bin/sh is provided by Bash, so errors
+like this aren't spotted. Notably Debian defaults to /bin/sh provided
+by dash which doesn't tolerate such bashisms as '=='.
+
+This retains compatibility with bash.
+
+Fixes configure warnings/errors like:
+```
+checking whether make supports nested variables... (cached) yes
+configure: 3698: CXXFLAGS+= -Ofast: not found
+```
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/configure.ac
++++ b/configure.ac
+@@ -33,7 +33,7 @@ AC_LANG(C++)
+
+ # Compiler flags. Apply -Ofast (implies -O3 -ffast-math) to allow gcc autovectorization
+ # generate effective SIMD code.
+-CXXFLAGS+=" -Ofast"
++CXXFLAGS="${CXXFLAGS} -Ofast"
+
+ # Set AR_FLAGS to avoid build warning "ar: `u' modifier ignored since `D' is the default (see `U')"
+ AR_FLAGS='cr'
diff --git a/media-libs/libsoundtouch/files/libsoundtouch-2.3.2-flags.patch b/media-libs/libsoundtouch/files/libsoundtouch-2.3.2-flags.patch
new file mode 100644
index 000000000000..badd42e43b26
--- /dev/null
+++ b/media-libs/libsoundtouch/files/libsoundtouch-2.3.2-flags.patch
@@ -0,0 +1,18 @@
+https://codeberg.org/soundtouch/soundtouch/pulls/35
+--- a/source/SoundTouchDLL/Makefile.am
++++ b/source/SoundTouchDLL/Makefile.am
+@@ -34,7 +34,7 @@ libSoundTouchDll_la_SOURCES=../SoundTouch/AAFilter.cpp ../SoundTouch/FIRFilter.c
+ # Compiler flags
+
+ # Modify the default 0.0.0 to LIB_SONAME.0.0
+-LDFLAGS=-version-info @LIB_SONAME@
++AM_LDFLAGS=$(LDFLAGS) -version-info @LIB_SONAME@
+
+ if X86
+ CXXFLAGS1=-mstackrealign -msse
+@@ -44,4 +44,4 @@ if X86_64
+ CXXFLAGS2=-fPIC
+ endif
+
+-CXXFLAGS+=$(AM_CXXFLAGS) $(CXXFLAGS1) $(CXXFLAGS2) -shared -DDLL_EXPORTS -fvisibility=hidden
++AM_CXXFLAGS=$(CXXFLAGS) $(CXXFLAGS1) $(CXXFLAGS2) -shared -DDLL_EXPORTS -fvisibility=hidden
diff --git a/media-libs/libsoundtouch/libsoundtouch-2.3.2-r1.ebuild b/media-libs/libsoundtouch/libsoundtouch-2.3.2-r1.ebuild
new file mode 100644
index 000000000000..642ab60742a3
--- /dev/null
+++ b/media-libs/libsoundtouch/libsoundtouch-2.3.2-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools multilib-minimal toolchain-funcs
+
+MY_PN=${PN/lib}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Audio processing library for changing tempo, pitch and playback rates"
+HOMEPAGE="https://www.surina.net/soundtouch/ https://codeberg.org/soundtouch/soundtouch"
+SRC_URI="https://www.surina.net/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_PN}"
+
+LICENSE="LGPL-2.1"
+# subslot = libSoundTouch.so soname
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cpu_flags_x86_sse openmp static-libs"
+
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3.2-configure-bashism.patch
+ "${FILESDIR}"/${PN}-2.3.2-flags.patch
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ sed -i "s:^\(dist_doc_DATA=\)COPYING.TXT :\1:" Makefile.am || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ --disable-integer-samples
+ $(use_enable cpu_flags_x86_sse x86-optimizations)
+ $(use_enable openmp)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" pkgdocdir="${EPREFIX}"/usr/share/doc/${PF}/html install
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/media-libs/libsoundtouch/libsoundtouch-2.3.2.ebuild b/media-libs/libsoundtouch/libsoundtouch-2.3.2.ebuild
index 36bff7c7e4a5..65fd97ae6c73 100644
--- a/media-libs/libsoundtouch/libsoundtouch-2.3.2.ebuild
+++ b/media-libs/libsoundtouch/libsoundtouch-2.3.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,8 +8,9 @@ inherit autotools multilib-minimal toolchain-funcs
MY_PN=${PN/lib}
MY_P=${MY_PN}-${PV}
DESCRIPTION="Audio processing library for changing tempo, pitch and playback rates"
-HOMEPAGE="https://www.surina.net/soundtouch/ https://gitlab.com/soundtouch/soundtouch"
+HOMEPAGE="https://www.surina.net/soundtouch/ https://codeberg.org/soundtouch/soundtouch"
SRC_URI="https://www.surina.net/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_PN}"
LICENSE="LGPL-2.1"
# subslot = libSoundTouch.so soname
@@ -19,7 +20,9 @@ IUSE="cpu_flags_x86_sse openmp static-libs"
BDEPEND="virtual/pkgconfig"
-S="${WORKDIR}/${MY_PN}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3.2-configure-bashism.patch
+)
pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
@@ -32,7 +35,6 @@ pkg_setup() {
src_prepare() {
default
sed -i "s:^\(dist_doc_DATA=\)COPYING.TXT :\1:" Makefile.am || die
- sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g' configure.ac || die
eautoreconf
}
diff --git a/media-libs/libsoundtouch/metadata.xml b/media-libs/libsoundtouch/metadata.xml
index 80c5adc46a80..fe8f7a319269 100644
--- a/media-libs/libsoundtouch/metadata.xml
+++ b/media-libs/libsoundtouch/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo Sound project</name>
</maintainer>
<upstream>
- <remote-id type="gitlab">soundtouch/soundtouch</remote-id>
+ <remote-id type="codeberg">soundtouch/soundtouch</remote-id>
</upstream>
</pkgmetadata>
diff --git a/net-proxy/torsocks/Manifest b/net-proxy/torsocks/Manifest
index 3af31a60f5ef..8fa5efad25c4 100644
--- a/net-proxy/torsocks/Manifest
+++ b/net-proxy/torsocks/Manifest
@@ -1 +1 @@
-DIST torsocks-2.4.0-r1.tar.gz 118991 BLAKE2B e1817c3bbf10f83431292c644d7187e40b62c5f223784074b3f9c082d8d75243090e226ffebb6fd81805fbd887588790833adc4ab8923e8116585c0a29255ad0 SHA512 7d625ce3a4600f87b86ae9ac79dfd206e7709cb0bafe0b7afcf33a6f1825f968cc63ad3e23c584582b244647bdeafbfdbfc54f7c81e521b0a3d278a1483ce86e
+DIST torsocks-v2.4.0.tar.bz2 96757 BLAKE2B af21b49623b01c6f70f4103168b2624837ca3c3905f5d39ed85482171ba608f74f4845bc05ad0df8353ce901a82ace1a3152fe6f61bd8ffbcbc74d2d80aa105a SHA512 95a97380d4b0f10296554dd5601e0f640d571454719998229974c4d2269ca636b74b7e8b402dddea68c0cbfce5ca5f2531690e1915167b3c7b87e9066e41bd83
diff --git a/net-proxy/torsocks/files/torsocks-2.4.0-configure.patch b/net-proxy/torsocks/files/torsocks-2.4.0-configure.patch
new file mode 100644
index 000000000000..96af0b4ee510
--- /dev/null
+++ b/net-proxy/torsocks/files/torsocks-2.4.0-configure.patch
@@ -0,0 +1,23 @@
+Fix bashism in libc.so filename check, and don't unconditionally set _F_S=2,
+as it clobbers e.g. _F_S=3.
+--- a/configure.ac
++++ b/configure.ac
+@@ -124,7 +124,7 @@ AS_CASE([$host_os],
+ [linux*|kfreebsd*-gnu|freebsd*],
+ [
+ libc_name=`ldd /usr/bin/yes | grep 'libc\.' | cut -d ' ' -f 1 | tr -d '\t'`
+- if test "${libc_name}" == ""; then
++ if test "${libc_name}" = ""; then
+ # Default libc on most system.
+ libc_name="libc.so.6"
+ fi
+@@ -258,9 +258,6 @@ AX_CHECK_LINK_FLAG([-pie],[LDFLAGS="$LDFLAGS -pie"],[],[])
+ AX_CHECK_LINK_FLAG([-z relro],[LDFLAGS="$LDFLAGS -z relro"],[],[])
+ AX_CHECK_LINK_FLAG([-z now],[LDFLAGS="$LDFLAGS -z now"],[],[])
+
+-dnl Add glibc hardening
+-CPPFLAGS="$CPPFLAGS -D_FORTIFY_SOURCE=2"
+-
+ ##############################################################################
+ # 10. Finish up
+ ##############################################################################
diff --git a/net-proxy/torsocks/torsocks-2.4.0-r1.ebuild b/net-proxy/torsocks/torsocks-2.4.0-r2.ebuild
index f4f8ba36bbf0..dc8c8a23ac6d 100644
--- a/net-proxy/torsocks/torsocks-2.4.0-r1.ebuild
+++ b/net-proxy/torsocks/torsocks-2.4.0-r2.ebuild
@@ -1,16 +1,15 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit autotools
-UPSTREAM_PF="${PN}-v${PV}"
-S=${WORKDIR}/${UPSTREAM_PF}
-
+UPSTREAM_P="${PN}-v${PV}"
DESCRIPTION="Use most socks-friendly applications with Tor"
HOMEPAGE="https://gitlab.torproject.org/tpo/core/torsocks"
-SRC_URI="https://gitlab.torproject.org/tpo/core/torsocks/-/archive/v${PV}/${UPSTREAM_PF}.tar.gz -> ${PF}.tar.gz"
+SRC_URI="https://gitlab.torproject.org/tpo/core/torsocks/-/archive/v${PV}/${UPSTREAM_P}.tar.bz2"
+S="${WORKDIR}"/${UPSTREAM_P}
LICENSE="GPL-2"
SLOT="0"
@@ -21,6 +20,7 @@ IUSE="static-libs"
PATCHES=(
"${FILESDIR}"/${PN}-2.4.0-clang16.patch
+ "${FILESDIR}"/${PN}-2.4.0-configure.patch
)
src_prepare() {
@@ -43,5 +43,5 @@ src_install() {
default
# Remove libtool .la files
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}