summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2017-04-25 19:24:57 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2017-04-25 19:24:57 +0000
commit26ffc1dda622e160fd8b83b5d045f2bf0eb17689 (patch)
tree25f08ddc19a21fb59eb20b38db404a89f8342e32
parent2017-04-25 19:00:52 UTC (diff)
parentqt5-build.eclass: update copyright year (diff)
downloadgentoo-26ffc1dda622e160fd8b83b5d045f2bf0eb17689.tar.gz
gentoo-26ffc1dda622e160fd8b83b5d045f2bf0eb17689.tar.bz2
gentoo-26ffc1dda622e160fd8b83b5d045f2bf0eb17689.zip
Merge updates from master
-rw-r--r--app-emulation/containerd/Manifest2
-rw-r--r--app-emulation/containerd/containerd-0.2.6.ebuild40
-rw-r--r--app-emulation/containerd/containerd-0.2.7.ebuild40
-rw-r--r--eclass/qt5-build.eclass4
-rw-r--r--games-strategy/freeorion/Manifest1
-rw-r--r--games-strategy/freeorion/freeorion-0.4.7_rc2.ebuild83
-rw-r--r--games-strategy/freeorion/freeorion-9999.ebuild87
7 files changed, 255 insertions, 2 deletions
diff --git a/app-emulation/containerd/Manifest b/app-emulation/containerd/Manifest
index c524e4fe21fc..dfc92c0b3911 100644
--- a/app-emulation/containerd/Manifest
+++ b/app-emulation/containerd/Manifest
@@ -2,3 +2,5 @@ DIST containerd-0.2.5.tar.gz 1003500 SHA256 88e099af66b50abe7f2159f13bdab793fa51
DIST containerd-0.2.5_p20170308.tar.gz 1021631 SHA256 d08d3d0758b76f7de0e8f503b74e1562d8c0a1014cb4baf4cd34e246751cec4c SHA512 8b00862a7b54490a8342bcc0eddaa7e8c86d1e05c02f5173b9f4a08321425f8d75d1fb0665e86bc79249294354977693c21d6a4d8405866ff8058da9772e2ecc WHIRLPOOL ed658d10f927fff4d9591930bdf855fc0ed259ca538d4361ce3cffcc5943dcfe39121242f1c9ef950897761016a8450b3a2117c0be0b8b0ebffeab330fe30b5d
DIST containerd-0.2.5_p20170315.tar.gz 1036056 SHA256 8223d934fa767fcabf45c734bdb616818a5eab8c95d525de6a69a350f4aeb826 SHA512 96f8a6a5053018fc7889583481c1e24d5cfd8cb780bd76d7c09d299cac836f0842927aa6c5ff7ae8b3cded99b596fce64c7db18f9de6dc527eacc2202baa01dd WHIRLPOOL feac3f3f1f078b46a4ef794e287fee78a34a59b159295f9f5779733e93c6b315cedde658538644d33a41057392c34a44b7de08942c77a03c456c1aef24862fa7
DIST containerd-0.2.5_p20170329.tar.gz 1036065 SHA256 da89086a7c643702a2ddecec67a45d3d8e4b0d610dd19036be63e6bd54cc1a85 SHA512 b7d56adaac26c9f0fd0900467fb5f8500472b602d7ce2373704c08ae6a0b852051e469a4fa51c8db475499872a51fcdd65c2adc4124102e66b8ca86cc5b2ff2f WHIRLPOOL 98567c28df37dbe3ad9f926fdae35e5ceb2df50c90373e58b14b1b5204d6eb9763050acf90abd40b44791510809ba3390f91b61a77265db078a221055557a301
+DIST containerd-0.2.6.tar.gz 1020572 SHA256 a67c4153ac5ae26b9d11daac133b90cba059ba16de7579e39c3e82bcda856493 SHA512 41018bda556a3ddfb1bd3a16e642548ba06f413b13fd1488e731896e277ba6c84a393ebd5de067ecaeccc695297a2b74edf22e5a3fe8f2e3eadf78d080bdeff6 WHIRLPOOL 98f64c888ea580074e51b91311ab186291cb2d3ecc9f178d828687dbb60b35104237041699b6125cf026edd245459a052fda1801ac3cd7e1efe34606c3d9a4eb
+DIST containerd-0.2.7.tar.gz 1034541 SHA256 cc46de64a75fa8babe0a85aac987f926870bf84d78040430f95ce478ed195122 SHA512 d0885fa37aaa1110d9312f81102e619ca4ae8d3c39c83c01852fd8618945121596169a1d41017d19ad32ff47b619a2c1c18a3582d290a56f08640412dcfc451a WHIRLPOOL 35748adf2c097dad4c60e48b2eb3389b57e78fc8d3b228f15b0297b5c1d037a77f29118089a5159c1f25baf7e4d7f93f6fc74d3cd2c85164711378e2df6e251d
diff --git a/app-emulation/containerd/containerd-0.2.6.ebuild b/app-emulation/containerd/containerd-0.2.6.ebuild
new file mode 100644
index 000000000000..cde4c658099c
--- /dev/null
+++ b/app-emulation/containerd/containerd-0.2.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/docker/${PN}"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_/-}"
+ EGIT_COMMIT="v${MY_PV}"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened +seccomp"
+
+DEPEND=""
+RDEPEND=">=app-emulation/docker-runc-1.0.0_rc2
+ seccomp? ( sys-libs/libseccomp )"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+src_compile() {
+ local options=( $(usex seccomp "seccomp") )
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
+}
+
+src_install() {
+ dobin bin/containerd* bin/ctr
+}
diff --git a/app-emulation/containerd/containerd-0.2.7.ebuild b/app-emulation/containerd/containerd-0.2.7.ebuild
new file mode 100644
index 000000000000..cde4c658099c
--- /dev/null
+++ b/app-emulation/containerd/containerd-0.2.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/docker/${PN}"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_/-}"
+ EGIT_COMMIT="v${MY_PV}"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened +seccomp"
+
+DEPEND=""
+RDEPEND=">=app-emulation/docker-runc-1.0.0_rc2
+ seccomp? ( sys-libs/libseccomp )"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+src_compile() {
+ local options=( $(usex seccomp "seccomp") )
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
+}
+
+src_install() {
+ dobin bin/containerd* bin/ctr
+}
diff --git a/eclass/qt5-build.eclass b/eclass/qt5-build.eclass
index e239b25ec2ec..9c3a76b67d64 100644
--- a/eclass/qt5-build.eclass
+++ b/eclass/qt5-build.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: qt5-build.eclass
@@ -47,7 +47,7 @@ esac
# for tests you should proceed with setting VIRTUALX_REQUIRED=test.
: ${VIRTUALX_REQUIRED:=manual}
-inherit eutils flag-o-matic toolchain-funcs versionator virtualx
+inherit estack flag-o-matic ltprune toolchain-funcs versionator virtualx
HOMEPAGE="https://www.qt.io/"
diff --git a/games-strategy/freeorion/Manifest b/games-strategy/freeorion/Manifest
index aa7542cc37f9..a4b1e956c972 100644
--- a/games-strategy/freeorion/Manifest
+++ b/games-strategy/freeorion/Manifest
@@ -1 +1,2 @@
DIST freeorion-0.4.6.tar.gz 145720274 SHA256 3e3ff3a758c8a1ffa71773dff18faff2c792051bb5162758b5f5b8ea59e8e311 SHA512 0488e36286358e8db2dcfe0cdae68e4638388fd2d4c627a258cdecf0afd57e9dbac03111f7683c3ef22edecbedd197a172d177400ddbb585a50f34804a50c50a WHIRLPOOL 30d56a2ca76158168492aa0d1b3fe5a9f164afd7dc378128fe2796ce149a9d65a64cd10c41c5b6c1510773e9ead564dff452869e6c384d949cd0789a51198b6c
+DIST freeorion-0.4.7_rc2.tar.gz 105944237 SHA256 6f9d2dd30609e65982fef197f4c64553e196a2c30dd9bae9db6b02758dd85191 SHA512 f703ae2e79d0ec1ba6217ff4de7fe443476ee280437f28e545286bfce7d20add5886c7275672091df2374222d03d535513a7d68db4e9bcc08bd72f1b28ca29d3 WHIRLPOOL c77c19f49c91452328c0b841f9bc127ab3c347963cd54582cd0fe587cc773565e6eec7e8cd3f1f30f7c690c24868029185e2c75bef32dcb53b25772bb1c1b0fd
diff --git a/games-strategy/freeorion/freeorion-0.4.7_rc2.ebuild b/games-strategy/freeorion/freeorion-0.4.7_rc2.ebuild
new file mode 100644
index 000000000000..1be8614838d4
--- /dev/null
+++ b/games-strategy/freeorion/freeorion-0.4.7_rc2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit cmake-utils python-any-r1 gnome2-utils
+
+DESCRIPTION="A free turn-based space empire and galactic conquest game"
+HOMEPAGE="http://www.freeorion.org"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/freeorion/freeorion.git"
+else
+ MY_PV="${PV/_/-}"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="GPL-2 LGPL-2.1 CC-BY-SA-3.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/boost-1.56[python,threads]
+ media-libs/freealut
+ media-libs/freetype
+ media-libs/glew:*
+ media-libs/libsdl2
+ >=media-libs/libogg-1.1.3
+ media-libs/libpng:0
+ media-libs/libsdl2[X,opengl,video]
+ >=media-libs/libvorbis-1.1.2
+ media-libs/openal
+ sci-physics/bullet
+ sys-libs/zlib
+ virtual/opengl
+ !dev-games/gigi"
+ # Use bundled gigi as of freeorion-0.4.3
+
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ # build system is using FindPythonLibs.cmake which needs python:2
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ sed -e "s/-O3//" -i CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_BUILD_TYPEE=Release
+ -DRELEASE_COMPILE_FLAGS=""
+ -DCMAKE_SKIP_RPATH=ON
+ )
+
+ append-cppflags -DBOOST_OPTIONAL_CONFIG_USE_OLD_IMPLEMENTATION_OF_OPTIONAL
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc ChangeLog.md
+
+ newenvd "${FILESDIR}/${PN}.envd" 99${PN}
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-strategy/freeorion/freeorion-9999.ebuild b/games-strategy/freeorion/freeorion-9999.ebuild
new file mode 100644
index 000000000000..a790572fcaf8
--- /dev/null
+++ b/games-strategy/freeorion/freeorion-9999.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit cmake-utils python-any-r1 gnome2-utils
+
+DESCRIPTION="A free turn-based space empire and galactic conquest game"
+HOMEPAGE="http://www.freeorion.org"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/freeorion/freeorion.git"
+else
+ RELDATE=2016-09-16
+ SHA=49f9123
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/FreeOrion_v${PV}_${RELDATE}.${SHA}_Source.tar.gz -> ${P}.tar.gz"
+ # Issue with version.cpp, TODO fix
+ #SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+
+ S="${WORKDIR}/src-tarball"
+fi
+
+LICENSE="GPL-2 LGPL-2.1 CC-BY-SA-3.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/boost-1.56[python,threads]
+ media-libs/freealut
+ media-libs/freetype
+ media-libs/glew:*
+ media-libs/libsdl2
+ >=media-libs/libogg-1.1.3
+ media-libs/libpng:0
+ media-libs/libsdl2[X,opengl,video]
+ >=media-libs/libvorbis-1.1.2
+ media-libs/openal
+ sci-physics/bullet
+ sys-libs/zlib
+ virtual/opengl
+ !dev-games/gigi"
+ # Use bundled gigi as of freeorion-0.4.3
+
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ # build system is using FindPythonLibs.cmake which needs python:2
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ sed -e "s/-O3//" -i CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_BUILD_TYPEE=Release
+ -DRELEASE_COMPILE_FLAGS=""
+ -DCMAKE_SKIP_RPATH=ON
+ )
+
+ append-cppflags -DBOOST_OPTIONAL_CONFIG_USE_OLD_IMPLEMENTATION_OF_OPTIONAL
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc ChangeLog.md
+
+ newenvd "${FILESDIR}/${PN}.envd" 99${PN}
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}