summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2022-10-21 00:45:03 -0500
committerJohn Helmert III <ajak@gentoo.org>2022-10-21 01:04:33 -0500
commit28f09fe35705c77bfdeb6066b2f859f54bdd0fa1 (patch)
tree894c61fcdaacff58550c27e5b05b9e40b3cd5d1a
parentwww-misc/buku: revbump to add DISTUTILS_USE_PEP517 (diff)
downloadgentoo-28f09fe35705c77bfdeb6066b2f859f54bdd0fa1.tar.gz
gentoo-28f09fe35705c77bfdeb6066b2f859f54bdd0fa1.tar.bz2
gentoo-28f09fe35705c77bfdeb6066b2f859f54bdd0fa1.zip
media-sound/pulsemixer: revbump to add DISTUTILS_USE_PEP517
Signed-off-by: John Helmert III <ajak@gentoo.org>
-rw-r--r--media-sound/pulsemixer/pulsemixer-1.5.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-sound/pulsemixer/pulsemixer-1.5.1-r1.ebuild b/media-sound/pulsemixer/pulsemixer-1.5.1-r1.ebuild
new file mode 100644
index 000000000000..114d7ce451a3
--- /dev/null
+++ b/media-sound/pulsemixer/pulsemixer-1.5.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1
+
+DESCRIPTION="CLI and curses mixer for PulseAudio"
+HOMEPAGE="https://github.com/GeorgeFilipkin/pulsemixer"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/GeorgeFilipkin/${PN}"
+else
+ SRC_URI="https://github.com/GeorgeFilipkin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="media-sound/pulseaudio"