summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-02 06:47:50 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-02 07:43:19 +0100
commit2e8e7c7176b5edc3a7b3497a0ddcd0a3ac81f3df (patch)
treeee50653d62806bb32ce528923212391a3b2d2f95
parentdev-debug/bpftrace: fix USE=fuzzing build (diff)
downloadgentoo-2e8e7c7176b5edc3a7b3497a0ddcd0a3ac81f3df.tar.gz
gentoo-2e8e7c7176b5edc3a7b3497a0ddcd0a3ac81f3df.tar.bz2
gentoo-2e8e7c7176b5edc3a7b3497a0ddcd0a3ac81f3df.zip
dev-python/botocore: Bump to 1.34.54
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.54.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index f08a4c0fe277..57a50f8d46e5 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,3 +5,4 @@ DIST botocore-1.34.50.gh.tar.gz 12731553 BLAKE2B 9f014ae935ba3cf0cfb52c68ae674f0
DIST botocore-1.34.51.gh.tar.gz 12732148 BLAKE2B 57df6b5825cc07b1179ca67b935c5bea270810377e1f62d9094dd318301140e3cde68551e9501331c825b46e17d267fa0aa30e92251d03039e72f53005f8ddb4 SHA512 8c09e99363f27ec840d392e3cfd2bf7cce42d79ad5e66d3eb77a5ddc5fd3d00070a3faaf602130d9fab0e86aee475cb8a33154de19e9c1458011cd0d6aeecebe
DIST botocore-1.34.52.gh.tar.gz 12741641 BLAKE2B 2a0106c3fc3414531f4edbe8105f589ebb8a5cc56d6d4b7a91e172889b9c5c287d5eadb2dff93d3ed5270d75d205600677079ea266dbcfbb74cfe85cfe4069ed SHA512 e511dc67e793400c94942752758fad320f424fcf13e2598d4b7ab39c326fbf0b0721bd92bb348878334254806b5bcd4108d7274463cbdae6fff0581a7f75a556
DIST botocore-1.34.53.gh.tar.gz 12747256 BLAKE2B a79257a473bfcaa25a8464a52d80d41ca51c597f66aadb242d1945de4137923fab19feaa827df54ac04897b66df9e25fdeddf79809dadcf96e72827da42c46e6 SHA512 fcdbcf41b369aca15a9991ac45f4ad133d251c4863cac49498978f5f433551a1347e5f58d4613fa3a344a6a675abf2bd4ddf51b1a5309ccaf0ea37b57d19957b
+DIST botocore-1.34.54.gh.tar.gz 12748623 BLAKE2B 2b4732636e0d7cf46e12fc2cf4320c7c4a89c79abe5102a06c0b60c61ca1f638edbfeda0248c3044dbfe594b3dcfe0e8e73f52011bcad0e96fa4c51f3b6b944f SHA512 36fbbd8ad1627b86723ffbb54149ffb7b740831cb31be2e9c0423d158c5755161ec853ef5f97f4fa2632116099266d5f8dc06e47fda6356f988eb39636f435aa
diff --git a/dev-python/botocore/botocore-1.34.54.ebuild b/dev-python/botocore/botocore-1.34.54.ebuild
new file mode 100644
index 000000000000..ba6cd2a5d2a2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.54.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}