summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2019-12-13 18:05:58 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2019-12-13 18:05:58 +0000
commit302eecfeeb8ab028eb33c4659c9bd12780d0b8ff (patch)
tree5fcc7df83299159f2aca01731148b712ec7d501a
parent2019-12-13 17:46:10 UTC (diff)
parentdev-tex/cjk-latex: port to EAPI=7 (diff)
downloadgentoo-302eecfeeb8ab028eb33c4659c9bd12780d0b8ff.tar.gz
gentoo-302eecfeeb8ab028eb33c4659c9bd12780d0b8ff.tar.bz2
gentoo-302eecfeeb8ab028eb33c4659c9bd12780d0b8ff.zip
Merge updates from master
-rw-r--r--dev-tex/cjk-latex/cjk-latex-4.8.4.ebuild85
-rw-r--r--sci-electronics/netgen/netgen-1.4.52.ebuild49
-rw-r--r--sci-libs/gaul-devel/gaul-devel-0.1849-r2.ebuild41
-rw-r--r--sci-libs/oc/oc-2.0.ebuild25
-rw-r--r--sci-libs/qfits/files/qfits-6.2.0-open.patch5
-rw-r--r--sci-libs/qfits/files/qfits-6.2.0-ttest.patch4
-rw-r--r--sci-libs/qfits/qfits-6.2.0.ebuild22
-rw-r--r--sci-libs/ta-lib/ta-lib-0.4.0.ebuild31
-rw-r--r--sci-libs/tnt/tnt-3.0.12.ebuild18
-rw-r--r--sci-libs/xgks-pmel/files/aclocal.patch12
-rw-r--r--sci-libs/xgks-pmel/xgks-pmel-2.5.5.ebuild35
11 files changed, 159 insertions, 168 deletions
diff --git a/dev-tex/cjk-latex/cjk-latex-4.8.4.ebuild b/dev-tex/cjk-latex/cjk-latex-4.8.4.ebuild
index 4393972bc9c6..d258be7dc29d 100644
--- a/dev-tex/cjk-latex/cjk-latex-4.8.4.ebuild
+++ b/dev-tex/cjk-latex/cjk-latex-4.8.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit latex-package elisp-common toolchain-funcs multilib eutils flag-o-matic
+inherit latex-package elisp-common toolchain-funcs flag-o-matic
MY_P="${P/-latex/}"
@@ -22,13 +22,16 @@ IUSE="doc emacs"
RDEPEND="virtual/latex-base
dev-libs/kpathsea
emacs? ( virtual/emacs )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- app-arch/unzip"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="app-arch/unzip
+ virtual/pkgconfig"
S="${WORKDIR}/${MY_P}"
src_prepare() {
+ default
for i in "${WORKDIR}"/CJK/*.tar.gz; do
tar -xzf ${i} || die "failed to unpack $i"
done
@@ -40,43 +43,43 @@ src_prepare() {
src_configure() {
has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
- cd utils
+ cd utils || die
for d in *conv; do
- cd $d
- local f=`echo $d | tr '[:upper:]' '[:lower:]'`
+ cd ${d} || die
+ local f=`echo ${d} | tr '[:upper:]' '[:lower:]'`
echo "all: $f" >> Makefile
- if [ $d = CEFconv ] ; then
+ if [ ${d} = CEFconv ] ; then
echo "all: cef5conv cefsconv" >> Makefile
fi
- cd -
+ cd - || die
done
- cd hbf2gf
+ cd hbf2gf || die
econf --with-kpathsea-lib="${EPREFIX}"/usr/$(get_libdir) \
--with-kpathsea-include="${EPREFIX}"/usr/include/kpathsea
}
src_compile() {
tc-export CC
- cd utils
+ cd utils || die
for d in *conv; do
- cd $d
+ cd ${d} || die
emake
- cd -
+ cd - || die
done
- cd hbf2gf
+ cd hbf2gf || die
emake
- cd -
+ cd - || die
if use emacs ; then
- cd lisp
+ cd lisp || die
elisp-compile *.el
- cd emacs
+ cd emacs || die
elisp-compile *.el
- cd ../mule-2.3
+ cd ../mule-2.3 || die
elisp-compile *.el
fi
- cd "${T}"
+ cd "${T}" || die
for f in "${S}"/texmf/hbf2gf/*.cfg ; do
env TEXMFCNF="${EPREFIX}/etc/texmf/web2c" HBF_TARGET="${S}/texmf/fonts" "${S}/utils/hbf2gf/hbf2gf" $f || die
@@ -90,39 +93,41 @@ src_compile() {
}
src_install() {
- cd utils
+ cd utils || die
for d in *conv; do
- cd $d
+ cd ${d} || die
local f=`echo $d | tr '[:upper:]' '[:lower:]'`
dobin *latex *conv
doman *.1
- cd -
+ cd - || die
done
- cd hbf2gf
- einstall || die "einstall failed"
+ cd hbf2gf || die
+ doman hbf2gf.1
+ dobin hbf2gf
+ dodir "${TEXMF}/fonts/hbf"
- cd "${S}"
+ cd "${S}" || die
# Install pk fonts
- pushd texmf &>/dev/null
+ pushd texmf &>/dev/null || die
for d in fonts/pk/modeless/*/* ; do
insinto ${TEXMF}/${d}
for f in "${T}"/${d##*/}*.pk ; do
- newins $f `basename ${f/.pk/.500pk}`
+ newins ${f} `basename ${f/.pk/.500pk}`
done
done
- popd &>/dev/null
+ popd &>/dev/null || die
insinto "${TEXMF}/tex/latex/${PN}"
- doins -r texinput/*
+ doins -r texinput
doins -r contrib/wadalab
if use emacs ; then
- cd utils/lisp
+ cd utils/lisp || die
elisp-install ${PN} *.el{,c} emacs/*.el{,c} mule-2.3/*.el{,c}
fi
- cd "${S}"
+ cd "${S}" || die
# uwpatch stuff
insinto ${TEXMF}/scripts/uwpatch
@@ -132,30 +137,30 @@ src_install() {
# jisksp40 stuff
insinto ${TEXMF}
- doins -r jisksp40/texmf/*
+ doins -r jisksp40/texmf
# kanji48 stuff
insinto ${TEXMF}
- doins -r kanji48/texmf/*
+ doins -r kanji48/texmf
use doc || rm -rf texmf/doc
insinto ${TEXMF}
- doins -r texmf/*
+ doins -r texmf
# Move fonts because hbf2gf expects them in MISCFONTS
mv "${ED}/${TEXMF}/fonts/hbf" "${ED}/${TEXMF}/fonts/misc" || die "mv font failed"
insinto ${TEXMF}/hbf2gf
- doins utils/hbf2gf/cfg/*
+ doins -r utils/hbf2gf/cfg/
insinto ${TEXMF}/scripts/subfonts
- doins utils/subfonts/*
+ doins -r utils/subfonts/
- rm -f doc/COPYING doc/INSTALL
+ rm -f doc/COPYING doc/INSTALL || die
dodoc ChangeLog README
if use doc ; then
insinto /usr/share/doc/${PF}
- doins -r doc/*
+ doins -r doc
doins -r examples
fi
docinto uwpatch
diff --git a/sci-electronics/netgen/netgen-1.4.52.ebuild b/sci-electronics/netgen/netgen-1.4.52.ebuild
index 0c90872fda8b..c07ac1310bcb 100644
--- a/sci-electronics/netgen/netgen-1.4.52.ebuild
+++ b/sci-electronics/netgen/netgen-1.4.52.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-
-inherit eutils
+EAPI=7
DESCRIPTION="LVS tool (layout versus schematic comparison)"
HOMEPAGE="http://www.opencircuitdesign.com/netgen/index.html"
@@ -14,46 +12,23 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE="X"
-DEPEND="X? (
+DEPEND="
+ X? (
dev-lang/tcl:0
dev-lang/tk:0
- x11-libs/libX11 )"
+ x11-libs/libX11
+ )"
RDEPEND="${DEPEND}"
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.4.40-tcl-bin-name.patch
-
- if $(use X) ; then
- cp -r "${S}" "${WORKDIR}"/with-x || die
- fi
-}
+PATCHES=( "${FILESDIR}"/${PN}-1.4.40-tcl-bin-name.patch )
src_configure() {
- cd scripts
- econf --without-x
-
- if $(use X) ; then
- cd "${WORKDIR}"/with-x/scripts || die
- econf --with-x
- fi
-}
-
-src_compile() {
- emake
-
- if $(use X) ; then
- cd "${WORKDIR}"/with-x || die
- emake
- fi
+ cd scripts || die
+ econf $(use_with X x)
}
src_install() {
- emake DESTDIR="${D}" DOCDIR=/usr/share/doc/${PF} install
-
- if $(use X) ; then
- cd "${WORKDIR}"/with-x || die
- emake DESTDIR="${D}" DOCDIR=/usr/share/doc/${PF} install
- fi
-
- dodoc Changes README TO_DO
+ emake DESTDIR="${D}" DOCDIR="${EPREFIX}"/usr/share/doc/${PF} install
+ einstalldocs
+ dodoc Changes TO_DO
}
diff --git a/sci-libs/gaul-devel/gaul-devel-0.1849-r2.ebuild b/sci-libs/gaul-devel/gaul-devel-0.1849-r2.ebuild
index 56d910c69c5a..883d578b3fea 100644
--- a/sci-libs/gaul-devel/gaul-devel-0.1849-r2.ebuild
+++ b/sci-libs/gaul-devel/gaul-devel-0.1849-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit autotools eutils
+inherit autotools
DESCRIPTION="Genetic Algorithm Utility Library"
HOMEPAGE="http://GAUL.sourceforge.net/"
@@ -12,34 +12,33 @@ SRC_URI="mirror://sourceforge/gaul/${P}-0.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug slang static-libs"
+IUSE="slang"
-DEPEND="
- sys-apps/sed
- slang? ( sys-libs/slang )"
-RDEPEND="${DEPEND}"
+RDEPEND="slang? ( sys-libs/slang:= )"
+DEPEND="${RDEPEND}"
-S=${WORKDIR}/${P}-0
+S="${WORKDIR}/${P}-0"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-slang2-error.patch
+ "${FILESDIR}"/${P}-as-needed.patch
+)
src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-slang2-error.patch \
- "${FILESDIR}"/${P}-as-needed.patch
+ default
+ mv configure.{in,ac} || die
eautoreconf
}
src_configure() {
- local myconf
- use slang || myconf="--enable-slang=no"
- if use debug ; then
- myconf="${myconf} --enable-debug=yes --enable-memory-debug=yes"
- else
- myconf="${myconf} --enable-g=no"
- fi
- econf $(use_enable static-libs static) ${myconf}
+ econf \
+ --disable-static \
+ $(use_enable slang)
}
src_install() {
- MAKEOPTS+=" -j1"
default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}
diff --git a/sci-libs/oc/oc-2.0.ebuild b/sci-libs/oc/oc-2.0.ebuild
index f44b5451489a..24434e06661f 100644
--- a/sci-libs/oc/oc-2.0.ebuild
+++ b/sci-libs/oc/oc-2.0.ebuild
@@ -1,26 +1,33 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit autotools-utils
+EAPI=7
DESCRIPTION="Network Data Access Protocol client C library"
HOMEPAGE="http://opendap.org/"
SRC_URI="http://opendap.org/pub/OC/source/${P}.tar.gz"
LICENSE="LGPL-2"
-
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc static-libs"
+IUSE="doc"
+# tests need network
+RESTRICT="test"
RDEPEND="net-misc/curl"
DEPEND="${RDEPEND}"
-# tests need network
-#PROPERTIES=network
+src_configure() {
+ econf --disable-static
+}
src_install() {
- autotools-utils_src_install
- use doc; dodoc docs/oc*html && dohtml docs/html/*
+ if use doc; then
+ dodoc docs/oc*html
+ HTML_DOCS=( docs/html/. )
+ fi
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}
diff --git a/sci-libs/qfits/files/qfits-6.2.0-open.patch b/sci-libs/qfits/files/qfits-6.2.0-open.patch
index 71d2df1a692a..951970da6dc4 100644
--- a/sci-libs/qfits/files/qfits-6.2.0-open.patch
+++ b/sci-libs/qfits/files/qfits-6.2.0-open.patch
@@ -1,6 +1,5 @@
-diff -ur qfits-6.2.0/src/qfits_memory.c qfits-6.2.0.new/src/qfits_memory.c
---- qfits-6.2.0/src/qfits_memory.c 2006-08-24 17:01:56.000000000 +0200
-+++ qfits-6.2.0.new/src/qfits_memory.c 2007-09-21 13:43:19.000000000 +0200
+--- a/src/qfits_memory.c
++++ b/src/qfits_memory.c
@@ -308,7 +308,7 @@
/* Create swap file with rights: rw-rw-rw- */
swapfileid = ++ qfits_memory_table.file_reg ;
diff --git a/sci-libs/qfits/files/qfits-6.2.0-ttest.patch b/sci-libs/qfits/files/qfits-6.2.0-ttest.patch
index ee87bfc702ca..a333a32e0a68 100644
--- a/sci-libs/qfits/files/qfits-6.2.0-ttest.patch
+++ b/sci-libs/qfits/files/qfits-6.2.0-ttest.patch
@@ -1,5 +1,5 @@
---- test/test_tfits.c 2006-04-27 14:08:43.000000000 +0100
-+++ test/test_tfits.c.new 2007-02-23 00:29:41.000000000 +0000
+--- a/test/test_tfits.c
++++ b/test/test_tfits.c
@@ -322,7 +322,7 @@
* Test on BINARY tables
*/
diff --git a/sci-libs/qfits/qfits-6.2.0.ebuild b/sci-libs/qfits/qfits-6.2.0.ebuild
index e98cd4afcfa2..181c4777ba8a 100644
--- a/sci-libs/qfits/qfits-6.2.0.ebuild
+++ b/sci-libs/qfits/qfits-6.2.0.ebuild
@@ -1,23 +1,27 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-
-inherit autotools-utils
+EAPI=7
DESCRIPTION="ESO stand-alone C library offering easy access to FITS files"
HOMEPAGE="http://www.eso.org/projects/aot/qfits/"
SRC_URI="ftp://ftp.hq.eso.org/pub/${PN}/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc static-libs"
-DEPEND=""
-RDEPEND=""
+IUSE="doc"
PATCHES=( "${FILESDIR}"/${P}-{ttest,open}.patch )
+src_configure() {
+ econf --disable-static
+}
+
src_install() {
- autotools-utils_src_install
- use doc && dohtml html/*
+ use doc && HTML_DOCS=( html/. )
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}
diff --git a/sci-libs/ta-lib/ta-lib-0.4.0.ebuild b/sci-libs/ta-lib/ta-lib-0.4.0.ebuild
index 99cb7258bb33..7a7a581a503c 100644
--- a/sci-libs/ta-lib/ta-lib-0.4.0.ebuild
+++ b/sci-libs/ta-lib/ta-lib-0.4.0.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-AUTOTOOLS_AUTORECONF=yes
-
-inherit autotools-utils
+inherit autotools
DESCRIPTION="Technical Analysis Library for analyzing financial markets trends"
HOMEPAGE="http://www.ta-lib.org/"
@@ -14,15 +12,28 @@ SRC_URI="mirror://sourceforge/ta-lib/${P}-src.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="static-libs"
-S="${WORKDIR}"/${PN}
+S="${WORKDIR}/${PN}"
PATCHES=( "${FILESDIR}"/${P}-asneeded.patch )
-AUTOTOOLS_IN_SOURCE_BUILD=1
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
src_test() {
- ewarn "Note: this testsuite will fail without an active internet connection."
- "${S}"/src/tools/ta_regtest/ta_regtest || die "Failed testsuite."
+ src/tools/ta_regtest/ta_regtest || die
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}
diff --git a/sci-libs/tnt/tnt-3.0.12.ebuild b/sci-libs/tnt/tnt-3.0.12.ebuild
index 2a622ddfa0c2..9de7e6dca2ee 100644
--- a/sci-libs/tnt/tnt-3.0.12.ebuild
+++ b/sci-libs/tnt/tnt-3.0.12.ebuild
@@ -1,28 +1,22 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit versionator
-
-MYP="${PN}_$(replace_all_version_separators '_')"
+MY_P="${PN}_$(ver_rs 1-3 '_')"
DESCRIPTION="Template Numerical Toolkit: C++ headers for array and matrices"
HOMEPAGE="http://math.nist.gov/tnt/"
-SRC_URI="http://math.nist.gov/tnt/${MYP}.zip"
+SRC_URI="http://math.nist.gov/tnt/${MY_P}.zip"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND="app-arch/unzip"
-RDEPEND=""
+BDEPEND="app-arch/unzip"
S="${WORKDIR}/${PN}"
src_install() {
- insinto /usr/include
- doins *.h
+ doheader *.h
}
diff --git a/sci-libs/xgks-pmel/files/aclocal.patch b/sci-libs/xgks-pmel/files/aclocal.patch
index 48d44d747647..dbedb2e49f29 100644
--- a/sci-libs/xgks-pmel/files/aclocal.patch
+++ b/sci-libs/xgks-pmel/files/aclocal.patch
@@ -1,5 +1,5 @@
---- port/aclocal.m4.orig 2009-04-26 13:33:51.434402251 -0700
-+++ port/aclocal.m4 2009-04-26 13:43:33.466651210 -0700
+--- a/port/aclocal.m4
++++ b/port/aclocal.m4
@@ -582,26 +582,6 @@
])])
@@ -122,8 +122,8 @@
# Check for udres(3) library.
#
define([UC_LIB_UDRES], [dnl
---- port/configure.in.orig 2009-04-26 13:34:08.430308009 -0700
-+++ port/configure.in 2009-04-26 13:44:26.218430537 -0700
+--- a/port/configure.in
++++ b/port/configure.in
@@ -24,8 +24,6 @@
UC_PROG_FORTC
UC_PROG_NEQN
@@ -133,8 +133,8 @@
UC_PROG_INSTALL
UC_UDPOSIX
---- port/master.mk.in.orig 2009-04-26 13:34:18.848400960 -0700
-+++ port/master.mk.in 2009-04-26 13:45:03.187651071 -0700
+--- a/port/master.mk.in
++++ b/port/master.mk.in
@@ -19,8 +19,6 @@
INSTALL_DATA = @INSTALL_DATA@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
diff --git a/sci-libs/xgks-pmel/xgks-pmel-2.5.5.ebuild b/sci-libs/xgks-pmel/xgks-pmel-2.5.5.ebuild
index a329866fa003..cc8aa0b44b78 100644
--- a/sci-libs/xgks-pmel/xgks-pmel-2.5.5.ebuild
+++ b/sci-libs/xgks-pmel/xgks-pmel-2.5.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils fortran-2 toolchain-funcs multilib
+inherit fortran-2 toolchain-funcs
DESCRIPTION="PMEL fork of XGKS, an X11-based version of the ANSI Graphical Kernel System"
HOMEPAGE="http://www.gentoogeek.org/viewvc/Linux/xgks-pmel/"
@@ -14,15 +14,13 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="doc"
-RDEPEND="
- x11-libs/libX11"
-DEPEND="${RDEPEND}
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+BDEPEND="
sys-devel/flex
sys-apps/groff"
-src_prepare() {
- epatch "${FILESDIR}"/aclocal.patch
-}
+PATCHES=( "${FILESDIR}"/aclocal.patch )
src_configure() {
sed -i -e "s:lib64:$(get_libdir):g" port/master.mk.in \
@@ -40,28 +38,27 @@ src_compile() {
# Fails parallel build, bug #295724
emake -j1
-
- cd src/fortran
- emake -j1
+ emake -C src/fortran -j1
}
src_install() {
- cd "${S}"/progs
-
- for tool in {defcolors,font,mi,pline,pmark}; do
+ pushd progs >/dev/null || die
+ local tool
+ for tool in defcolors font mi pline pmark; do
newbin ${tool} xgks-${tool}
done
+ popd >/dev/null || die
- cd "${S}"
dolib.a src/lib/libxgks.a
- dodoc COPYRIGHT HISTORY INSTALL README
+ dodoc COPYRIGHT HISTORY README
doman doc/{xgks.3,xgks_synop.3}
if use doc; then
newdoc doc/binding/cbinding.me cbinding
newdoc doc/userdoc/userdoc.me userdoc
- insinto /usr/share/doc/${P}/examples
- doins progs/{hanoi.c,star.c}
+
+ docinto examples
+ dodoc progs/{hanoi.c,star.f}
fi
insinto /usr/include/xgks