summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-30 15:32:37 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-30 15:32:37 +0200
commit30774feeb8e42221e159e316a9676e124452335a (patch)
tree973b444d842034049e693f484c8a55794e0d9e7f
parentsys-cluster/ceph: Add dev-vcs/git dep (diff)
downloadgentoo-30774feeb8e42221e159e316a9676e124452335a.tar.gz
gentoo-30774feeb8e42221e159e316a9676e124452335a.tar.bz2
gentoo-30774feeb8e42221e159e316a9676e124452335a.zip
xfce-extra/xfce4-screenshooter: Bump to 1.11.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-extra/xfce4-screenshooter/Manifest1
-rw-r--r--xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.11.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-screenshooter/Manifest b/xfce-extra/xfce4-screenshooter/Manifest
index 766a2aba225a..2a71d88e359d 100644
--- a/xfce-extra/xfce4-screenshooter/Manifest
+++ b/xfce-extra/xfce4-screenshooter/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-screenshooter-1.10.6.tar.bz2 813187 BLAKE2B 2f5d12cd1879d35911fee159e909f8b64970831fdd350fd46ca64371376592d30db8658d03045cc84d52ce16c19ec374dcb926b0151fcfc35e365832eb3b8803 SHA512 2984ff3a64d0783c62ad5ac33ef54f4ec70fb6d06ac66f4a963940878d04b5e77c100a8121b73788ce6cc0af427fec9d5bf09235465b3591cd57cd16c7d9cda2
DIST xfce4-screenshooter-1.11.0.tar.bz2 720373 BLAKE2B 8a6cf00a61be097a41222db42b887a97972013c3f93e0b969db5d0c1fc75a0f85a8b0f671b0047dba2198ad770045a608e078323d06b265a688efd700100cbf8 SHA512 afe7c97799c94e498b4304923d48ec195ebba776ecb626df55b4e5b091e53717d331a7513cde1095b1da5c1fac93fc52ab5a77c67ffbd71931c3bb4f5eb3dc64
+DIST xfce4-screenshooter-1.11.1.tar.bz2 721424 BLAKE2B 386e203b534993f93ffa6fc8c6d15dcbcefd79ca1c133a61ff157b406d96cef30da58bb6dcc069fd7e1d9911a256adaaa4fa01541ab07d61f683f1f603f73477 SHA512 aee31311faea2bb08d5e29722da190b0c7e2b37948a688a49212cd57cc4efc3f43b3c1588d9326f97eb174771412c60707cc88ae2ee0596546e9750a06112588
diff --git a/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.11.1.ebuild b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.11.1.ebuild
new file mode 100644
index 000000000000..ed2919ed920f
--- /dev/null
+++ b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.11.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Xfce4 screenshooter application and panel plugin"
+HOMEPAGE="
+ https://docs.xfce.org/apps/xfce4-screenshooter/start
+ https://gitlab.xfce.org/apps/xfce4-screenshooter/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="X wayland"
+REQUIRED_USE="|| ( X wayland )"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gdk-pixbuf-2.16
+ >=x11-libs/gtk+-3.24.0:3[X?,wayland?]
+ >=x11-libs/pango-1.44.0
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/xfce4-panel-4.16.0:=
+ >=xfce-base/libxfce4util-4.16.0:=
+ >=xfce-base/libxfce4ui-4.16.0:=
+ >=xfce-base/xfconf-4.16.0:=
+ wayland? (
+ dev-libs/wayland
+ )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXfixes
+ >=x11-libs/libXi-1.7.8
+ x11-libs/libXtst
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/glib-utils
+ sys-apps/help2man
+ sys-devel/gettext
+ virtual/pkgconfig
+ wayland? (
+ dev-util/wayland-scanner
+ )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable X x11)
+ $(use_enable X libxtst)
+ $(use_enable wayland)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}