summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-12 10:05:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-12 10:37:11 +0200
commit3271309b292bb198077520fcf630fa81548db3ae (patch)
tree80e979dce4c860a59f1a4ffc5cc8b14032375458
parentdev-python/pydantic: Bump to 1.8.2 (diff)
downloadgentoo-3271309b292bb198077520fcf630fa81548db3ae.tar.gz
gentoo-3271309b292bb198077520fcf630fa81548db3ae.tar.bz2
gentoo-3271309b292bb198077520fcf630fa81548db3ae.zip
dev-python/botocore: Bump to 1.20.71
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.71.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 4457861ca1e7..6c3387e4f238 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -6,3 +6,4 @@ DIST botocore-1.20.67.tar.gz 7691087 BLAKE2B b56cb7e80179b7c5c2b4daa27907870c075
DIST botocore-1.20.68.tar.gz 7692876 BLAKE2B a5de44db992688a7ceff14e2663e21f370811871d87286215d04db9d0ba9649c67c047b6ec290967eddcdc8cc6fd12bbe9c99589fea183ec2b2036dc69f4d7e6 SHA512 f3de8f5cb621174dc0ed1b8c8d4cbbc3cee56f0b0f4363767cfc68a879fc6e837225e82538640736687efa4340d62ff3d1923abc315f914b0a9189f775c65b6b
DIST botocore-1.20.69.tar.gz 7695769 BLAKE2B 994e5415c278a0c021deb1749c59ee5c654c7212cc2a1961fb2c528b7f5aea0a4d3f70c88a72489410cda935c8498cb3c4b1ec4830b3150ee043eb3429174781 SHA512 dbb0e77484a545489b54a1f71c78d2cf7d95b7f3a4f4ec54a9c07d7af354e9037d6eaa3100cf6a8e89d778bb0ed19f9475d68dceee98666bd69a4b05662c5939
DIST botocore-1.20.70.tar.gz 7700136 BLAKE2B ab7ea88763dd4637754a5d9eb955e0947efd9c5fa87856276056d6eaac341f57d5edd43ca830dd35c1283c6f41de43be2f9b06e8f328a8900cde41ec5953bf9d SHA512 d992b88df31a77b153fd3110119d1523587e98d56e4b80ac14d0c5351d76b3e4c188295fbbeafcd8efd3f414a1c0af0d78f21555b2d3285d6f8e88eefab282dc
+DIST botocore-1.20.71.tar.gz 7720081 BLAKE2B 4f5d4f237222a034d2102cb637722c7d63ac34549ca582fce8d7b02a93345cc48067b195f339010a0dd47fa04a53ee4dde5f98eb58a1db3b0d4c958066717063 SHA512 7a9154efeeedc90dd9089641798494095cca9f1967e3615131af154e718081e2ce85e37fea1a729e7d7cd42d2fd6a9f79cae9409ff32aa18674a40a0e2fd0fe1
diff --git a/dev-python/botocore/botocore-1.20.71.ebuild b/dev-python/botocore/botocore-1.20.71.ebuild
new file mode 100644
index 000000000000..4e5d698e619b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.71.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}