summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-10 22:36:08 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-10 22:38:22 +0200
commit3362206d916422cbdb854203943f9ff9c5c20685 (patch)
treef39f72f3ad7024c9d7f2057ef19922772ac9b7d4
parentdev-python/pytest-mock: Enable py3.11 (diff)
downloadgentoo-3362206d916422cbdb854203943f9ff9c5c20685.tar.gz
gentoo-3362206d916422cbdb854203943f9ff9c5c20685.tar.bz2
gentoo-3362206d916422cbdb854203943f9ff9c5c20685.zip
dev-python/simplejson: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/simplejson/simplejson-3.17.5-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/simplejson/simplejson-3.17.5-r1.ebuild b/dev-python/simplejson/simplejson-3.17.5-r1.ebuild
new file mode 100644
index 000000000000..a8971fc8bc71
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.17.5-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="
+ https://github.com/simplejson/simplejson/
+ https://pypi.org/project/simplejson/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+DOCS=( README.rst CHANGES.txt )
+
+distutils_enable_tests unittest