summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2023-01-20 14:02:13 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2023-01-20 14:02:13 +0000
commit3d7a9f3fe189e21bd14c77c994fb7ec454ccb5db (patch)
tree6fb1a625cd32da5ed2e13f92e00070ac2c7bc8bd
parent2023-01-20 13:47:53 UTC (diff)
parentprofiles: Unmask kde-plasma/plasma-welcome so it can be keyworded (diff)
downloadgentoo-3d7a9f3fe189e21bd14c77c994fb7ec454ccb5db.tar.gz
gentoo-3d7a9f3fe189e21bd14c77c994fb7ec454ccb5db.tar.bz2
gentoo-3d7a9f3fe189e21bd14c77c994fb7ec454ccb5db.zip
Merge updates from master
-rw-r--r--dev-libs/plasma-wayland-protocols/Manifest1
-rw-r--r--dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.10.0.ebuild19
-rw-r--r--media-gfx/converseen/Manifest1
-rw-r--r--media-gfx/converseen/converseen-0.9.10.0.ebuild52
-rw-r--r--media-gfx/tuxpaint/Manifest1
-rw-r--r--media-gfx/tuxpaint/tuxpaint-0.9.24-r2.ebuild71
-rw-r--r--media-gfx/tuxpaint/tuxpaint-0.9.28-r1.ebuild67
-rw-r--r--media-gfx/tuxpaint/tuxpaint-0.9.28-r2.ebuild4
-rw-r--r--profiles/package.mask1
9 files changed, 74 insertions, 143 deletions
diff --git a/dev-libs/plasma-wayland-protocols/Manifest b/dev-libs/plasma-wayland-protocols/Manifest
index 89b3ddad185e..9fbc01e18907 100644
--- a/dev-libs/plasma-wayland-protocols/Manifest
+++ b/dev-libs/plasma-wayland-protocols/Manifest
@@ -1 +1,2 @@
+DIST plasma-wayland-protocols-1.10.0.tar.xz 43268 BLAKE2B 1f0bc6fcd822ed8f010a1e9144b4e423e44de04c429e39a465e2ef5e59553d22db08fc379b84cc93624fa5dd64ca00ddc7d0e788251809036bfd09c8fe6ae0b7 SHA512 ddb09de9b3320f8e10d21c5d201ffe43d7e1f2f6c0d0c1b33aced28d8c324c9439800b4bd1516e7a34e45b1ac94e252c825216378d52b5cd6d671d73baa24c03
DIST plasma-wayland-protocols-1.9.0.tar.xz 42920 BLAKE2B cdf277f0fad842b018bdc05cfcb7834b81750784d395fc24ef1c906d828d178268f524af5e3383d0f2f799a73aad44d78a82c4fa333f420cdf89674ed98d373b SHA512 96157622e22b19da9b2b842a9996595d75b792c179127e617347429d01bc8236d44cc12a5c34dd2ed903d4b43791ffaedc44cf773b82da9b60a06f711353a68c
diff --git a/dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.10.0.ebuild b/dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.10.0.ebuild
new file mode 100644
index 000000000000..6835a08de545
--- /dev/null
+++ b/dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.10.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_NONGUI=true
+KFMIN=5.82.0
+inherit ecm kde.org
+
+DESCRIPTION="Plasma Specific Protocols for Wayland"
+HOMEPAGE="https://invent.kde.org/libraries/plasma-wayland-protocols"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
diff --git a/media-gfx/converseen/Manifest b/media-gfx/converseen/Manifest
index 07783b3a2e17..725f9fcb6224 100644
--- a/media-gfx/converseen/Manifest
+++ b/media-gfx/converseen/Manifest
@@ -1 +1,2 @@
+DIST converseen-0.9.10.0.tar.gz 769693 BLAKE2B 651edf41b6cdf010fdae47d457f2459c4e99a1657302bc4facfbd70bd7d7b7b85842290b74ea76a396fa75ca5f5398234d309aae179704ce40f1dbb61195835c SHA512 c2ee7c59685879dffcb6f3f4ef9267cb611d358bec21ecd57b90bbc7fa86a07b4aa8dd855956970b35ec671c57b8bbc4d0620c2cb5629a36ca4305e47f4d3b59
DIST converseen-0.9.9.8.tar.gz 769184 BLAKE2B 136d4454825fd64bd8129544df25213346550d4a1bf550fd8c32eef7c2c02cda5965aa235ec8f637de53462968a08c1e1b7c5db454c68ed1cac64d08c322fd54 SHA512 64ef5c5614c6536d84c6fc5ad6f9180c45a4c9d1294e492f0b09a596203d91871191f62ef80c6f888f010377c834ae76d825a29b137885756cc33a7d38d70208
diff --git a/media-gfx/converseen/converseen-0.9.10.0.ebuild b/media-gfx/converseen/converseen-0.9.10.0.ebuild
new file mode 100644
index 000000000000..45e1cbd45d90
--- /dev/null
+++ b/media-gfx/converseen/converseen-0.9.10.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Batch image converter and resizer based on ImageMagick"
+HOMEPAGE="https://converseen.fasterland.net/
+ https://github.com/Faster3ck/Converseen/"
+SRC_URI="https://github.com/Faster3ck/Converseen/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+# FIXME: graphicsmagick dependency does not work properly, failures when compiling
+# || ( media-gfx/imagemagick[cxx] media-gfx/graphicsmagick[cxx,imagemagick] )
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-gfx/imagemagick:=[cxx]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+
+S="${WORKDIR}/${P^}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.9.0-appdata-path.patch"
+ "${FILESDIR}/${PN}-0.9.9.0-no-update.patch"
+)
+
+pkg_postinst() {
+ elog "Please note that due to security policy restrictions"
+ elog "on media-gfx/imagemagick the support for PS, PDF and"
+ elog "XPS files must be explicitly enabled by commenting out"
+ elog "the respective policies in /etc/ImageMagick-7/policy.xml."
+ elog "See https://wiki.gentoo.org/wiki/ImageMagick#Troubleshooting"
+ elog "for more information."
+
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/media-gfx/tuxpaint/Manifest b/media-gfx/tuxpaint/Manifest
index af5f57e33be0..602f0fbbc91e 100644
--- a/media-gfx/tuxpaint/Manifest
+++ b/media-gfx/tuxpaint/Manifest
@@ -1,3 +1,2 @@
-DIST tuxpaint-0.9.24.tar.gz 15561675 BLAKE2B 971baec8b7728cbb54a2a45b604c152a9620d0f6a1856cca99482ad0fd76f2a4493aab81f54e10e5da4d81800b0e3506cb73dda0e00510ef966b0c98f8aa5cb4 SHA512 a4ee9eea833f9a6313701a4686f9f276570df84436c68d9a3d04e9448a8ea00833207e1034965e15145be744194c7b9a7d3c91bdfa3489d06a61de84b64cc723
DIST tuxpaint-0.9.27.tar.gz 14292992 BLAKE2B f1337b828604bac968325437eba21046f871a0e07e049f2d3568f44adac400e729f4c6d46bcba9eddf9078089aaf55aab7d0774fb5ab126b96d317b59e37ee00 SHA512 197c6e23fb772edd57614e34dec23e160ece528b58e4a17d67fe4100c58cbcd6c4b5efccfbb24ca760b3a20755230b47f4e3e49969e75ba04ce722102a7f2dd9
DIST tuxpaint-0.9.28.tar.gz 14802638 BLAKE2B 7f7a8f3d61faf052d9872b5af775a6becdefae7cee1207ebcbb5db108fc381b0fa5ba8b7a8facd55ba6dcfca59886125cba7837d2de432fd5c75d2c40b509c41 SHA512 038f92f8d7ee8d85b1c9b18f7781e814ee55067e090fbfa597028e2d13218911157d00f312de2be9db29754a07c5706fc3c3e0e6ea3c71a15f80c37bb2eceb34
diff --git a/media-gfx/tuxpaint/tuxpaint-0.9.24-r2.ebuild b/media-gfx/tuxpaint/tuxpaint-0.9.24-r2.ebuild
deleted file mode 100644
index 324da8c01842..000000000000
--- a/media-gfx/tuxpaint/tuxpaint-0.9.24-r2.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop optfeature toolchain-funcs xdg
-
-DESCRIPTION="Drawing program designed for young children"
-HOMEPAGE="http://www.tuxpaint.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-
-RDEPEND="
- app-text/libpaper:=
- dev-libs/fribidi
- gnome-base/librsvg:2
- >=media-libs/libpng-1.2:0=
- >=media-libs/freetype-2:2
- media-libs/libsdl[joystick]
- media-libs/sdl-image[png]
- media-libs/sdl-mixer
- media-libs/sdl-pango
- media-libs/sdl-ttf
- x11-libs/cairo
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-util/gperf
- media-gfx/imagemagick[jpeg,png,svg]
- sys-devel/gettext
-"
-
-src_prepare() {
- xdg_src_prepare
-
- sed -i \
- -e 's|linux_ARCH_INSTALL:=install-xdg|linux_ARCH_INSTALL:=|' \
- -e "s|linux_PREFIX:=/usr/local|linux_PREFIX:=/usr|" \
- -e "s:/lib/:/$(get_libdir)/:g" \
- -e 's:/share/doc/tuxpaint-$(VER_VERSION)/:'"/share/doc/${PF}/:g" \
- -e '/@gzip -f/d' \
- -e '/@chmod a+rx,g-w,o-w $(MAN_PREFIX)/d' \
- -e "s|linux_ARCH_CFLAGS:=|linux_ARCH_CFLAGS:= ${CFLAGS}|" \
- Makefile || die
-}
-
-src_compile() {
- # parallel build may break things
- emake -j1 CC="$(tc-getCC)"
-}
-
-src_install() {
- emake -j1 DESTDIR="${D}" install
- local file size
- for file in data/images/icon[0-9]*x[0-9]*.png; do
- size=${file##*/icon}
- size=${size%%x*}
- newicon -s "${size}" "${file}" tux4kids-tuxpaint.png
- done
- newmenu src/tuxpaint.desktop tux4kids-tuxpaint.desktop
- dodoc docs/*.txt
- dodoc docs/en/*.txt
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- optfeature "additional graphic stamps" media-gfx/tuxpaint-stamps
-}
diff --git a/media-gfx/tuxpaint/tuxpaint-0.9.28-r1.ebuild b/media-gfx/tuxpaint/tuxpaint-0.9.28-r1.ebuild
deleted file mode 100644
index 22513e2bb481..000000000000
--- a/media-gfx/tuxpaint/tuxpaint-0.9.28-r1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit desktop optfeature toolchain-funcs xdg
-
-DESCRIPTION="Drawing program designed for young children"
-HOMEPAGE="https://www.tuxpaint.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}-sdl1.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/${P}-sdl1
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-RDEPEND="
- app-text/libpaper:=
- dev-libs/fribidi
- gnome-base/librsvg:2
- >=media-libs/libpng-1.2:0=
- >=media-libs/freetype-2:2
- media-libs/libsdl[X,joystick]
- media-libs/sdl-image[png]
- media-libs/sdl-mixer
- media-libs/sdl-pango
- media-libs/sdl-ttf
- media-libs/sdl-gfx:=
- media-gfx/libimagequant
- sys-libs/zlib
- x11-libs/cairo
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-util/gperf
- media-gfx/graphicsmagick[jpeg,png,svg]
- sys-devel/gettext
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-Makefile.patch
-)
-
-src_compile() {
- emake CC="$(tc-getCC)" LIBDIR="$(get_libdir)"
-}
-
-src_install() {
- # Parallel install may break the building process
- # See: https://bugs.gentoo.org/859169
- emake -j1 DESTDIR="${D}" install
- local file size
- for file in data/images/icon[0-9]*x[0-9]*.png; do
- size=${file##*/icon}
- size=${size%%x*}
- newicon -s "${size}" "${file}" tux4kids-tuxpaint.png
- done
- newmenu src/tuxpaint.desktop tux4kids-tuxpaint.desktop
- docinto /usr/share/doc/${PF}
- dodoc docs/*.txt
- dodoc docs/en/*.txt
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- optfeature "additional graphic stamps" media-gfx/tuxpaint-stamps
-}
diff --git a/media-gfx/tuxpaint/tuxpaint-0.9.28-r2.ebuild b/media-gfx/tuxpaint/tuxpaint-0.9.28-r2.ebuild
index e8221ae4e7d1..1ee910e78064 100644
--- a/media-gfx/tuxpaint/tuxpaint-0.9.28-r2.ebuild
+++ b/media-gfx/tuxpaint/tuxpaint-0.9.28-r2.ebuild
@@ -46,9 +46,7 @@ src_compile() {
}
src_install() {
- # Parallel install may break the building process
- # See: https://bugs.gentoo.org/859169
- emake -j1 DESTDIR="${D}" GENTOO_LIBDIR="$(get_libdir)" install
+ emake DESTDIR="${D}" GENTOO_LIBDIR="$(get_libdir)" install
local file size
for file in data/images/icon[0-9]*x[0-9]*.png; do
size=${file##*/icon}
diff --git a/profiles/package.mask b/profiles/package.mask
index b863143be758..a3e1e2a68273 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -82,7 +82,6 @@
~kde-plasma/plasma-workspace-5.26.90
~kde-plasma/plasma-workspace-wallpapers-5.26.90
~kde-plasma/plasma-vault-5.26.90
-~kde-plasma/plasma-welcome-5.26.90
~kde-plasma/plymouth-kcm-5.26.90
~kde-plasma/polkit-kde-agent-5.26.90
~kde-plasma/powerdevil-5.26.90