summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-11-13 13:16:04 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-11-13 13:38:00 +0100
commit3f36bd4d40e605b647fdb807474c080a6a89b427 (patch)
tree3e238c1fc553bfb9c66a3b2266f530cc67b3d308
parentapp-emacs/cider: bump to 1.11.1 (diff)
downloadgentoo-3f36bd4d40e605b647fdb807474c080a6a89b427.tar.gz
gentoo-3f36bd4d40e605b647fdb807474c080a6a89b427.tar.bz2
gentoo-3f36bd4d40e605b647fdb807474c080a6a89b427.zip
app-emacs/compat: bump to 29.1.4.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/compat/Manifest1
-rw-r--r--app-emacs/compat/compat-29.1.4.4.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/compat/Manifest b/app-emacs/compat/Manifest
index d7aab19cc37c..aa24480a8ca7 100644
--- a/app-emacs/compat/Manifest
+++ b/app-emacs/compat/Manifest
@@ -1 +1,2 @@
DIST compat-29.1.4.2.tar.gz 128695 BLAKE2B e02d431c307b08d07888362a20fb597cfcb275b645522229a116169eff7f875ff3dbf23bb1344249fa8ac2b25cf7ade20752ce9e97188a49d851ba5ae1dfa8cb SHA512 a31fb1564b1bad20f0f7a0a400e9834e88c2e21b8c022ce4696e27cddc351b7c882765235accde0b3f4a417680699bc5bb69f7485436c8e64d799e8a5ac9e390
+DIST compat-29.1.4.4.tar.gz 129900 BLAKE2B 460aa851cbb341290cef250e70bf501a30cd174cd135ea429f7a3aa71597804c802c4225424072b49b4b7726b6e31c0ba36e6c0a4e154a2048075697656c2d31 SHA512 b6ecfde494dc5b1e96ed6d6cb450b3b647761c30128859a03d0d054e633227dd0714dd4ee8d39cf9eb4d702e9f08feaba41c39d91e6871724c458173e16d9e89
diff --git a/app-emacs/compat/compat-29.1.4.4.ebuild b/app-emacs/compat/compat-29.1.4.4.ebuild
new file mode 100644
index 000000000000..4c6643fbd200
--- /dev/null
+++ b/app-emacs/compat/compat-29.1.4.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Compatibility libraries for Emacs"
+HOMEPAGE="https://github.com/emacs-compat/compat/
+ https://git.sr.ht/~pkal/compat/"
+SRC_URI="https://github.com/emacs-compat/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="sys-apps/texinfo"
+
+ELISP_TEXINFO="${PN}.texi"
+
+src_compile() {
+ emake compile ${PN}.info
+}
+
+src_test() {
+ local has_json="$("${EMACS}" ${EMACSFLAGS} --eval "(princ (fboundp 'json-parse-string))")"
+ if [[ "${has_json}" != t ]] ; then
+ local line
+ while read line ; do
+ ewarn "${line}"
+ done <<-EOF
+ Your current Emacs version does not support native JSON parsing,
+ which is required for running tests of ${CATEGORY}/${PN}.
+ Emerge >=app-editors/emacs-27 with USE="json" and use "eselect emacs"
+ to select that version.
+ EOF
+ else
+ emake test
+ fi
+}