summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2018-09-15 22:04:12 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2018-09-15 22:04:12 +0000
commit4163598c484eecd353b7ac65ff94ac729e08841e (patch)
treeb3c5c6a1966bdaa85d82f1f4190809927ae03291
parent2018-09-15 21:44:28 UTC (diff)
parentmedia-gfx/inkscape: Fix ugly bug with PDF import and Type3 fonts (diff)
downloadgentoo-4163598c484eecd353b7ac65ff94ac729e08841e.tar.gz
gentoo-4163598c484eecd353b7ac65ff94ac729e08841e.tar.bz2
gentoo-4163598c484eecd353b7ac65ff94ac729e08841e.zip
Merge updates from master
-rw-r--r--media-gfx/inkscape/files/inkscape-0.92.3-poppler-0.64-2.patch160
-rw-r--r--media-gfx/inkscape/inkscape-0.92.3-r1.ebuild180
-rw-r--r--net-libs/libssh/Manifest1
-rw-r--r--net-libs/libssh/libssh-0.8.1.ebuild115
-rw-r--r--net-libs/libssh/libssh-0.8.2.ebuild30
5 files changed, 351 insertions, 135 deletions
diff --git a/media-gfx/inkscape/files/inkscape-0.92.3-poppler-0.64-2.patch b/media-gfx/inkscape/files/inkscape-0.92.3-poppler-0.64-2.patch
new file mode 100644
index 000000000000..4608bc79ecde
--- /dev/null
+++ b/media-gfx/inkscape/files/inkscape-0.92.3-poppler-0.64-2.patch
@@ -0,0 +1,160 @@
+From 66d05776ea2d403f2f48437f70d096a09724dfec Mon Sep 17 00:00:00 2001
+From: Eduard Braun <eduard.braun2@gmx.de>
+Date: Wed, 5 Sep 2018 00:31:06 +0200
+Subject: [PATCH] Modified fix for compatibility with poppler 0.64
+
+This is slightly uglier than f0697de012598ea84edafea9a326e5e101eccd2a
+but avoids duplicating strings (which is unnecessary and leaked memory).
+
+It's also closer to what upstream intended with the changes in 0.64.
+
+(cherry picked from commit 722e121361d0f784083d10e897155b7d4e44e515)
+---
+ .../internal/pdfinput/pdf-parser.cpp | 19 ++++++++++++++++---
+ src/extension/internal/pdfinput/pdf-parser.h | 6 ++++++
+ .../internal/pdfinput/svg-builder.cpp | 6 +++---
+ src/extension/internal/pdfinput/svg-builder.h | 4 ++--
+ 4 files changed, 27 insertions(+), 8 deletions(-)
+
+diff --git a/src/extension/internal/pdfinput/pdf-parser.cpp b/src/extension/internal/pdfinput/pdf-parser.cpp
+index a3aa3213a1..ea9f902e09 100644
+--- a/src/extension/internal/pdfinput/pdf-parser.cpp
++++ b/src/extension/internal/pdfinput/pdf-parser.cpp
+@@ -36,6 +36,7 @@ extern "C" {
+ #include "pdf-parser.h"
+ #include "util/units.h"
+
++#include "glib/poppler-features.h"
+ #include "goo/gmem.h"
+ #include "goo/GooString.h"
+ #include "GlobalParams.h"
+@@ -2581,7 +2582,11 @@ void PdfParser::opShowSpaceText(Object args[], int /*numArgs*/)
+ }
+ }
+
++#if POPPLER_CHECK_VERSION(0,64,0)
+ void PdfParser::doShowText(const GooString *s) {
++#else
++void PdfParser::doShowText(GooString *s) {
++#endif
+ GfxFont *font;
+ int wMode;
+ double riseX, riseY;
+@@ -2594,7 +2599,11 @@ void PdfParser::doShowText(const GooString *s) {
+ Object charProc;
+ Dict *resDict;
+ Parser *oldParser;
++#if POPPLER_CHECK_VERSION(0,64,0)
++ const char *p;
++#else
+ char *p;
++#endif
+ int len, n, uLen;
+
+ font = state->getFont();
+@@ -2630,7 +2639,7 @@ void PdfParser::doShowText(const GooString *s) {
+ double lineX = state->getLineX();
+ double lineY = state->getLineY();
+ oldParser = parser;
+- p = g_strdup(s->getCString());
++ p = s->getCString();
+ len = s->getLength();
+ while (len > 0) {
+ n = font->getNextChar(p, len, &code,
+@@ -2685,7 +2694,7 @@ void PdfParser::doShowText(const GooString *s) {
+
+ } else {
+ state->textTransformDelta(0, state->getRise(), &riseX, &riseY);
+- p = g_strdup(s->getCString());
++ p = s->getCString();
+ len = s->getLength();
+ while (len > 0) {
+ n = font->getNextChar(p, len, &code,
+@@ -2731,7 +2740,11 @@ void PdfParser::opXObject(Object args[], int /*numArgs*/)
+ {
+ Object obj1, obj2, obj3, refObj;
+
+- char *name = g_strdup(args[0].getName());
++#if POPPLER_CHECK_VERSION(0,64,0)
++ const char *name = args[0].getName();
++#else
++ char *name = args[0].getName();
++#endif
+ #if defined(POPPLER_NEW_OBJECT_API)
+ if ((obj1 = res->lookupXObject(name)).isNull()) {
+ #else
+diff --git a/src/extension/internal/pdfinput/pdf-parser.h b/src/extension/internal/pdfinput/pdf-parser.h
+index f985b15cad..ed28274f42 100644
+--- a/src/extension/internal/pdfinput/pdf-parser.h
++++ b/src/extension/internal/pdfinput/pdf-parser.h
+@@ -25,6 +25,7 @@ namespace Inkscape {
+ // TODO clean up and remove using:
+ using Inkscape::Extension::Internal::SvgBuilder;
+
++#include "glib/poppler-features.h"
+ #include "goo/gtypes.h"
+ #include "Object.h"
+
+@@ -287,7 +288,12 @@ private:
+ void opMoveShowText(Object args[], int numArgs);
+ void opMoveSetShowText(Object args[], int numArgs);
+ void opShowSpaceText(Object args[], int numArgs);
++#if POPPLER_CHECK_VERSION(0,64,0)
+ void doShowText(const GooString *s);
++#else
++ void doShowText(GooString *s);
++#endif
++
+
+ // XObject operators
+ void opXObject(Object args[], int numArgs);
+diff --git a/src/extension/internal/pdfinput/svg-builder.cpp b/src/extension/internal/pdfinput/svg-builder.cpp
+index 617861928d..767c8af4d4 100644
+--- a/src/extension/internal/pdfinput/svg-builder.cpp
++++ b/src/extension/internal/pdfinput/svg-builder.cpp
+@@ -1020,9 +1020,9 @@ void SvgBuilder::updateFont(GfxState *state) {
+ GfxFont *font = state->getFont();
+ // Store original name
+ if (font->getName()) {
+- _font_specification = g_strdup(font->getName()->getCString());
++ _font_specification = font->getName()->getCString();
+ } else {
+- _font_specification = (char*) "Arial";
++ _font_specification = "Arial";
+ }
+
+ // Prune the font name to get the correct font family name
+@@ -1030,7 +1030,7 @@ void SvgBuilder::updateFont(GfxState *state) {
+ char *font_family = NULL;
+ char *font_style = NULL;
+ char *font_style_lowercase = NULL;
+- char *plus_sign = strstr(_font_specification, "+");
++ const char *plus_sign = strstr(_font_specification, "+");
+ if (plus_sign) {
+ font_family = g_strdup(plus_sign + 1);
+ _font_specification = plus_sign + 1;
+diff --git a/src/extension/internal/pdfinput/svg-builder.h b/src/extension/internal/pdfinput/svg-builder.h
+index ed2a4d48e0..55daacee74 100644
+--- a/src/extension/internal/pdfinput/svg-builder.h
++++ b/src/extension/internal/pdfinput/svg-builder.h
+@@ -80,7 +80,7 @@ struct SvgGlyph {
+ bool style_changed; // Set to true if style has to be reset
+ SPCSSAttr *style;
+ int render_mode; // Text render mode
+- char *font_specification; // Pointer to current font specification
++ const char *font_specification; // Pointer to current font specification
+ };
+
+ /**
+@@ -202,7 +202,7 @@ private:
+
+ SPCSSAttr *_font_style; // Current font style
+ GfxFont *_current_font;
+- char *_font_specification;
++ const char *_font_specification;
+ double _font_scaling;
+ bool _need_font_update;
+ Geom::Affine _text_matrix;
+--
+2.19.0
+
diff --git a/media-gfx/inkscape/inkscape-0.92.3-r1.ebuild b/media-gfx/inkscape/inkscape-0.92.3-r1.ebuild
new file mode 100644
index 000000000000..36a68a10d4e9
--- /dev/null
+++ b/media-gfx/inkscape/inkscape-0.92.3-r1.ebuild
@@ -0,0 +1,180 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit autotools flag-o-matic gnome2-utils xdg toolchain-funcs python-single-r1
+
+MY_P="${P/_/}"
+
+DESCRIPTION="A SVG based generic vector-drawing program"
+HOMEPAGE="https://inkscape.org/"
+SRC_URI="https://inkscape.global.ssl.fastly.net/media/resources/file/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="cdr dia dbus exif gnome imagemagick openmp postscript inkjar jpeg latex"
+IUSE+=" lcms nls spell static-libs visio wpg"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ >=app-text/poppler-0.26.0:=[cairo]
+ >=dev-cpp/glibmm-2.48
+ >=dev-cpp/gtkmm-2.18.0:2.4
+ >=dev-cpp/cairomm-1.9.8
+ >=dev-libs/boehm-gc-7.1:=
+ >=dev-libs/glib-2.28
+ >=dev-libs/libsigc++-2.0.12
+ >=dev-libs/libxml2-2.6.20
+ >=dev-libs/libxslt-1.0.15
+ dev-libs/popt
+ dev-python/lxml[${PYTHON_USEDEP}]
+ media-gfx/potrace
+ media-gfx/scour[${PYTHON_USEDEP}]
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/libpng:0
+ sci-libs/gsl:=
+ x11-libs/libX11
+ >=x11-libs/gtk+-2.10.7:2
+ >=x11-libs/pango-1.24
+ cdr? (
+ media-libs/libcdr
+ app-text/libwpg:0.3
+ dev-libs/librevenge
+ )
+ dbus? ( dev-libs/dbus-glib )
+ exif? ( media-libs/libexif )
+ gnome? ( >=gnome-base/gnome-vfs-2.0 )
+ imagemagick? ( media-gfx/imagemagick:=[cxx] )
+ jpeg? ( virtual/jpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ spell? (
+ app-text/aspell
+ app-text/gtkspell:2
+ )
+ visio? (
+ media-libs/libvisio
+ app-text/libwpg:0.3
+ dev-libs/librevenge
+ )
+ wpg? (
+ app-text/libwpg:0.3
+ dev-libs/librevenge
+ )
+"
+
+# These only use executables provided by these packages
+# See share/extensions for more details. inkscape can tell you to
+# install these so we could of course just not depend on those and rely
+# on that.
+RDEPEND="${COMMON_DEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ media-gfx/uniconvertor
+ dia? ( app-office/dia )
+ latex? (
+ media-gfx/pstoedit[plotutils]
+ app-text/dvipsk
+ app-text/texlive-core
+ )
+ postscript? ( app-text/ghostscript-gpl )
+"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/boost-1.36
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.92.1-automagic.patch"
+ "${FILESDIR}/${PN}-0.91_pre3-cppflags.patch"
+ "${FILESDIR}/${PN}-0.92.1-desktop.patch"
+ "${FILESDIR}/${PN}-0.91_pre3-exif.patch"
+ "${FILESDIR}/${PN}-0.91_pre3-sk-man.patch"
+ "${FILESDIR}/${PN}-0.48.4-epython.patch"
+ "${FILESDIR}/${PN}-0.92.3-freetype_pkgconfig.patch"
+ "${FILESDIR}/${PN}-0.92.3-poppler-0.64.patch"
+ "${FILESDIR}/${PN}-0.92.3-poppler-0.65.patch"
+ "${FILESDIR}/${PN}-0.92.3-poppler-0.64-2.patch"
+)
+
+S="${WORKDIR}/${MY_P}"
+
+RESTRICT="test"
+
+pkg_pretend() {
+ if use openmp; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+}
+
+src_prepare() {
+ default
+
+ sed -i "s#@EPYTHON@#${EPYTHON}#" \
+ src/extension/implementation/script.cpp || die
+
+ eautoreconf
+
+ # bug 421111
+ python_fix_shebang share/extensions
+}
+
+src_configure() {
+ # aliasing unsafe wrt #310393
+ append-flags -fno-strict-aliasing
+
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable nls)
+ $(use_enable openmp)
+ $(use_enable exif)
+ $(use_enable jpeg)
+ $(use_enable lcms)
+ --enable-poppler-cairo
+ $(use_enable wpg)
+ $(use_enable visio)
+ $(use_enable cdr)
+ $(use_enable dbus dbusapi)
+ $(use_enable imagemagick magick)
+ $(use_with gnome gnome-vfs)
+ $(use_with inkjar)
+ $(use_with spell gtkspell)
+ $(use_with spell aspell)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name "*.la" -delete || die
+ python_optimize "${ED%/}"/usr/share/${PN}/extensions
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
diff --git a/net-libs/libssh/Manifest b/net-libs/libssh/Manifest
index ac53341e4884..2d38869b7419 100644
--- a/net-libs/libssh/Manifest
+++ b/net-libs/libssh/Manifest
@@ -1,4 +1,3 @@
DIST libssh-0.7.4.tar.xz 351892 BLAKE2B 5427faa04eac7b57f73909f113d933daf667f8311c30364bbf06d4f01121a58f5b560e0a1d9071655ce9b310fa3f3f801e11e880ca3eacde66efa0f49dc51b2b SHA512 94b8183e5c83e339303c1a160c92ccff6159471ac7d189ab66cf6d606d2e803fd616519f079aef1577c947d3a14e315332b05ea08e44d0ab550edbcb768dbea7
DIST libssh-0.7.5.tar.xz 351632 BLAKE2B b41cccb6215c5b7e66742171d91e1081d3c1bf44455b65a5992093d31b28db7a6375e815303e115e02b2458c734d9c61e4b1528ba905bf8a421ca2bbb7221ce6 SHA512 6c7f539899caaedf13d66fa2e0fac1a475ecdfe389131abcbdf908bdebc50a0b9e6b0d43e67e52aea85c32f6aa68e46ca2f50695992f82ded83489f445a8e775
-DIST libssh-0.8.1.tar.xz 409572 BLAKE2B 65bf38c5bba803a588ff4a1cc5f774cacc43c500bf0aaa77674f9120eccda26027e446aeb9e61a2418eb81077fdb0aa55d8e014f6d466877a9cd96b665c5e7ce SHA512 6630d0b101dc109116ba7a6cffb00db1bc9b5bc6004c843c5361d3d97c6cf4c323129ebf3bbf25ab2fc1961b74520490d7a16999504849c07b26a25679724b93
DIST libssh-0.8.2.tar.xz 408412 BLAKE2B bbd531ed511baa84d40c2e156cc63fca09345196e24e485930d8f42fed451529ea6ec2ce6f50276dfa56d5523062bbc45774891ad47ce7c748e8b95bc28b9f8c SHA512 ef9877d2a35f1871139c12452c917a3888172ea29f71d880e824de182695e5a8786bb39ca2f4874a160e156648d52065a8b2e7c040220badf65eee35dcfddeb9
diff --git a/net-libs/libssh/libssh-0.8.1.ebuild b/net-libs/libssh/libssh-0.8.1.ebuild
deleted file mode 100644
index 641c1853e986..000000000000
--- a/net-libs/libssh/libssh-0.8.1.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_P="${PN}-${PV/_rc/rc}"
-inherit cmake-multilib
-
-DESCRIPTION="Access a working SSH implementation by means of a library"
-HOMEPAGE="https://www.libssh.org/"
-
-if [[ "${PV}" == *9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://git.libssh.org/projects/libssh.git"
-else
- inherit eapi7-ver
- SRC_URI="https://www.libssh.org/files/$(ver_cut 1-2)/${MY_P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="LGPL-2.1"
-SLOT="0/4" # subslot = soname major version
-IUSE="debug doc examples gcrypt gssapi libressl mbedtls pcap server +sftp static-libs test zlib"
-# Maintainer: check IUSE-defaults at DefineOptions.cmake
-
-RDEPEND="
- !gcrypt? (
- !mbedtls? (
- !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
- )
- )
- gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
- gssapi? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
- mbedtls? ( net-libs/mbedtls[${MULTILIB_USEDEP}] )
- zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- test? ( >=dev-util/cmocka-0.3.1[${MULTILIB_USEDEP}] )
-"
-
-REQUIRED_USE="?? ( gcrypt mbedtls )"
-
-DOCS=( AUTHORS README ChangeLog )
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.8.0-tests.patch"
-)
-
-src_prepare() {
- cmake-utils_src_prepare
-
- # just install the examples do not compile them
- sed -i \
- -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' \
- CMakeLists.txt || die
-
- # keyfile torture test is currently broken
- sed -i \
- -e '/torture_keyfiles/d' \
- tests/unittests/CMakeLists.txt || die
-}
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DUNIT_TESTING="$(usex test)"
- -DWITH_DEBUG_CALLTRACE="$(usex debug)"
- -DWITH_DEBUG_CRYPTO="$(usex debug)"
- -DWITH_GCRYPT="$(usex gcrypt)"
- -DWITH_GSSAPI="$(usex gssapi)"
- -DWITH_MBEDTLS="$(usex mbedtls)"
- -DWITH_NACL=no
- -DWITH_PCAP="$(usex pcap)"
- -DWITH_SERVER="$(usex server)"
- -DWITH_SFTP="$(usex sftp)"
- -DWITH_STACK_PROTECTOR=OFF
- -DWITH_STATIC_LIB="$(usex static-libs)"
- -DWITH_STATIC_LIB="$(usex test)"
- -DWITH_ZLIB="$(usex zlib)"
- )
-
- cmake-utils_src_configure
-}
-
-multilib_src_compile() {
- cmake-utils_src_compile
- multilib_is_native_abi && use doc && cmake-utils_src_compile doc
-}
-
-multilib_src_install() {
- cmake-utils_src_install
-
- if multilib_is_native_abi && use doc ; then
- docinto html
- dodoc -r doc/html/.
- fi
-
- use static-libs || rm -f "${D}"/usr/$(get_libdir)/libssh.a
-
- # compatibility symlink until all consumers have been updated
- # to no longer use libssh_threads.so
- dosym libssh.so /usr/$(get_libdir)/libssh_threads.so
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- if use examples; then
- docinto examples
- dodoc examples/*.{c,h,cpp}
- fi
-}
diff --git a/net-libs/libssh/libssh-0.8.2.ebuild b/net-libs/libssh/libssh-0.8.2.ebuild
index 641c1853e986..d187c20721b6 100644
--- a/net-libs/libssh/libssh-0.8.2.ebuild
+++ b/net-libs/libssh/libssh-0.8.2.ebuild
@@ -23,6 +23,8 @@ SLOT="0/4" # subslot = soname major version
IUSE="debug doc examples gcrypt gssapi libressl mbedtls pcap server +sftp static-libs test zlib"
# Maintainer: check IUSE-defaults at DefineOptions.cmake
+REQUIRED_USE="?? ( gcrypt mbedtls ) test? ( static-libs )"
+
RDEPEND="
!gcrypt? (
!mbedtls? (
@@ -36,27 +38,21 @@ RDEPEND="
zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
+ doc? ( app-doc/doxygen[dot] )
test? ( >=dev-util/cmocka-0.3.1[${MULTILIB_USEDEP}] )
"
-REQUIRED_USE="?? ( gcrypt mbedtls )"
-
DOCS=( AUTHORS README ChangeLog )
S="${WORKDIR}/${MY_P}"
-PATCHES=(
- "${FILESDIR}/${PN}-0.8.0-tests.patch"
-)
+PATCHES=( "${FILESDIR}/${PN}-0.8.0-tests.patch" )
src_prepare() {
cmake-utils_src_prepare
- # just install the examples do not compile them
- sed -i \
- -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' \
- CMakeLists.txt || die
+ # just install the examples, do not compile them
+ cmake_comment_add_subdirectory examples
# keyfile torture test is currently broken
sed -i \
@@ -78,27 +74,22 @@ multilib_src_configure() {
-DWITH_SFTP="$(usex sftp)"
-DWITH_STACK_PROTECTOR=OFF
-DWITH_STATIC_LIB="$(usex static-libs)"
- -DWITH_STATIC_LIB="$(usex test)"
-DWITH_ZLIB="$(usex zlib)"
)
+ multilib_is_native_abi || mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON )
+
cmake-utils_src_configure
}
multilib_src_compile() {
cmake-utils_src_compile
- multilib_is_native_abi && use doc && cmake-utils_src_compile doc
+ multilib_is_native_abi && use doc && cmake-utils_src_compile docs
}
multilib_src_install() {
cmake-utils_src_install
-
- if multilib_is_native_abi && use doc ; then
- docinto html
- dodoc -r doc/html/.
- fi
-
- use static-libs || rm -f "${D}"/usr/$(get_libdir)/libssh.a
+ use doc && HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
# compatibility symlink until all consumers have been updated
# to no longer use libssh_threads.so
@@ -106,6 +97,7 @@ multilib_src_install() {
}
multilib_src_install_all() {
+ use mbedtls && DOCS+=( README.mbedtls )
einstalldocs
if use examples; then