summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-06-15 10:09:06 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-06-15 10:09:14 +0200
commit42223bf930628e5fddf2c31c1bd7883b527f3438 (patch)
treefc1cd722f9dc338db6d5e908118f6f724b748445
parentsys-apps/file: Bump to version 5.39 (diff)
downloadgentoo-42223bf930628e5fddf2c31c1bd7883b527f3438.tar.gz
gentoo-42223bf930628e5fddf2c31c1bd7883b527f3438.tar.bz2
gentoo-42223bf930628e5fddf2c31c1bd7883b527f3438.zip
sys-apps/file: Synced live ebuild
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-apps/file/file-9999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sys-apps/file/file-9999.ebuild b/sys-apps/file/file-9999.ebuild
index 0fd7e8ca10da..98499a3c73df 100644
--- a/sys-apps/file/file-9999.ebuild
+++ b/sys-apps/file/file-9999.ebuild
@@ -6,11 +6,11 @@ EAPI=7
PYTHON_COMPAT=( python3_{6..9} )
DISTUTILS_OPTIONAL=1
-inherit distutils-r1 libtool toolchain-funcs multilib-minimal
+inherit autotools distutils-r1 libtool toolchain-funcs multilib-minimal
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/glensc/file.git"
- inherit autotools git-r3
+ inherit git-r3
else
SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
@@ -36,10 +36,13 @@ RDEPEND="${DEPEND}
python? ( !dev-python/python-magic )
seccomp? ( sys-libs/libseccomp[${MULTILIB_USEDEP}] )"
+PATCHES=(
+ "${FILESDIR}/${PN}-5.39-seccomp_sandbox.patch" #713710
+)
+
src_prepare() {
default
-
- [[ ${PV} == "9999" ]] && eautoreconf
+ eautoreconf
elibtoolize
# don't let python README kill main README #60043