summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2021-06-19 17:49:58 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2021-06-19 17:49:58 +0000
commit459eebea474315414b87f8141aa04d725ec9517e (patch)
tree67f8e7e9376a3e10a4e7f05d7c25be75c621ba5e
parent2021-06-19 17:05:10 UTC (diff)
parentdev-python/blosc: Enable py3.10 (diff)
downloadgentoo-459eebea474315414b87f8141aa04d725ec9517e.tar.gz
gentoo-459eebea474315414b87f8141aa04d725ec9517e.tar.bz2
gentoo-459eebea474315414b87f8141aa04d725ec9517e.zip
Merge updates from master
-rw-r--r--dev-java/javatoolkit/Manifest1
-rw-r--r--dev-java/javatoolkit/javatoolkit-0.6.6.ebuild28
-rw-r--r--dev-python/blosc/blosc-1.10.4.ebuild2
-rw-r--r--dev-python/scikit-build/files/scikit-build-0.11.1-py310.patch28
-rw-r--r--dev-python/scikit-build/scikit-build-0.11.1.ebuild9
5 files changed, 64 insertions, 4 deletions
diff --git a/dev-java/javatoolkit/Manifest b/dev-java/javatoolkit/Manifest
index c6e0e966a030..6e70e30082bc 100644
--- a/dev-java/javatoolkit/Manifest
+++ b/dev-java/javatoolkit/Manifest
@@ -1 +1,2 @@
DIST javatoolkit-0.6.5.tar.bz2 24380 BLAKE2B 69442b45e32e63e9f4f8104570ae644d6dd5571b6b909fd751a7060abddfedf84cc147f342a40ade8c4e04764f1a8362d853fae91353171708d5daf68ef3f8e1 SHA512 8a9cf0f2b7951bfe9ab544b48eecf5857ae4bddf129a1a0b928a2b37df7960b082495c44f42954cffe885d48f850b070781593352f09221d1b35b9a94ba5b55b
+DIST javatoolkit-0.6.6.tar.bz2 24414 BLAKE2B adce23f533bfb14a621e79044def278fca799ecf0f4d78f236183977598fe012f3b9dc50ea10d5c8f6880efc2e0c4e15d426457fa4bf3e95ab83cfc877f807ea SHA512 9ac023e9dec1a7c219ce7fc7c6f702f857d1419910712a628708736d2e91ebe6fff0a8a99e3d477d1de859b4194b8a5350ea3608ed4640802e50f0606e7aec42
diff --git a/dev-java/javatoolkit/javatoolkit-0.6.6.ebuild b/dev-java/javatoolkit/javatoolkit-0.6.6.ebuild
new file mode 100644
index 000000000000..5296dbc8e73e
--- /dev/null
+++ b/dev-java/javatoolkit/javatoolkit-0.6.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="xml(+)"
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1 prefix
+
+DESCRIPTION="Collection of Gentoo-specific tools for Java"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Java"
+SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+python_prepare_all() {
+ hprefixify src/py/buildparser src/py/findclass setup.py
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install \
+ --install-scripts="${EPREFIX}"/usr/libexec/${PN}
+}
diff --git a/dev-python/blosc/blosc-1.10.4.ebuild b/dev-python/blosc/blosc-1.10.4.ebuild
index 43923c61a128..f2deced4776c 100644
--- a/dev-python/blosc/blosc-1.10.4.ebuild
+++ b/dev-python/blosc/blosc-1.10.4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
diff --git a/dev-python/scikit-build/files/scikit-build-0.11.1-py310.patch b/dev-python/scikit-build/files/scikit-build-0.11.1-py310.patch
new file mode 100644
index 000000000000..fa00556f9add
--- /dev/null
+++ b/dev-python/scikit-build/files/scikit-build-0.11.1-py310.patch
@@ -0,0 +1,28 @@
+From c1677527af3f7afd48ebbe1b2338ac822f64c524 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 19 Jun 2021 19:27:09 +0200
+Subject: [PATCH] fix: fix regex in test_get_python_version for Python 3.10
+
+Fix the regular expression in test_get_python_version to permit
+the minor version to contain more than one digit. This fixes the test
+on Python 3.10.
+---
+ tests/test_cmaker.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test_cmaker.py b/tests/test_cmaker.py
+index d63059c..52d0028 100644
+--- a/tests/test_cmaker.py
++++ b/tests/test_cmaker.py
+@@ -21,7 +21,7 @@ from . import _tmpdir, get_cmakecache_variables
+
+
+ def test_get_python_version():
+- assert re.match(r'^[23](\.?)[0-9]$', CMaker.get_python_version())
++ assert re.match(r'^[23](\.?)\d+$', CMaker.get_python_version())
+
+
+ def test_get_python_include_dir():
+--
+2.32.0
+
diff --git a/dev-python/scikit-build/scikit-build-0.11.1.ebuild b/dev-python/scikit-build/scikit-build-0.11.1.ebuild
index b65c6bdf6891..bbebf508eb95 100644
--- a/dev-python/scikit-build/scikit-build-0.11.1.ebuild
+++ b/dev-python/scikit-build/scikit-build-0.11.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -32,7 +32,10 @@ DEPEND="
dev-python/virtualenv[${PYTHON_USEDEP}]
)"
-PATCHES=( "${FILESDIR}/${PN}-0.10.0-docs.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-0.10.0-docs.patch"
+ "${FILESDIR}"/${P}-py310.patch
+)
distutils_enable_sphinx docs \
dev-python/sphinx_rtd_theme \