summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-21 09:51:20 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-21 09:57:26 +0200
commit47df00b85acdfbf08ac9018fc9f2805001973fb4 (patch)
tree8b9dfe8fc9a46871e31ccf9d1dd195e5769e602e
parentdev-python/cftime: Bump to 1.5.0 (diff)
downloadgentoo-47df00b85acdfbf08ac9018fc9f2805001973fb4.tar.gz
gentoo-47df00b85acdfbf08ac9018fc9f2805001973fb4.tar.bz2
gentoo-47df00b85acdfbf08ac9018fc9f2805001973fb4.zip
dev-python/dogpile-cache: Bump to 1.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dogpile-cache/Manifest1
-rw-r--r--dev-python/dogpile-cache/dogpile-cache-1.1.3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/dogpile-cache/Manifest b/dev-python/dogpile-cache/Manifest
index 1b8046f9a6a4..b7a1b2077ff9 100644
--- a/dev-python/dogpile-cache/Manifest
+++ b/dev-python/dogpile-cache/Manifest
@@ -1 +1,2 @@
DIST dogpile.cache-1.1.2.tar.gz 370404 BLAKE2B 6895ffe057ef614ef6bcc4ba58a4bb2fe69b8e57943cff38dfc472bd3dec5ad4e34fc65d9fa0830a2396f6a789aedd6cd1e1e06dff911a3197ca4b64fdca1c36 SHA512 e68c2b358e6822d2db90422b92f1e9c9b997c89087ca69c8fc9511be1e06cdfeb14eef759085fdbca4dfc668dabf3901cddeb6a6c2f327d28c8968975908c160
+DIST dogpile.cache-1.1.3.tar.gz 387490 BLAKE2B 580be4f524196fb56e651d793045bf2e3419d3c98e65be0ba2cfaaed97f9c9cc08efe67191f77b273e97ffe907e8f5e050a7a36d2d8287522a21e7c4290d1354 SHA512 fd735b0bb9b7eb3bb559c030c15ac547aeb3f4718c64d7edb0f26f0f8a71b9b067434e984460c40cfbca57696d2b9579266f0c9d48bad4cb3c5bbc07030a4fb4
diff --git a/dev-python/dogpile-cache/dogpile-cache-1.1.3.ebuild b/dev-python/dogpile-cache/dogpile-cache-1.1.3.ebuild
new file mode 100644
index 000000000000..4174912da531
--- /dev/null
+++ b/dev-python/dogpile-cache/dogpile-cache-1.1.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A locking API for expiring values while a single thread generates a new value."
+HOMEPAGE="https://github.com/sqlalchemy/dogpile.cache"
+SRC_URI="mirror://pypi/${PN:0:1}/dogpile.cache/dogpile.cache-${PV}.tar.gz"
+S="${WORKDIR}/dogpile.cache-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/decorator-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest