summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-03-25 20:09:10 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-03-25 20:09:10 +0000
commit48425e9a32211f4c5ac66d5865c640445bea1247 (patch)
tree168780e7ba239e98eb82c5f869d1efbdd0a82f4f
parent2022-03-25 19:49:47 UTC (diff)
parentsci-astronomy/kstars: 3.5.8 version bump (diff)
downloadgentoo-48425e9a32211f4c5ac66d5865c640445bea1247.tar.gz
gentoo-48425e9a32211f4c5ac66d5865c640445bea1247.tar.bz2
gentoo-48425e9a32211f4c5ac66d5865c640445bea1247.zip
Merge updates from master
-rw-r--r--app-misc/solaar/solaar-1.1.2_rc2-r1.ebuild (renamed from app-misc/solaar/solaar-1.1.2_rc2.ebuild)3
-rw-r--r--eclass/bash-completion-r1.eclass4
-rw-r--r--eclass/multilib.eclass7
-rw-r--r--eclass/portability.eclass5
-rw-r--r--eclass/ruby-ng.eclass9
-rw-r--r--eclass/subversion.eclass86
-rw-r--r--eclass/tmpfiles.eclass6
-rw-r--r--sci-astronomy/kstars/Manifest1
-rw-r--r--sci-astronomy/kstars/kstars-3.5.8.ebuild97
-rw-r--r--sci-libs/indilib/Manifest1
-rw-r--r--sci-libs/indilib/indilib-1.9.5.1.ebuild69
-rw-r--r--sci-libs/stellarsolver/Manifest1
-rw-r--r--sci-libs/stellarsolver/files/stellarsolver-2.2-fix-implicit-vasprintf-decl.patch88
-rw-r--r--sci-libs/stellarsolver/stellarsolver-2.2.ebuild30
-rw-r--r--www-client/google-chrome/Manifest2
-rw-r--r--www-client/google-chrome/google-chrome-99.0.4844.84.ebuild (renamed from www-client/google-chrome/google-chrome-99.0.4844.82.ebuild)0
-rw-r--r--www-plugins/chrome-binary-plugins/Manifest2
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-99.0.4844.84.ebuild (renamed from www-plugins/chrome-binary-plugins/chrome-binary-plugins-99.0.4844.82.ebuild)0
18 files changed, 348 insertions, 63 deletions
diff --git a/app-misc/solaar/solaar-1.1.2_rc2.ebuild b/app-misc/solaar/solaar-1.1.2_rc2-r1.ebuild
index ed9a688180e5..c33af3ddaf5e 100644
--- a/app-misc/solaar/solaar-1.1.2_rc2.ebuild
+++ b/app-misc/solaar/solaar-1.1.2_rc2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -28,6 +28,7 @@ RDEPEND="
$(python_gen_cond_dep '
dev-python/psutil[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
dev-python/python-xlib[${PYTHON_USEDEP}]
>=dev-python/pyudev-0.13[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
diff --git a/eclass/bash-completion-r1.eclass b/eclass/bash-completion-r1.eclass
index f0451b773a93..df1a2a54d39a 100644
--- a/eclass/bash-completion-r1.eclass
+++ b/eclass/bash-completion-r1.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: bash-completion-r1.eclass
@@ -64,7 +64,7 @@ _bash-completion-r1_get_bashcompdir() {
_bash-completion-r1_get_bashdir completionsdir /usr/share/bash-completion/completions
}
-# @FUNCTION: _bash-completion-r1_get_helpersdir
+# @FUNCTION: _bash-completion-r1_get_bashhelpersdir
# @INTERNAL
# @DESCRIPTION:
# Get unprefixed bash-completion helpers directory.
diff --git a/eclass/multilib.eclass b/eclass/multilib.eclass
index fadd371f3ca7..ec2676cb6cfb 100644
--- a/eclass/multilib.eclass
+++ b/eclass/multilib.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: multilib.eclass
@@ -299,8 +299,13 @@ get_modname() {
echo ".${modname}"
}
+# @FUNCTION: multilib_env
+# @USAGE:
+# @DESCRIPTION:
# This is for the toolchain to setup profile variables when pulling in
# a crosscompiler (and thus they aren't set in the profile).
+#
+# This must only be used by toolchain packages.
multilib_env() {
local CTARGET=${1:-${CTARGET}}
local cpu=${CTARGET%%*-}
diff --git a/eclass/portability.eclass b/eclass/portability.eclass
index 1cc36757b625..8df8fcebc47b 100644
--- a/eclass/portability.eclass
+++ b/eclass/portability.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: portability.eclass
@@ -153,7 +153,4 @@ get_mounts() {
done
}
-_dead_portability_user_funcs() { die "if you really need this, please file a bug for base-system@gentoo.org"; }
-is-login-disabled() { _dead_portability_user_funcs; }
-
fi
diff --git a/eclass/ruby-ng.eclass b/eclass/ruby-ng.eclass
index 1bc934573140..72e714129715 100644
--- a/eclass/ruby-ng.eclass
+++ b/eclass/ruby-ng.eclass
@@ -66,20 +66,19 @@
# (e.g. selenium's firefox driver extension). When set this argument is
# passed to "grep -E" to remove reporting of these shared objects.
-local inherits=""
case ${EAPI} in
5)
- inherits="eutils toolchain-funcs"
+ inherit eutils toolchain-funcs
;;
6)
- inherits="estack toolchain-funcs"
+ inherit estack toolchain-funcs
;;
*)
- inherits="estack"
+ inherit estack
;;
esac
-inherit ${inherits} multilib ruby-utils
+inherit multilib ruby-utils
EXPORT_FUNCTIONS src_unpack src_prepare src_configure src_compile src_test src_install pkg_setup
diff --git a/eclass/subversion.eclass b/eclass/subversion.eclass
index 5530758d1baa..349878618427 100644
--- a/eclass/subversion.eclass
+++ b/eclass/subversion.eclass
@@ -12,11 +12,9 @@
# The subversion eclass provides functions to fetch software sources
# from subversion repositories.
-ESVN="${ECLASS}"
-
case ${EAPI} in
6|7|8) inherit estack ;;
- *) die "${ESVN}: EAPI ${EAPI:-0} is not supported" ;;
+ *) die "${ECLASS}: EAPI ${EAPI:-0} is not supported" ;;
esac
PROPERTIES+=" live"
@@ -176,7 +174,7 @@ subversion_fetch() {
local S_dest="${2}"
if [[ -z ${repo_uri} ]]; then
- die "${ESVN}: ESVN_REPO_URI (or specified URI) is empty."
+ die "${ECLASS}: ESVN_REPO_URI (or specified URI) is empty."
fi
[[ -n "${ESVN_REVISION}" ]] && revision="${ESVN_REVISION}"
@@ -191,7 +189,7 @@ subversion_fetch() {
file)
;;
*)
- die "${ESVN}: fetch from '${scheme}' is not yet implemented."
+ die "${ECLASS}: fetch from '${scheme}' is not yet implemented."
;;
esac
@@ -204,10 +202,10 @@ subversion_fetch() {
if [[ ! -d ${ESVN_STORE_DIR} ]]; then
debug-print "${FUNCNAME}: initial checkout. creating subversion directory"
- mkdir -m 775 -p "${ESVN_STORE_DIR}" || die "${ESVN}: can't mkdir ${ESVN_STORE_DIR}."
+ mkdir -m 775 -p "${ESVN_STORE_DIR}" || die "${ECLASS}: can't mkdir ${ESVN_STORE_DIR}."
fi
- pushd "${ESVN_STORE_DIR}" >/dev/null || die "${ESVN}: can't chdir to ${ESVN_STORE_DIR}"
+ pushd "${ESVN_STORE_DIR}" >/dev/null || die "${ECLASS}: can't chdir to ${ESVN_STORE_DIR}"
local wc_path="$(subversion__get_wc_path "${repo_uri}")"
local options="${ESVN_OPTIONS} --config-dir ${ESVN_STORE_DIR}/.subversion"
@@ -237,32 +235,32 @@ subversion_fetch() {
debug-print "${FUNCNAME}: ${ESVN_FETCH_CMD} ${options} ${repo_uri}"
- mkdir -m 775 -p "${ESVN_PROJECT}" || die "${ESVN}: can't mkdir ${ESVN_PROJECT}."
- cd "${ESVN_PROJECT}" || die "${ESVN}: can't chdir to ${ESVN_PROJECT}"
+ mkdir -m 775 -p "${ESVN_PROJECT}" || die "${ECLASS}: can't mkdir ${ESVN_PROJECT}."
+ cd "${ESVN_PROJECT}" || die "${ECLASS}: can't chdir to ${ESVN_PROJECT}"
if [[ -n "${ESVN_USER}" ]]; then
- ${ESVN_FETCH_CMD} ${options} --username "${ESVN_USER}" --password "${ESVN_PASSWORD}" "${repo_uri}" || die "${ESVN}: can't fetch to ${wc_path} from ${repo_uri}."
+ ${ESVN_FETCH_CMD} ${options} --username "${ESVN_USER}" --password "${ESVN_PASSWORD}" "${repo_uri}" || die "${ECLASS}: can't fetch to ${wc_path} from ${repo_uri}."
else
- ${ESVN_FETCH_CMD} ${options} "${repo_uri}" || die "${ESVN}: can't fetch to ${wc_path} from ${repo_uri}."
+ ${ESVN_FETCH_CMD} ${options} "${repo_uri}" || die "${ECLASS}: can't fetch to ${wc_path} from ${repo_uri}."
fi
elif [[ -n ${ESVN_OFFLINE} ]]; then
svn upgrade "${wc_path}" &>/dev/null
svn cleanup "${wc_path}" &>/dev/null
- subversion_wc_info "${repo_uri}" || die "${ESVN}: unknown problem occurred while accessing working copy."
+ subversion_wc_info "${repo_uri}" || die "${ECLASS}: unknown problem occurred while accessing working copy."
if [[ -n ${ESVN_REVISION} && ${ESVN_REVISION} != ${ESVN_WC_REVISION} ]]; then
- die "${ESVN}: You requested off-line updating and revision ${ESVN_REVISION} but only revision ${ESVN_WC_REVISION} is available locally."
+ die "${ECLASS}: You requested off-line updating and revision ${ESVN_REVISION} but only revision ${ESVN_WC_REVISION} is available locally."
fi
einfo "Fetching disabled: Using existing repository copy at revision ${ESVN_WC_REVISION}."
else
svn upgrade "${wc_path}" &>/dev/null
svn cleanup "${wc_path}" &>/dev/null
- subversion_wc_info "${repo_uri}" || die "${ESVN}: unknown problem occurred while accessing working copy."
+ subversion_wc_info "${repo_uri}" || die "${ECLASS}: unknown problem occurred while accessing working copy."
local esvn_up_freq=
if [[ -n ${ESVN_UP_FREQ} ]]; then
if [[ -n ${ESVN_UP_FREQ//[[:digit:]]} ]]; then
- die "${ESVN}: ESVN_UP_FREQ must be an integer value corresponding to the minimum number of hours between svn up."
+ die "${ECLASS}: ESVN_UP_FREQ must be an integer value corresponding to the minimum number of hours between svn up."
elif [[ -z $(find "${wc_path}/.svn/entries" -mmin "+$((ESVN_UP_FREQ*60))") ]]; then
einfo "Fetching disabled since ${ESVN_UP_FREQ} hours has not passed since last update."
einfo "Using existing repository copy at revision ${ESVN_WC_REVISION}."
@@ -282,12 +280,12 @@ subversion_fetch() {
debug-print "${FUNCNAME}: ${ESVN_FETCH_CMD} ${options} ${repo_uri}"
- mkdir -m 775 -p "${ESVN_PROJECT}" || die "${ESVN}: can't mkdir ${ESVN_PROJECT}."
- cd "${ESVN_PROJECT}" || die "${ESVN}: can't chdir to ${ESVN_PROJECT}"
+ mkdir -m 775 -p "${ESVN_PROJECT}" || die "${ECLASS}: can't mkdir ${ESVN_PROJECT}."
+ cd "${ESVN_PROJECT}" || die "${ECLASS}: can't chdir to ${ESVN_PROJECT}"
if [[ -n "${ESVN_USER}" ]]; then
- ${ESVN_FETCH_CMD} ${options} --username "${ESVN_USER}" --password "${ESVN_PASSWORD}" "${repo_uri}" || die "${ESVN}: can't fetch to ${wc_path} from ${repo_uri}."
+ ${ESVN_FETCH_CMD} ${options} --username "${ESVN_USER}" --password "${ESVN_PASSWORD}" "${repo_uri}" || die "${ECLASS}: can't fetch to ${wc_path} from ${repo_uri}."
else
- ${ESVN_FETCH_CMD} ${options} "${repo_uri}" || die "${ESVN}: can't fetch to ${wc_path} from ${repo_uri}."
+ ${ESVN_FETCH_CMD} ${options} "${repo_uri}" || die "${ECLASS}: can't fetch to ${wc_path} from ${repo_uri}."
fi
elif [[ ${ESVN_WC_URL} != $(subversion__get_repository_uri "${repo_uri}") ]]; then
einfo "subversion switch start -->"
@@ -296,11 +294,11 @@ subversion_fetch() {
debug-print "${FUNCNAME}: ${ESVN_SWITCH_CMD} ${options} ${repo_uri}"
- cd "${wc_path}" || die "${ESVN}: can't chdir to ${wc_path}"
+ cd "${wc_path}" || die "${ECLASS}: can't chdir to ${wc_path}"
if [[ -n "${ESVN_USER}" ]]; then
- ${ESVN_SWITCH_CMD} ${options} --username "${ESVN_USER}" --password "${ESVN_PASSWORD}" ${repo_uri} || die "${ESVN}: can't update ${wc_path} from ${repo_uri}."
+ ${ESVN_SWITCH_CMD} ${options} --username "${ESVN_USER}" --password "${ESVN_PASSWORD}" ${repo_uri} || die "${ECLASS}: can't update ${wc_path} from ${repo_uri}."
else
- ${ESVN_SWITCH_CMD} ${options} ${repo_uri} || die "${ESVN}: can't update ${wc_path} from ${repo_uri}."
+ ${ESVN_SWITCH_CMD} ${options} ${repo_uri} || die "${ECLASS}: can't update ${wc_path} from ${repo_uri}."
fi
else
# update working copy
@@ -309,16 +307,16 @@ subversion_fetch() {
debug-print "${FUNCNAME}: ${ESVN_UPDATE_CMD} ${options}"
- cd "${wc_path}" || die "${ESVN}: can't chdir to ${wc_path}"
+ cd "${wc_path}" || die "${ECLASS}: can't chdir to ${wc_path}"
if [[ -n "${ESVN_USER}" ]]; then
- ${ESVN_UPDATE_CMD} ${options} --username "${ESVN_USER}" --password "${ESVN_PASSWORD}" || die "${ESVN}: can't update ${wc_path} from ${repo_uri}."
+ ${ESVN_UPDATE_CMD} ${options} --username "${ESVN_USER}" --password "${ESVN_PASSWORD}" || die "${ECLASS}: can't update ${wc_path} from ${repo_uri}."
else
- ${ESVN_UPDATE_CMD} ${options} || die "${ESVN}: can't update ${wc_path} from ${repo_uri}."
+ ${ESVN_UPDATE_CMD} ${options} || die "${ECLASS}: can't update ${wc_path} from ${repo_uri}."
fi
fi
# export updated information for the working copy
- subversion_wc_info "${repo_uri}" || die "${ESVN}: unknown problem occurred while accessing working copy."
+ subversion_wc_info "${repo_uri}" || die "${ECLASS}: unknown problem occurred while accessing working copy."
fi
fi
@@ -329,15 +327,15 @@ subversion_fetch() {
einfo " working copy: ${wc_path}"
if ! has "export" ${ESVN_RESTRICT}; then
- cd "${wc_path}" || die "${ESVN}: can't chdir to ${wc_path}"
+ cd "${wc_path}" || die "${ECLASS}: can't chdir to ${wc_path}"
local S="${S}/${S_dest}"
mkdir -p "${S}"
# export to the ${WORKDIR}
#* "svn export" has a bug. see https://bugs.gentoo.org/119236
- #* svn export . "${S}" || die "${ESVN}: can't export to ${S}."
- rsync -rlpgo --exclude=".svn/" . "${S}" || die "${ESVN}: can't export to ${S}."
+ #* svn export . "${S}" || die "${ECLASS}: can't export to ${S}."
+ rsync -rlpgo --exclude=".svn/" . "${S}" || die "${ECLASS}: can't export to ${S}."
fi
popd >/dev/null
@@ -374,7 +372,7 @@ subversion_wc_info() {
# @DESCRIPTION:
# Default src_unpack. Fetch.
subversion_src_unpack() {
- subversion_fetch || die "${ESVN}: unknown problem occurred in subversion_fetch."
+ subversion_fetch || die "${ECLASS}: unknown problem occurred in subversion_fetch."
}
# @FUNCTION: subversion_pkg_preinst
@@ -401,11 +399,9 @@ subversion_pkg_preinst() {
## -- Private Functions
-## -- subversion__svn_info() ------------------------------------------------- #
-#
-# param $1 - a target.
-# param $2 - a key name.
-#
+# @FUNCTION: subversion__svn_info
+# @USAGE: <target> <key name>
+# @INTERNAL
subversion__svn_info() {
local target="${1}"
local key="${2}"
@@ -415,15 +411,15 @@ subversion__svn_info() {
| cut -d" " -f2-
}
-## -- subversion__get_repository_uri() --------------------------------------- #
-#
-# param $1 - a repository URI.
+# @FUNCTION: subversion__get_repository_uri
+# @USAGE: <repository URI>
+# @INTERNAL
subversion__get_repository_uri() {
local repo_uri="${1}"
debug-print "${FUNCNAME}: repo_uri = ${repo_uri}"
if [[ -z ${repo_uri} ]]; then
- die "${ESVN}: ESVN_REPO_URI (or specified URI) is empty."
+ die "${ECLASS}: ESVN_REPO_URI (or specified URI) is empty."
fi
# delete trailing slash
if [[ -z ${repo_uri##*/} ]]; then
@@ -434,9 +430,9 @@ subversion__get_repository_uri() {
echo "${repo_uri}"
}
-## -- subversion__get_wc_path() ---------------------------------------------- #
-#
-# param $1 - a repository URI.
+# @FUNCTION: subversion__get_wc_path
+# @USAGE: <repository URI>
+# @INTERNAL
subversion__get_wc_path() {
local repo_uri="$(subversion__get_repository_uri "${1}")"
@@ -445,9 +441,9 @@ subversion__get_wc_path() {
echo "${ESVN_STORE_DIR}/${ESVN_PROJECT}/${repo_uri##*/}"
}
-## -- subversion__get_peg_revision() ----------------------------------------- #
-#
-# param $1 - a repository URI.
+# @FUNCTION: subversion__get_peg_revision
+# @USAGE: <repository URI>
+# @INTERNAL
subversion__get_peg_revision() {
local repo_uri="${1}"
local peg_rev=
diff --git a/eclass/tmpfiles.eclass b/eclass/tmpfiles.eclass
index 165d95d4e6fb..39650401a6a0 100644
--- a/eclass/tmpfiles.eclass
+++ b/eclass/tmpfiles.eclass
@@ -1,4 +1,4 @@
-# Copyright 2016-2021 Gentoo Authors
+# Copyright 2016-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: tmpfiles.eclass
@@ -52,8 +52,8 @@
#
# @CODE
-if [[ -z ${TMPFILES_ECLASS} ]]; then
-TMPFILES_ECLASS=1
+if [[ -z ${_TMPFILES_ECLASS} ]]; then
+_TMPFILES_ECLASS=1
case "${EAPI}" in
5|6|7|8) ;;
diff --git a/sci-astronomy/kstars/Manifest b/sci-astronomy/kstars/Manifest
index a182f80497b5..70846eba0ded 100644
--- a/sci-astronomy/kstars/Manifest
+++ b/sci-astronomy/kstars/Manifest
@@ -1,2 +1,3 @@
DIST kstars-3.5.5.tar.xz 79302220 BLAKE2B df8503c72c689301e70345169491dbc8e27116b44c75a78088f91da0d103965f4da359d4de22c3a177898cfe734f66b06810440c2d4dd7ec15862f0ad4d4edf0 SHA512 03ed4db0e3998c9501f77fb22e26046177d4bc427e769be1964ba3d54701a1240908117bc65424768917252710b73811e38ec61e2391182794b30ad6c9d68d96
DIST kstars-3.5.7.tar.xz 86749048 BLAKE2B 12c1502c2b4c2edf3e77bc28338d44ef0d61133b0db4aa800cca1c06a9ab2b9acb2c628ac0681a5ac253b5d105d0368eede5f91739b3be2c6f7a996d9322e320 SHA512 48ac509c8f2241155235a386ccfe321398a39886f1332b2b2829d6db3ebc2bf1161f8900a5f0fcf9b51925a655c547e10eef58526257ee5dafc8d77db9a11845
+DIST kstars-3.5.8.tar.xz 86831012 BLAKE2B a44e057427f0c91c932c3914a35c158b6a879ced0e2c9a1f496c73676a62da0f5b663b6ef8640b6afaac0451bfaa127dba96a8c291da3b631069810f552a6c4c SHA512 d238a157fd9b4e92ce7d2b156e837c02d65e416a4e2df2791c24c98735e7f6a20eb2982eaa898f971d5b70b53852a760d0e01a2f6abb47d1f66d1f5a282c5120
diff --git a/sci-astronomy/kstars/kstars-3.5.8.ebuild b/sci-astronomy/kstars/kstars-3.5.8.ebuild
new file mode 100644
index 000000000000..f49418d9b462
--- /dev/null
+++ b/sci-astronomy/kstars/kstars-3.5.8.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=5.82.0
+QTMIN=5.15.2
+inherit ecm kde.org optfeature
+
+DESCRIPTION="Desktop Planetarium"
+HOMEPAGE="https://apps.kde.org/kstars/ https://edu.kde.org/kstars/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+ GPL-3+"
+SLOT="5"
+IUSE="fits indi +password raw wcs"
+
+REQUIRED_USE="indi? ( fits ) ${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ >=dev-qt/qtdatavis3d-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwebsockets-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/knotifyconfig-${KFMIN}:5
+ >=kde-frameworks/kplotting-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ sys-libs/zlib
+ fits? ( sci-libs/cfitsio:= )
+ indi? (
+ sci-libs/gsl:=
+ >=sci-libs/indilib-1.9.1
+ sci-libs/libnova:=
+ >=sci-libs/stellarsolver-2.2
+ )
+ password? ( dev-libs/qtkeychain:= )
+ raw? ( media-libs/libraw:= )
+ wcs? ( sci-astronomy/wcslib:= )
+"
+# TODO: Add back when re-enabled by upstream
+# opengl? (
+# >=dev-qt/qtopengl-${QTMIN}:5
+# virtual/opengl
+# )
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/eigen:3
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-qt/qtgraphicaleffects-${QTMIN}:5
+ >=dev-qt/qtpositioning-${QTMIN}:5
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DFETCH_TRANSLATIONS=OFF
+ -DBUILD_PYKSTARS=OFF
+ -DBUILD_DOC=$(usex handbook)
+ $(cmake_use_find_package fits CFitsio)
+ $(cmake_use_find_package indi INDI)
+ $(cmake_use_find_package indi Nova)
+ $(cmake_use_find_package password Qt5Keychain)
+ $(cmake_use_find_package raw LibRaw)
+ $(cmake_use_find_package wcs WCSLIB)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Display 'current' pictures of planets" x11-misc/xplanet
+ fi
+ ecm_pkg_postinst
+}
diff --git a/sci-libs/indilib/Manifest b/sci-libs/indilib/Manifest
index a59d791817e3..4eb5e3d5c30d 100644
--- a/sci-libs/indilib/Manifest
+++ b/sci-libs/indilib/Manifest
@@ -1,2 +1,3 @@
DIST indilib-1.9.2.tar.gz 2335834 BLAKE2B 47d8bde8e3c783cefb23c8a8f865fa46bb9a6ed4ee08618d198680f3036e9ca9a16178b1ec4dab070d0cb3ec8d638847cedb752a2a5a1d5e2dc5ddbd362c0a86 SHA512 0a1ada5b5880553ddbcf794bac952ddce76d3aa46652c48621e284a04a7d3d9ba7492d8874bf30f7e3f614a904a829109eaee9dae53dd5854d72bb1c98740f44
DIST indilib-1.9.4.tar.gz 2370816 BLAKE2B 4df98abfaecdfe226d889e063928d3d5a09f9141b7bbeb2798da8190f874d0137313ff05b9c524a645440298d79655f9627ac611ae3132ee30f902e46d2db34d SHA512 2331d49545cfeb5904529f74b52ba0454c81066cb644e158e159a8f3597269d6d48bb1a608162771108c30f2fdb7e21fc5c1078b152f0e2a640f2e10ad3f9142
+DIST indilib-1.9.5.1.tar.gz 2420537 BLAKE2B 1be0f19a92cfb9d36ba88fc51adf55f5c39743efc4da352d1f11f4eb9e8a82c0624d29de1032a0b2a0a96babb13b33e225ef453ef92d091c695cc0a62642900c SHA512 80e764eff9ce40754bd1ba3dc8a49714aeccb3fc2d2e623f50dff25d7bcef9f9744b48fa052c60a94105677479a1629cc80f452002e1e00fc9f6549c1809df65
diff --git a/sci-libs/indilib/indilib-1.9.5.1.ebuild b/sci-libs/indilib/indilib-1.9.5.1.ebuild
new file mode 100644
index 000000000000..b6d000763a3b
--- /dev/null
+++ b/sci-libs/indilib/indilib-1.9.5.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake udev
+
+DESCRIPTION="INDI Astronomical Control Protocol library"
+HOMEPAGE="https://www.indilib.org/"
+SRC_URI="https://github.com/${PN}/${PN/lib/}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P/lib/}"
+
+LICENSE="BSD GPL-2+ LGPL-2+ LGPL-2.1+"
+SLOT="0/1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="ogg rtlsdr test websocket"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ net-misc/curl
+ sci-libs/cfitsio:=
+ sci-libs/fftw:3.0=
+ sci-libs/gsl:=
+ sci-libs/libnova:=
+ sys-libs/zlib
+ virtual/jpeg:0
+ virtual/libusb:0
+ ogg? (
+ media-libs/libogg
+ media-libs/libtheora
+ )
+ rtlsdr? ( net-wireless/rtl-sdr )
+ websocket? ( dev-libs/boost:= )
+"
+DEPEND="${RDEPEND}
+ kernel_linux? ( sys-kernel/linux-headers )
+ test? ( >=dev-cpp/gtest-1.8.0 )
+ websocket? ( dev-cpp/websocketpp )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DINDI_BUILD_QT5_CLIENT=OFF
+ -DUDEVRULES_INSTALL_DIR="${EPREFIX}$(get_udevdir)"/rules.d
+ $(cmake_use_find_package ogg OggTheora)
+ $(cmake_use_find_package rtlsdr RTLSDR)
+ -DINDI_BUILD_UNITTESTS=$(usex test)
+ -DINDI_BUILD_WEBSOCKET=$(usex websocket)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=()
+
+ if use ppc || use ppc64 || use sparc ; then
+ # Broken on big endian for quite some time.
+ # Reported upstream: file needs to be replaced w/ a normal library
+ # for b64.
+ # bug #763126
+ myctestargs+=(
+ -E "(test_base64)"
+ )
+ fi
+
+ BUILD_DIR="${BUILD_DIR}"/test cmake_src_test
+}
diff --git a/sci-libs/stellarsolver/Manifest b/sci-libs/stellarsolver/Manifest
index 4b2ab6e6f597..7e29c11d356d 100644
--- a/sci-libs/stellarsolver/Manifest
+++ b/sci-libs/stellarsolver/Manifest
@@ -1 +1,2 @@
DIST stellarsolver-1.9.tar.gz 9117560 BLAKE2B dd458399bd53a6e9de50293ebe15538275fb494d8ef63699eb1234aaee5234fdbb81fe23a28cc1d264490ea8849569293342125461d9e638111c9acb9756fbdf SHA512 a618e551ec28bd8439a495ca6f2a69b857852f0129c8e7d692315bd124b7c7a5130763775264b3f6a7394b3d0480d4f95c1605fb02e311ab6c38b4c60bc6b9e3
+DIST stellarsolver-2.2.tar.gz 10971732 BLAKE2B 019b822d9a84401dfe2d01053da14c3f0eafb8a8b67e60c4f664ad64c0ffefe72f9dc086edef6dac5950f7fd99e655a641ecf781609b8b54e50cf3c0f8a516b5 SHA512 0b200437130ea8131ade9219e1055ea4265925168cbfb5a7bdcf3836e267a1b670df43f20d4657ef64dea2c1ef2314cfc0bcb8503eb4ead3f0cc3fae3267f7bc
diff --git a/sci-libs/stellarsolver/files/stellarsolver-2.2-fix-implicit-vasprintf-decl.patch b/sci-libs/stellarsolver/files/stellarsolver-2.2-fix-implicit-vasprintf-decl.patch
new file mode 100644
index 000000000000..b2625fe4429e
--- /dev/null
+++ b/sci-libs/stellarsolver/files/stellarsolver-2.2-fix-implicit-vasprintf-decl.patch
@@ -0,0 +1,88 @@
+From acb58bd78388adec25eb6e09ce6434546de008b8 Mon Sep 17 00:00:00 2001
+From: Robert Lancaster <rlancaste@gmail.com>
+Date: Wed, 16 Mar 2022 18:15:21 -0400
+Subject: [PATCH] Trying to eliminate vasprintf implicit declaration warning on
+ Linux
+
+---
+ stellarsolver/astrometry/util/bl.c | 4 +++-
+ stellarsolver/astrometry/util/errors.c | 4 +++-
+ stellarsolver/astrometry/util/fitsioutils.c | 3 +++
+ stellarsolver/astrometry/util/ioutils.c | 4 +++-
+ stellarsolver/astrometry/util/log.c | 4 +++-
+ 5 files changed, 15 insertions(+), 4 deletions(-)
+
+diff --git a/stellarsolver/astrometry/util/bl.c b/stellarsolver/astrometry/util/bl.c
+index 1a0fee9..e84d74a 100644
+--- a/stellarsolver/astrometry/util/bl.c
++++ b/stellarsolver/astrometry/util/bl.c
+@@ -2,7 +2,9 @@
+ # This file is part of the Astrometry.net suite.
+ # Licensed under a 3-clause BSD style license - see LICENSE
+ */
+-
++#ifdef __GNUC__ //# Modified by Robert Lancaster for the StellarSolver Internal Library
++#define __STDC_WANT_LIB_EXT2__ 1
++#endif
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdlib.h>
+diff --git a/stellarsolver/astrometry/util/errors.c b/stellarsolver/astrometry/util/errors.c
+index 94f5f9c..b7c4e9f 100644
+--- a/stellarsolver/astrometry/util/errors.c
++++ b/stellarsolver/astrometry/util/errors.c
+@@ -2,7 +2,9 @@
+ # This file is part of the Astrometry.net suite.
+ # Licensed under a 3-clause BSD style license - see LICENSE
+ */
+-
++#ifdef __GNUC__ //# Modified by Robert Lancaster for the StellarSolver Internal Library
++#define __STDC_WANT_LIB_EXT2__ 1
++#endif
+ #include <stdlib.h>
+ #include <string.h>
+ #include <errno.h>
+diff --git a/stellarsolver/astrometry/util/fitsioutils.c b/stellarsolver/astrometry/util/fitsioutils.c
+index 7451c36..f2b20bc 100644
+--- a/stellarsolver/astrometry/util/fitsioutils.c
++++ b/stellarsolver/astrometry/util/fitsioutils.c
+@@ -2,6 +2,9 @@
+ # This file is part of the Astrometry.net suite.
+ # Licensed under a 3-clause BSD style license - see LICENSE
+ */
++#ifdef __GNUC__ //# Modified by Robert Lancaster for the StellarSolver Internal Library
++#define __STDC_WANT_LIB_EXT2__ 1
++#endif
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdint.h>
+diff --git a/stellarsolver/astrometry/util/ioutils.c b/stellarsolver/astrometry/util/ioutils.c
+index ee17011..c490fb8 100644
+--- a/stellarsolver/astrometry/util/ioutils.c
++++ b/stellarsolver/astrometry/util/ioutils.c
+@@ -2,7 +2,9 @@
+ # This file is part of the Astrometry.net suite.
+ # Licensed under a 3-clause BSD style license - see LICENSE
+ */
+-
++#ifdef __GNUC__ //# Modified by Robert Lancaster for the StellarSolver Internal Library
++#define __STDC_WANT_LIB_EXT2__ 1
++#endif
+ #include <stdio.h>
+ #include <errno.h>
+ #include <string.h>
+diff --git a/stellarsolver/astrometry/util/log.c b/stellarsolver/astrometry/util/log.c
+index 256d5a1..1a2b8db 100644
+--- a/stellarsolver/astrometry/util/log.c
++++ b/stellarsolver/astrometry/util/log.c
+@@ -2,7 +2,9 @@
+ # This file is part of the Astrometry.net suite.
+ # Licensed under a 3-clause BSD style license - see LICENSE
+ */
+-
++#ifdef __GNUC__ //# Modified by Robert Lancaster for the StellarSolver Internal Library
++#define __STDC_WANT_LIB_EXT2__ 1
++#endif
+ #include <stdio.h>
+ #include <stdarg.h>
+ #include <stdlib.h>
diff --git a/sci-libs/stellarsolver/stellarsolver-2.2.ebuild b/sci-libs/stellarsolver/stellarsolver-2.2.ebuild
new file mode 100644
index 000000000000..3fd2a5f94878
--- /dev/null
+++ b/sci-libs/stellarsolver/stellarsolver-2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Cross-platform Sextractor and Astrometry.net-Based internal astrometric solver"
+HOMEPAGE="https://github.com/rlancaste/stellarsolver"
+SRC_URI="https://github.com/rlancaste/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ sci-libs/cfitsio:=
+ sci-libs/gsl:=
+ sci-astronomy/wcslib:=
+"
+DEPEND="${RDEPEND}"
+
+# https://github.com/rlancaste/stellarsolver/issues/108
+PATCHES=( "${FILESDIR}/${P}-fix-implicit-vasprintf-decl.patch" )
diff --git a/www-client/google-chrome/Manifest b/www-client/google-chrome/Manifest
index 082414dafa39..4f2980100783 100644
--- a/www-client/google-chrome/Manifest
+++ b/www-client/google-chrome/Manifest
@@ -1 +1 @@
-DIST google-chrome-stable_99.0.4844.82-1_amd64.deb 82974424 BLAKE2B 9f6982d6e83ae7e07e6c545094e2fae1eb162a2be6fd577dec089bc22f4ae1bc18ad72e2062659f5fb499b5e42634dd8a049bebb1e46159811001eb8e420df20 SHA512 e1c186ba889bf6af9bc56316f1f5286bd4c8072b12c3830f149a3e0873771ca122f3e11730100edf2e25862bc6d336825f4b831e7c14bf74789b4f9589281f28
+DIST google-chrome-stable_99.0.4844.84-1_amd64.deb 82967408 BLAKE2B b033e8ba6dc2334d1e45e723f74b32e0e31cf8d2c17c3326133cd38a60d7da8f3e4b9a216eaec1bca5cd51819e90981e12f434f08d93ef6baeb533d957ab8717 SHA512 925c283e4b4ebdb21c86873e23e9987cbdd6ef6b43fe006a75ddb46041c4d0c4e523a814b77c3a173f8f006c9efab84f2c18b3a22af9f05510c506248c889f70
diff --git a/www-client/google-chrome/google-chrome-99.0.4844.82.ebuild b/www-client/google-chrome/google-chrome-99.0.4844.84.ebuild
index 3af8d9e0922d..3af8d9e0922d 100644
--- a/www-client/google-chrome/google-chrome-99.0.4844.82.ebuild
+++ b/www-client/google-chrome/google-chrome-99.0.4844.84.ebuild
diff --git a/www-plugins/chrome-binary-plugins/Manifest b/www-plugins/chrome-binary-plugins/Manifest
index 3e45c3806cad..260a4c379a0f 100644
--- a/www-plugins/chrome-binary-plugins/Manifest
+++ b/www-plugins/chrome-binary-plugins/Manifest
@@ -1,3 +1,3 @@
DIST google-chrome-beta_100.0.4896.56-1_amd64.deb 83611996 BLAKE2B 7b4b3ecb5d9e7e8083833686e2cc329c2e456804b75604cd53177ec5847cf55aeafcb444f9c1e8a5907f2ad60e698779a936fadb0623b286485c11aa2e73b16f SHA512 06a317477d3a9efc6b7dbce053b930ddc483105bcaf72f3bac8cfc8f8d4bfd755261e7cbeca797bbb27edebbcda56b9e8054e1c9cd70c31c04f2003280268d7c
-DIST google-chrome-stable_99.0.4844.82-1_amd64.deb 82974424 BLAKE2B 9f6982d6e83ae7e07e6c545094e2fae1eb162a2be6fd577dec089bc22f4ae1bc18ad72e2062659f5fb499b5e42634dd8a049bebb1e46159811001eb8e420df20 SHA512 e1c186ba889bf6af9bc56316f1f5286bd4c8072b12c3830f149a3e0873771ca122f3e11730100edf2e25862bc6d336825f4b831e7c14bf74789b4f9589281f28
+DIST google-chrome-stable_99.0.4844.84-1_amd64.deb 82967408 BLAKE2B b033e8ba6dc2334d1e45e723f74b32e0e31cf8d2c17c3326133cd38a60d7da8f3e4b9a216eaec1bca5cd51819e90981e12f434f08d93ef6baeb533d957ab8717 SHA512 925c283e4b4ebdb21c86873e23e9987cbdd6ef6b43fe006a75ddb46041c4d0c4e523a814b77c3a173f8f006c9efab84f2c18b3a22af9f05510c506248c889f70
DIST google-chrome-unstable_101.0.4951.7-1_amd64.deb 84358668 BLAKE2B efc65d59dea8474c697f2c24349898995bd37370f2322e918226542b2ce04061633f1d358d42f5dd4bc36148e55f156c7be51dfb09afcfd359bc16431cdac41e SHA512 f26ed8f4cce75cb858536355320268bbdc1c2dab35505eb58c3e2b5cfd4915ff5776336d353074ce0b1447d9b22b63d02bd502df152220c1e801afe045778374
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-99.0.4844.82.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-99.0.4844.84.ebuild
index a8c4f73dffbd..a8c4f73dffbd 100644
--- a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-99.0.4844.82.ebuild
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-99.0.4844.84.ebuild