summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2023-12-17 11:01:51 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2023-12-17 11:01:51 +0000
commit4c9d222d3b148fed896d01575e00f2f4b7347ac3 (patch)
treef2c83c4d1b787998e324a1b98bcbc46c8fd8e690
parent2023-12-17 10:46:54 UTC (diff)
parentapp-editors/gvim: enable ruby32 (diff)
downloadgentoo-4c9d222d3b148fed896d01575e00f2f4b7347ac3.tar.gz
gentoo-4c9d222d3b148fed896d01575e00f2f4b7347ac3.tar.bz2
gentoo-4c9d222d3b148fed896d01575e00f2f4b7347ac3.zip
Merge updates from master
-rw-r--r--app-editors/gvim/gvim-9.0.2167.ebuild8
-rw-r--r--app-editors/vim/vim-9.0.2167.ebuild2
-rw-r--r--dev-db/qdbm/qdbm-1.8.78-r4.ebuild4
3 files changed, 7 insertions, 7 deletions
diff --git a/app-editors/gvim/gvim-9.0.2167.ebuild b/app-editors/gvim/gvim-9.0.2167.ebuild
index a136616f03f9..8c935fcb5164 100644
--- a/app-editors/gvim/gvim-9.0.2167.ebuild
+++ b/app-editors/gvim/gvim-9.0.2167.ebuild
@@ -11,7 +11,7 @@ VIM_PATCHES_VERSION="9.0.2092"
LUA_COMPAT=( lua5-{1..4} luajit )
PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="threads(+)"
-USE_RUBY="ruby27 ruby30 ruby31"
+USE_RUBY="ruby31 ruby32"
inherit bash-completion-r1 flag-o-matic lua-single prefix python-single-r1 ruby-single toolchain-funcs vim-doc xdg-utils
@@ -118,9 +118,9 @@ src_prepare() {
# Read vimrc and gvimrc from /etc/vim
echo '#define SYS_VIMRC_FILE "'${EPREFIX}'/etc/vim/vimrc"' \
- >> "${S}"/src/feature.h || die "echo failed"
+ >> "${S}"/src/feature.h || die "echo failed"
echo '#define SYS_GVIMRC_FILE "'${EPREFIX}'/etc/vim/gvimrc"' \
- >> "${S}"/src/feature.h || die "echo failed"
+ >> "${S}"/src/feature.h || die "echo failed"
# Use exuberant ctags which installs as /usr/bin/exuberant-ctags.
# Hopefully this pattern won't break for a while at least.
@@ -138,7 +138,7 @@ src_prepare() {
# which isn't even in the source file being invalid, we'll do some trickery
# to make the error never occur. bug 66162 (02 October 2004 ciaranm)
find "${S}" -name '*.c' | while read c; do
- echo >> "$c" || die "echo failed"
+ echo >> "$c" || die "echo failed"
done
# Try to avoid sandbox problems. Bug #114475.
diff --git a/app-editors/vim/vim-9.0.2167.ebuild b/app-editors/vim/vim-9.0.2167.ebuild
index fa9f884f8193..854c1a5ce766 100644
--- a/app-editors/vim/vim-9.0.2167.ebuild
+++ b/app-editors/vim/vim-9.0.2167.ebuild
@@ -11,7 +11,7 @@ VIM_PATCHES_VERSION="9.0.2092"
LUA_COMPAT=( lua5-{1..4} luajit )
PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="threads(+)"
-USE_RUBY="ruby27 ruby30 ruby31"
+USE_RUBY="ruby31 ruby32"
inherit vim-doc flag-o-matic bash-completion-r1 lua-single python-single-r1 ruby-single toolchain-funcs desktop xdg-utils
diff --git a/dev-db/qdbm/qdbm-1.8.78-r4.ebuild b/dev-db/qdbm/qdbm-1.8.78-r4.ebuild
index 43796938adc8..f1ea111f2075 100644
--- a/dev-db/qdbm/qdbm-1.8.78-r4.ebuild
+++ b/dev-db/qdbm/qdbm-1.8.78-r4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
-USE_RUBY="ruby27 ruby30 ruby31"
+USE_RUBY="ruby31 ruby32"
RUBY_OPTIONAL="yes"
inherit autotools flag-o-matic java-pkg-opt-2 perl-functions ruby-ng