summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-13 22:38:10 +0000
committerSam James <sam@gentoo.org>2023-03-13 22:45:06 +0000
commit4e7bd768ddd549a9518fc9e55fa6ec948fff7c16 (patch)
tree86b71ebdc1d4cf0d4c857ae9fa58499a3109a144
parentnet-libs/nghttp2: sync live ebuild (diff)
downloadgentoo-4e7bd768ddd549a9518fc9e55fa6ec948fff7c16.tar.gz
gentoo-4e7bd768ddd549a9518fc9e55fa6ec948fff7c16.tar.bz2
gentoo-4e7bd768ddd549a9518fc9e55fa6ec948fff7c16.zip
dev-util/ccache: avoid verify-sig for doc tarball
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/ccache/ccache-4.8.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-util/ccache/ccache-4.8.ebuild b/dev-util/ccache/ccache-4.8.ebuild
index b57b66d696ce..f839a350fcda 100644
--- a/dev-util/ccache/ccache-4.8.ebuild
+++ b/dev-util/ccache/ccache-4.8.ebuild
@@ -59,6 +59,15 @@ PATCHES=(
"${FILESDIR}"/${PN}-4.0-objdump.patch
)
+src_unpack() {
+ # Avoid aborting on the doc tarball
+ if use verify-sig ; then
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.asc}
+ fi
+
+ default
+}
+
src_prepare() {
cmake_src_prepare