summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-06-19 19:02:56 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-06-19 19:02:56 +0000
commit51b1ae8e0ce68b38fb8428e4552bd84456b5119a (patch)
tree45bb03c2c4304d59798c4097e410306387c0303f
parent2022-06-19 18:33:01 UTC (diff)
parentdev-python/moto: add 3.1.14 (diff)
downloadgentoo-51b1ae8e0ce68b38fb8428e4552bd84456b5119a.tar.gz
gentoo-51b1ae8e0ce68b38fb8428e4552bd84456b5119a.tar.bz2
gentoo-51b1ae8e0ce68b38fb8428e4552bd84456b5119a.zip
Merge updates from master
-rw-r--r--app-doc/xmltoman/xmltoman-0.4-r2.ebuild (renamed from app-doc/xmltoman/xmltoman-0.4-r1.ebuild)10
-rw-r--r--app-shells/gentoo-bashcomp/Manifest1
-rw-r--r--app-shells/gentoo-bashcomp/gentoo-bashcomp-20180302.ebuild22
-rw-r--r--app-shells/gentoo-bashcomp/gentoo-bashcomp-20190211-r1.ebuild (renamed from app-shells/gentoo-bashcomp/gentoo-bashcomp-20190211.ebuild)4
-rw-r--r--dev-libs/libIDL/libIDL-0.8.14-r3.ebuild (renamed from dev-libs/libIDL/libIDL-0.8.14-r2.ebuild)16
-rw-r--r--dev-libs/librevenge/librevenge-0.0.4-r2.ebuild (renamed from dev-libs/librevenge/librevenge-0.0.4-r1.ebuild)39
-rw-r--r--dev-libs/librevenge/librevenge-9999.ebuild14
-rw-r--r--dev-python/moto/Manifest1
-rw-r--r--dev-python/moto/moto-3.1.14.ebuild90
-rw-r--r--sys-devel/automake-wrapper/automake-wrapper-11-r1.ebuild (renamed from sys-devel/automake-wrapper/automake-wrapper-11.ebuild)11
-rw-r--r--sys-devel/bc/bc-1.07.1-r4.ebuild (renamed from sys-devel/bc/bc-1.07.1-r3.ebuild)28
-rw-r--r--sys-devel/bc/metadata.xml8
12 files changed, 149 insertions, 95 deletions
diff --git a/app-doc/xmltoman/xmltoman-0.4-r1.ebuild b/app-doc/xmltoman/xmltoman-0.4-r2.ebuild
index 9a5c39b406ac..efb9811d3457 100644
--- a/app-doc/xmltoman/xmltoman-0.4-r1.ebuild
+++ b/app-doc/xmltoman/xmltoman-0.4-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="Simple scripts for converting xml to groff or html"
HOMEPAGE="https://sourceforge.net/projects/xmltoman/"
@@ -10,18 +10,20 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE=""
-RDEPEND="dev-lang/perl
+RDEPEND="
+ dev-lang/perl
dev-perl/XML-Parser"
-DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
src_install() {
# 'make install' requires GNU install, upstream is dead and carrying
# a patch is more space than redoing it here
dobin xmltoman xmlmantohtml
+
insinto /usr/share/xmltoman
doins xmltoman.{css,dtd,xsl}
+
dodoc README
doman xmltoman.1 xmlmantohtml.1
}
diff --git a/app-shells/gentoo-bashcomp/Manifest b/app-shells/gentoo-bashcomp/Manifest
index d4cd85627218..fb85b8f9d37d 100644
--- a/app-shells/gentoo-bashcomp/Manifest
+++ b/app-shells/gentoo-bashcomp/Manifest
@@ -1,2 +1 @@
-DIST gentoo-bashcomp-20180302.tar.bz2 21485 BLAKE2B 887ac5cfa8c6ba431a6aa5f5918b8bdfbe6a1ae9a2e7ac21b3c06ec2062b448d924f928b1372e81749ece6d4aa673bbbaaa364ca744124c842e3819349917169 SHA512 6b4551b078505e6348cb10ca2d67faab4d323a0f0ddefc872145314303d6f95fe31f9706d43d9f20c0139610ce47e4cf70ba7516d911dc4927cfbf5d863bc063
DIST gentoo-bashcomp-20190211.tar.bz2 21508 BLAKE2B 410994819f62b0bd105ca398c335d76993fd694b8e7f56c761b94fc1e2f6e90f2010f2f2a88febd71ac0c5643fc0e923c60151fbf9411e8a553b5917d6bcd8db SHA512 4b0a5e79f90ee8122fa8d0a7224fee6472b1762a0dda680ea1c0e8d4069760be9b6472e052b1b166a389c0e779816b98715386dbc62a3574e7ad851b2567a070
diff --git a/app-shells/gentoo-bashcomp/gentoo-bashcomp-20180302.ebuild b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20180302.ebuild
deleted file mode 100644
index 64f152cbe4fd..000000000000
--- a/app-shells/gentoo-bashcomp/gentoo-bashcomp-20180302.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit bash-completion-r1
-
-DESCRIPTION="Gentoo-specific bash command-line completions (emerge, ebuild, equery, etc)"
-HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
-SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris"
-IUSE=""
-
-src_install() {
- emake DESTDIR="${D}" install \
- completionsdir="$(get_bashcompdir)" \
- helpersdir="$(get_bashhelpersdir)" \
- compatdir="${EPREFIX}/etc/bash_completion.d"
-}
diff --git a/app-shells/gentoo-bashcomp/gentoo-bashcomp-20190211.ebuild b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20190211-r1.ebuild
index 6c802bbf31f7..8e4ce74b2707 100644
--- a/app-shells/gentoo-bashcomp/gentoo-bashcomp-20190211.ebuild
+++ b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20190211-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit bash-completion-r1
diff --git a/dev-libs/libIDL/libIDL-0.8.14-r2.ebuild b/dev-libs/libIDL/libIDL-0.8.14-r3.ebuild
index b8846164f94a..6f9443f5ab35 100644
--- a/dev-libs/libIDL/libIDL-0.8.14-r2.ebuild
+++ b/dev-libs/libIDL/libIDL-0.8.14-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-GNOME_TARBALL_SUFFIX="bz2"
+EAPI=8
+GNOME_TARBALL_SUFFIX="bz2"
inherit gnome2 multilib-minimal
DESCRIPTION="CORBA tree builder"
@@ -12,18 +12,16 @@ HOMEPAGE="https://www.gnome.org/"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
-IUSE=""
RDEPEND=">=dev-libs/glib-2.44.1-r1:2[${MULTILIB_USEDEP}]"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
sys-devel/flex
virtual/yacc
- virtual/pkgconfig
-"
+ virtual/pkgconfig"
multilib_src_configure() {
- local ECONF_SOURCE="${S}"
- gnome2_src_configure --disable-static
+ ECONF_SOURCE="${S}" gnome2_src_configure
}
multilib_src_compile() {
diff --git a/dev-libs/librevenge/librevenge-0.0.4-r1.ebuild b/dev-libs/librevenge/librevenge-0.0.4-r2.ebuild
index 14145f8a95a9..8859233f807d 100644
--- a/dev-libs/librevenge/librevenge-0.0.4-r1.ebuild
+++ b/dev-libs/librevenge/librevenge-0.0.4-r2.ebuild
@@ -1,52 +1,47 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit flag-o-matic multilib-minimal
+inherit multilib-minimal
-DESCRIPTION="A helper library for REVerse ENGineered formats filters"
-HOMEPAGE="https://sf.net/p/libwpd/librevenge"
if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="git://git.code.sf.net/p/libwpd/librevenge"
+ EGIT_REPO_URI="https://git.code.sf.net/p/libwpd/librevenge"
inherit git-r3 autotools
else
SRC_URI="https://sf.net/projects/libwpd/files/${PN}/${P}/${P}.tar.xz"
KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~sparc x86"
fi
+DESCRIPTION="Helper library for REVerse ENGineered formats filters"
+HOMEPAGE="https://sf.net/p/libwpd/librevenge"
+
LICENSE="|| ( MPL-2.0 LGPL-2.1 )"
SLOT="0"
IUSE="doc test"
RESTRICT="!test? ( test )"
-RDEPEND="
- sys-libs/zlib[${MULTILIB_USEDEP}]
-"
+RDEPEND="sys-libs/zlib[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}
dev-libs/boost
- doc? ( app-doc/doxygen )
- test? ( dev-util/cppunit[${MULTILIB_USEDEP}] )
-"
+ test? ( dev-util/cppunit[${MULTILIB_USEDEP}] )"
+BDEPEND="doc? ( app-doc/doxygen )"
src_prepare() {
default
- [[ ${PV} = *9999 ]] && eautoreconf
-
- # bug 651264
- append-cxxflags -std=c++11
+ [[ ${PV} == *9999 ]] && eautoreconf
}
multilib_src_configure() {
- ECONF_SOURCE=${S} \
- econf \
- --disable-static \
- --disable-werror \
- $(use_with doc docs) \
+ local myeconfargs=(
+ --disable-werror
+ $(use_with doc docs)
$(use_enable test tests)
+ )
+ ECONF_SOURCE=${S} econf "${myeconfargs[@]}"
}
multilib_src_install_all() {
einstalldocs
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -type f -delete || die
}
diff --git a/dev-libs/librevenge/librevenge-9999.ebuild b/dev-libs/librevenge/librevenge-9999.ebuild
index eff06c57664d..1507cf6e091a 100644
--- a/dev-libs/librevenge/librevenge-9999.ebuild
+++ b/dev-libs/librevenge/librevenge-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit flag-o-matic multilib-minimal
+inherit multilib-minimal
-if [[ ${PV} == *9999* ]] ; then
+if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://git.code.sf.net/p/libwpd/librevenge"
inherit git-r3 autotools
else
@@ -19,19 +19,17 @@ HOMEPAGE="https://sf.net/p/libwpd/librevenge"
LICENSE="|| ( MPL-2.0 LGPL-2.1 )"
SLOT="0"
IUSE="doc test"
-
RESTRICT="!test? ( test )"
RDEPEND="sys-libs/zlib[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}
dev-libs/boost
- test? ( dev-util/cppunit[${MULTILIB_USEDEP}] )
-"
+ test? ( dev-util/cppunit[${MULTILIB_USEDEP}] )"
BDEPEND="doc? ( app-doc/doxygen )"
src_prepare() {
default
- [[ ${PV} == *9999* ]] && eautoreconf
+ [[ ${PV} == *9999 ]] && eautoreconf
}
multilib_src_configure() {
@@ -45,5 +43,5 @@ multilib_src_configure() {
multilib_src_install_all() {
einstalldocs
- find "${D}" -name '*.la' -type f -delete || die
+ find "${ED}" -name '*.la' -type f -delete || die
}
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index ec3bc288b459..1f2713591b81 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -2,4 +2,5 @@ DIST moto-3.1.10.tar.gz 2314423 BLAKE2B ad09f8cb70a1541dce640c870355c349f9a932be
DIST moto-3.1.11.tar.gz 2320905 BLAKE2B 14cd572defd974e428a77f75be32f576d7cb222fa80a37b5f72bdb8f10fd36be3b456d7d660fe7943862824393b48b4d70687dde191ffc49a49db7ee05772994 SHA512 2e1a84beef161442f74dee95b1e5dc7b23c77d9b001c27b0d8ee3c429c5da13be9a6d0074bc26bacad72f5ea82b0eb85e88dd2adb585f7dfd688bd1e3d9cc5e9
DIST moto-3.1.12.tar.gz 2323555 BLAKE2B f2ecefc5dbbc3f4ce66a799ec255cad40ce466f62fe3bfb0885866c7d0125884a0fef299b58fdcf1cb5da7ef58ac513d844b2fbae6d6545dcb38f2a3bbb2cda4 SHA512 29b8d0d71f3227784eddd05959434451ad88c9c0346b3684360e57bd3df8b9734f781d263bf992ac946749c88b433f6c86c1fc71d71a2dc565633c812579c297
DIST moto-3.1.13.tar.gz 2330638 BLAKE2B ded004bcd783f623edd5b198c39b0245bc847233be46e101b8556adf71c8a7495a175957b3c5c475ca66c392df0999f53c8cedbb439cbb39cd5566e610887cc2 SHA512 95708e6638ab9a8d68b1acaf3af14fc381584e2d978d7f03ee500c50cd2b3409d99633f0e211bfb86c40335e67581f9e6ff3dc7934f8e91fc9f8be8311de8b5b
+DIST moto-3.1.14.tar.gz 2340613 BLAKE2B 8bdd9131449c2f3aeb1e4b4fcf40fe2d7ffac86777a73bcdff1d04a3450ec71030e5611c1d3d7429fd57e7ebc0791aecca4c57b8fb12456d18f2256693387fa0 SHA512 3a07e4f15a70ec422f81ba8cf5e2f38624981ff809e7ec51a3e23e26f3dff1755aa11d236daac097da0961948a46cc93e549e36102fbd8d5036f419d5fc96312
DIST moto-3.1.9.tar.gz 2308059 BLAKE2B 85f5c084fc81d74e8297ab0a78e3823bb6e98b1d4fdb70b802dabfa3ba11475670c3bfda27f48069e5298691a8ca71c98acf156c3b15ab79ff85555545c7596e SHA512 600ec2042e5e6df5e3bbc9fafcaa32255568c35a2a127e4f093ecc9332a799b568002cb414e5c086f24795c4f8f510517bf00c29a9b6a38dd667807d04a18954
diff --git a/dev-python/moto/moto-3.1.14.ebuild b/dev-python/moto/moto-3.1.14.ebuild
new file mode 100644
index 000000000000..d32692d1217f
--- /dev/null
+++ b/dev-python/moto/moto-3.1.14.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="https://github.com/spulec/moto"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-python-0.93[${PYTHON_USEDEP}]
+ dev-python/boto[${PYTHON_USEDEP}]
+ dev-python/cfn-lint[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3.0.7[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.2.8[${PYTHON_USEDEP}]
+ dev-python/pretty-yaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/python-sshpubkeys[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_firehose/test_firehose_put.py::test_put_record_http_destination
+ tests/test_firehose/test_firehose_put.py::test_put_record_batch_http_destination
+ tests/test_swf/responses/test_decision_tasks.py::test_respond_decision_task_completed_with_schedule_activity_task_boto3
+ tests/test_swf/responses/test_timeouts.py::test_activity_task_heartbeat_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_decision_task_start_to_close_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_workflow_execution_start_to_close_timeout_boto3
+ # broken code (local variable used referenced before definition)
+ tests/test_appsync/test_appsync_schema.py
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_batch/test_batch_jobs.py::test_terminate_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_pending_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_running_job
+ tests/test_batch/test_batch_jobs.py::test_dependencies
+ tests/test_batch/test_batch_jobs.py::test_container_overrides
+ tests/test_cloudformation/test_cloudformation_custom_resources.py::test_create_custom_lambda_resource__verify_cfnresponse_failed
+ tests/test_cloudformation/test_cloudformation_stack_integration.py::test_lambda_function
+ tests/test_events/test_events_lambdatriggers_integration.py::test_creating_bucket__invokes_lambda
+ tests/test_sqs/test_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_exception
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events0-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events1-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events3-ObjectCreated:Put]"
+ )
+
+ # pytest-django causes freezegun try to mangle stuff inside django
+ # which fails when django is not really used
+ epytest -p no:django -m 'not network'
+}
diff --git a/sys-devel/automake-wrapper/automake-wrapper-11.ebuild b/sys-devel/automake-wrapper/automake-wrapper-11-r1.ebuild
index c373025d175d..e65eb87b26c7 100644
--- a/sys-devel/automake-wrapper/automake-wrapper-11.ebuild
+++ b/sys-devel/automake-wrapper/automake-wrapper-11-r1.ebuild
@@ -1,17 +1,15 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
DESCRIPTION="wrapper for automake to manage multiple automake versions"
HOMEPAGE="https://gitweb.gentoo.org/proj/autotools-wrappers.git"
+S="${WORKDIR}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-S=${WORKDIR}
src_unpack() {
cp "${FILESDIR}"/am-wrapper-${PV}.sh "${S}"/ || die
@@ -22,13 +20,12 @@ src_prepare() {
# usr/bin/aclocal: bad substitution -> /bin/sh != POSIX shell
if use prefix ; then
- sed -i -e '1c\#!'"${EPREFIX}"'/bin/sh' \
- "${S}"/am-wrapper-${PV}.sh || die
+ sed -i -e '1c\#!'"${EPREFIX}"'/bin/sh' am-wrapper-${PV}.sh || die
fi
}
src_install() {
- newbin "${S}"/am-wrapper-${PV}.sh automake
+ newbin am-wrapper-${PV}.sh automake
dosym automake /usr/bin/aclocal
keepdir /usr/share/aclocal
diff --git a/sys-devel/bc/bc-1.07.1-r3.ebuild b/sys-devel/bc/bc-1.07.1-r4.ebuild
index ae9a4a678054..b0ba700abde5 100644
--- a/sys-devel/bc/bc-1.07.1-r3.ebuild
+++ b/sys-devel/bc/bc-1.07.1-r4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
inherit flag-o-matic toolchain-funcs
@@ -17,25 +17,21 @@ IUSE="libedit readline static"
RDEPEND="
!readline? ( libedit? ( dev-libs/libedit:= ) )
readline? (
- >=sys-libs/readline-4.1:0=
- >=sys-libs/ncurses-5.2:=
- )
-"
-DEPEND="
- ${RDEPEND}
+ sys-libs/readline:=
+ sys-libs/ncurses:=
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="
sys-devel/flex
- virtual/yacc
-"
+ virtual/yacc"
-PATCHES=(
- "${FILESDIR}/${PN}-1.07.1-no-ed-its-sed.patch"
-)
+PATCHES=( "${FILESDIR}"/${PN}-1.07.1-no-ed-its-sed.patch )
src_prepare() {
default
- # Avoid bad build tool usage when cross-compiling. #627126
- tc-is-cross-compiler && eapply "${FILESDIR}/${PN}-1.07.1-use-system-bc.patch"
+ # Avoid bad build tool usage when cross-compiling. Bug #627126
+ tc-is-cross-compiler && eapply "${FILESDIR}"/${PN}-1.07.1-use-system-bc.patch
}
src_configure() {
@@ -52,8 +48,8 @@ src_configure() {
econf "${myconf[@]}"
# Do not regen docs -- configure produces a small fragment that includes
- # the version info which causes all pages to regen (newer file). #554774
- touch -r doc doc/*
+ # the version info which causes all pages to regen (newer file). Bug #554774
+ touch -r doc doc/* || die
}
src_compile() {
diff --git a/sys-devel/bc/metadata.xml b/sys-devel/bc/metadata.xml
index 73dda144f9ac..b0d83aa2e489 100644
--- a/sys-devel/bc/metadata.xml
+++ b/sys-devel/bc/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>base-system@gentoo.org</email>
- <name>Gentoo Base System</name>
-</maintainer>
+ <maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+ </maintainer>
</pkgmetadata>