summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-02-15 01:22:17 +1000
committerMatt Jolly <kangie@gentoo.org>2024-02-15 01:24:24 +1000
commit53acd112770fb3a953131848b481f5a3dc15773d (patch)
treea0a1575f2e2379daf068c524295cadcc678a62da
parentapp-arch/zchunk: update maintainers (diff)
downloadgentoo-53acd112770fb3a953131848b481f5a3dc15773d.tar.gz
gentoo-53acd112770fb3a953131848b481f5a3dc15773d.tar.bz2
gentoo-53acd112770fb3a953131848b481f5a3dc15773d.zip
app-arch/zchunk: add 1.4.0
Signed-off-by: Matt Jolly <kangie@gentoo.org>
-rw-r--r--app-arch/zchunk/Manifest1
-rw-r--r--app-arch/zchunk/zchunk-1.4.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-arch/zchunk/Manifest b/app-arch/zchunk/Manifest
index 43c8549fedd5..3ea0402f20fb 100644
--- a/app-arch/zchunk/Manifest
+++ b/app-arch/zchunk/Manifest
@@ -1 +1,2 @@
DIST zchunk-1.3.2.tar.gz 1508683 BLAKE2B a8b866d28e3a0f5bf5fda3b44f5f1d0589c374dd700d8c64497d729758e35ed1215367ff8b1114e436a776a419f1aa329f429016981f11c19fd0896db3520811 SHA512 32f3167db747a494373c03941450e8b6b7eb6ad6a07633ccb9dbd3176ffb79073746bbdf3f132605ad51de23b3b20434d1580cf7cd72e0b658263bb32359f5bc
+DIST zchunk-1.4.0.tar.gz 1513670 BLAKE2B 97fa848f7f760874f4a521153983fb8263680ff57f04644ed124aa1c81fcb36d068d489c83bd95e2e4e70efa79892a835c10be8b61a3674550e8218f23852ac4 SHA512 7fbe50182d46e4e8ce8730959cd97ea39b48dd77d034303435ce15caec194409984d435167d3b55769577d6be6c539573eddd9351f178377a756babc508d6281
diff --git a/app-arch/zchunk/zchunk-1.4.0.ebuild b/app-arch/zchunk/zchunk-1.4.0.ebuild
new file mode 100644
index 000000000000..0759ca5b2011
--- /dev/null
+++ b/app-arch/zchunk/zchunk-1.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="File format designed for highly efficient deltas with good compression"
+HOMEPAGE="https://github.com/zchunk/zchunk"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zchunk/zchunk.git"
+else
+ SRC_URI="https://github.com/zchunk/zchunk/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ app-arch/zstd:=
+ net-misc/curl
+ dev-libs/openssl:=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+
+ meson_src_configure
+}