summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gmail.com>2021-08-09 16:00:20 +0300
committerMichał Górny <mgorny@gentoo.org>2021-08-13 22:41:20 +0200
commit54fde09d94d23abdf569b4abb87af725372696a0 (patch)
tree104edc68a0e7a1ebd0e3987d79652dfd48b1bffe
parentdev-python/plumbum: fix SRC_URI (diff)
downloadgentoo-54fde09d94d23abdf569b4abb87af725372696a0.tar.gz
gentoo-54fde09d94d23abdf569b4abb87af725372696a0.tar.bz2
gentoo-54fde09d94d23abdf569b4abb87af725372696a0.zip
dev-python/plumbum: enable py3.10, fix deps, cleanup
- add pytest-timeout test dependency, used during testing - remove patch and use pytest deselect Signed-off-by: Arthur Zamarin <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/plumbum/files/plumbum-1.7.0-test.patch34
-rw-r--r--dev-python/plumbum/plumbum-1.7.0-r1.ebuild41
2 files changed, 27 insertions, 48 deletions
diff --git a/dev-python/plumbum/files/plumbum-1.7.0-test.patch b/dev-python/plumbum/files/plumbum-1.7.0-test.patch
deleted file mode 100644
index a79c5f67d18a..000000000000
--- a/dev-python/plumbum/files/plumbum-1.7.0-test.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-diff -r -U2 plumbum-1.7.0.orig/setup.cfg plumbum-1.7.0/setup.cfg
---- plumbum-1.7.0.orig/setup.cfg 2021-02-09 02:46:57.071159800 +0700
-+++ plumbum-1.7.0/setup.cfg 2021-03-15 15:51:13.873287602 +0700
-@@ -66,5 +66,4 @@
-
- [tool:pytest]
--addopts = -v -ra --cov-config=setup.cfg
- norecursedirs = examples experiments
- timeout = 300
-diff -r -U2 plumbum-1.7.0.orig/tests/test_env.py plumbum-1.7.0/tests/test_env.py
---- plumbum-1.7.0.orig/tests/test_env.py 2021-02-09 02:46:46.000000000 +0700
-+++ plumbum-1.7.0/tests/test_env.py 2021-03-15 15:50:18.943289430 +0700
-@@ -14,4 +14,5 @@
- @skip_on_windows
- class TestEnv:
-+ @pytest.mark.skip("Something wrong here")
- def test_change_env(self):
- with local.env(silly=12):
-@@ -23,4 +24,5 @@
- assert len(local.env) == len(actual)
-
-+ @pytest.mark.skip("Something wrong here")
- def test_dictlike(self):
- keys = {x.split("=")[0] for x in printenv().splitlines() if "=" in x}
-diff -r -U2 plumbum-1.7.0.orig/tests/test_local.py plumbum-1.7.0/tests/test_local.py
---- plumbum-1.7.0.orig/tests/test_local.py 2021-02-09 02:46:46.000000000 +0700
-+++ plumbum-1.7.0/tests/test_local.py 2021-03-15 15:50:18.943289430 +0700
-@@ -168,5 +168,5 @@
- assert parts == ("/", "some", "long", "path", "to", "file.txt")
-
-- @pytest.mark.usefixtures("testdir")
-+ @pytest.mark.skip("Something wrong here")
- def test_iterdir(self):
- cwd = local.path(".")
diff --git a/dev-python/plumbum/plumbum-1.7.0-r1.ebuild b/dev-python/plumbum/plumbum-1.7.0-r1.ebuild
index 59aac2a17d01..09603ad72375 100644
--- a/dev-python/plumbum/plumbum-1.7.0-r1.ebuild
+++ b/dev-python/plumbum/plumbum-1.7.0-r1.ebuild
@@ -2,33 +2,46 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 optfeature
DESCRIPTION="A library for shell script-like programs in python"
HOMEPAGE="https://plumbum.readthedocs.io/en/latest/ https://github.com/tomerfiliba/plumbum"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}] )"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-PATCHES=( "${FILESDIR}"/${PN}-1.7.0-test.patch )
+
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )"
+
distutils_enable_tests pytest
src_prepare() {
+ sed -e '/addopts/d' -i setup.cfg || die
distutils-r1_src_prepare
+}
- # Need sshd running
- rm tests/test_remote.py || die "rm test_remote.py failed"
- rm tests/test_utils.py || die "rm test_utils.py failed"
- rm tests/_test_paramiko.py || die "rm _test_paramiko.py failed"
- # Windows specific
- rm tests/test_putty.py || die "rm test_putty.py failed"
- # Needs sudo without password
- rm tests/test_sudo.py || die "rm test_sudo.py failed"
+python_test() {
+ local deselect=(
+ # Need sshd running
+ tests/test_remote.py
+ tests/test_utils.py
+ # Windows specific
+ tests/test_putty.py
+ # Needs sudo without password
+ tests/test_sudo.py
+ # Wrong assumptions about env handling
+ tests/test_env.py::TestEnv::test_change_env
+ tests/test_env.py::TestEnv::test_dictlike
+ tests/test_local.py::TestLocalPath::test_iterdir
+ )
+ epytest ${deselect[@]/#/--deselect }
}
pkg_postinst() {